aboutsummaryrefslogtreecommitdiff
path: root/net/linc
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-02-14 01:37:45 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-02-14 01:37:45 +0000
commit4bad7f6ed09a5ba35cabc35ffca7563502d608d9 (patch)
tree8533dade5ede284e79c8ac8d9cf59b18c4628171 /net/linc
parentf8d30394bf9c653092a2577442833df3814b8ec4 (diff)
downloadports-4bad7f6ed09a5ba35cabc35ffca7563502d608d9.tar.gz
ports-4bad7f6ed09a5ba35cabc35ffca7563502d608d9.zip
Use version of the patch-ltmain.sh which doesn't strip -pthread flags
when linking shared libraries. Bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=54680
Diffstat (limited to 'net/linc')
-rw-r--r--net/linc/Makefile1
-rw-r--r--net/linc/files/patch-ltmain.sh25
2 files changed, 22 insertions, 4 deletions
diff --git a/net/linc/Makefile b/net/linc/Makefile
index a7f35962c834..93293c496fe2 100644
--- a/net/linc/Makefile
+++ b/net/linc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= linc
PORTVERSION= 0.1.16
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-alpha2
diff --git a/net/linc/files/patch-ltmain.sh b/net/linc/files/patch-ltmain.sh
index 98cb05e4ddb3..91713d2306f8 100644
--- a/net/linc/files/patch-ltmain.sh
+++ b/net/linc/files/patch-ltmain.sh
@@ -1,9 +1,26 @@
$FreeBSD$
---- ltmain.sh 2001/08/27 09:51:26 1.1
-+++ ltmain.sh 2001/08/27 09:51:42
-@@ -2408,6 +2408,9 @@
+--- ltmain.sh.orig Wed Jan 23 11:38:40 2002
++++ ltmain.sh Sun Feb 3 01:44:17 2002
+@@ -1037,8 +1037,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -2412,6 +2420,9 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
@@ -13,7 +30,7 @@ $FreeBSD$
*)
# Add libc to deplibs on all other systems if necessary.
if test "$build_libtool_need_lc" = "yes"; then
-@@ -4175,10 +4178,12 @@
+@@ -4179,10 +4190,12 @@
fi
# Install the pseudo-library for information purposes.