aboutsummaryrefslogtreecommitdiff
path: root/net/py-errbot/Makefile
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-25 13:01:07 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-25 13:37:07 +0000
commit6b0f06d75b1da4fcf9147a8382fbfddaf63f183a (patch)
tree3f248d35090520ff96ed76620c7cf642fa4ef8c1 /net/py-errbot/Makefile
parentba05a586f0c5a56b2878be94c8b0476c5b0955b7 (diff)
downloadports-6b0f06d75b1da4fcf9147a8382fbfddaf63f183a.tar.gz
ports-6b0f06d75b1da4fcf9147a8382fbfddaf63f183a.zip
net/py-errbot: Add IRC, SLACK_RTM, TELEGRAM and XMPP options
Diffstat (limited to 'net/py-errbot/Makefile')
-rw-r--r--net/py-errbot/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/net/py-errbot/Makefile b/net/py-errbot/Makefile
index ef6775f80016..664ff28a462c 100644
--- a/net/py-errbot/Makefile
+++ b/net/py-errbot/Makefile
@@ -30,4 +30,17 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+OPTIONS_DEFINE= IRC SLACK_RTM TELEGRAM XMPP
+IRC_DESC= IRC messaging support
+SLACK-RTM_DESC= Slack messaging support
+TELEGRAM_DESC= Telegram messaging support
+XMPP_DESC= XMPP messaging support
+
+IRC_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}irc>=0:irc/py-irc@${PY_FLAVOR}
+SLACK-RTM_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}slackclient>=2.0:net-im/py-slackclient@${PY_FLAVOR}
+TELEGRAM_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-telegram-bot>=0:net-im/py-python-telegram-bot@${PY_FLAVOR}
+XMPP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>=0:devel/py-pyasn1@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyasn1-modules>=0:devel/py-pyasn1-modules@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}slixmpp>=0:net-im/py-slixmpp@${PY_FLAVOR}
+
.include <bsd.port.mk>