aboutsummaryrefslogtreecommitdiff
path: root/net/radiator/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2015-09-23 01:33:50 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2015-09-23 01:33:50 +0000
commit4d88e8c0fadb73d834b6d840a7229efc0f8de754 (patch)
treeaa597495827858bd9560c9ca6f598bcd9f7392c4 /net/radiator/Makefile
parentd40787583d69a422f21dd341cdf864daf86cb8fe (diff)
downloadports-4d88e8c0fadb73d834b6d840a7229efc0f8de754.tar.gz
ports-4d88e8c0fadb73d834b6d840a7229efc0f8de754.zip
1: Upgrade to 4.14.
2: install rc file. 3: install some sample config files. 4: sort pkg-plist. Approved by: maintainer
Notes
Notes: svn path=/head/; revision=397602
Diffstat (limited to 'net/radiator/Makefile')
-rw-r--r--net/radiator/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/net/radiator/Makefile b/net/radiator/Makefile
index a11230c63110..876bfd24a8dd 100644
--- a/net/radiator/Makefile
+++ b/net/radiator/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= Radiator
-PORTVERSION= 4.13
-PORTREVISION= 2
+PORTVERSION= 4.14
CATEGORIES= net
MASTER_SITES= # fetch manually
DIST_SUBDIR= ${PORTNAME}
@@ -16,6 +15,7 @@ MYSQL_DESC= MySQL support
USES= perl5 tar:tgz
USE_PERL5= configure
+USE_RC_SUBR= radiator
RESTRICTED= Commercial software
@@ -40,4 +40,15 @@ pre-configure:
${TAR} -xvzf ${DISTDIR}/${DIST_SUBDIR}/patches-${PORTVERSION}.tar.gz -C ${WRKSRC}
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/radius.cfg
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/radiator
+ ${INSTALL_DATA} ${WRKSRC}/radius.cfg ${STAGEDIR}${PREFIX}/etc/radiator/radius.cfg.sample
+ ${INSTALL_DATA} ${WRKSRC}/dictionary ${STAGEDIR}${PREFIX}/etc/radiator
+ ${INSTALL_DATA} ${WRKSRC}/dictionary.ascend ${STAGEDIR}${PREFIX}/etc/radiator
+ ${INSTALL_DATA} ${WRKSRC}/dictionary.cisco-vpn ${STAGEDIR}${PREFIX}/etc/radiator
+ ${INSTALL_DATA} ${WRKSRC}/dictionary.sip ${STAGEDIR}${PREFIX}/etc/radiator
+
.include <bsd.port.post.mk>