aboutsummaryrefslogtreecommitdiff
path: root/net/tclsoap
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-06-19 09:01:15 +0000
committerJohn Marino <marino@FreeBSD.org>2014-06-19 09:01:15 +0000
commit1a4672f9fe7619ff057792b6cbe6a06588aacbce (patch)
treee64eb31f55f73ace8b5ba5a6a559ab6b17a823a1 /net/tclsoap
parent74a09dfd9412fda7281dcfe0c7163fede9541be2 (diff)
downloadports-1a4672f9fe7619ff057792b6cbe6a06588aacbce.tar.gz
ports-1a4672f9fe7619ff057792b6cbe6a06588aacbce.zip
Add net port net/tclsoap (after 1.5 year wait)
This PR was submitted 5 January 2013. It suffered a bit of bitrot, but staging worked out of the box. I made some minor adjustments. PR: 174988 Submitted by: Sebastien Santoro ================================================================ tclsoap provides support for building clients and servers for the SOAP remote procedure call protocol from Tcl. SOAP is an XML based RPC mechanism which provides cross-platform cross language compatability.
Notes
Notes: svn path=/head/; revision=358367
Diffstat (limited to 'net/tclsoap')
-rw-r--r--net/tclsoap/Makefile21
-rw-r--r--net/tclsoap/distinfo2
-rw-r--r--net/tclsoap/files/patch-Makefile.in13
-rw-r--r--net/tclsoap/files/patch-SOAP.tcl21
-rw-r--r--net/tclsoap/files/patch-pkgIndex.tcl14
-rw-r--r--net/tclsoap/files/patch-xpath.tcl17
-rw-r--r--net/tclsoap/pkg-descr6
-rw-r--r--net/tclsoap/pkg-plist20
8 files changed, 114 insertions, 0 deletions
diff --git a/net/tclsoap/Makefile b/net/tclsoap/Makefile
new file mode 100644
index 000000000000..37a6e4daf8a5
--- /dev/null
+++ b/net/tclsoap/Makefile
@@ -0,0 +1,21 @@
+# Created by: Sebastien Santoro <dereckson@gmail.com>
+# $FreeBSD$
+
+PORTNAME= tclsoap
+PORTVERSION= 1.6.7
+CATEGORIES= net
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/TclSOAP-${PORTVERSION}
+DISTNAME= TclSOAP-${PORTVERSION}
+
+MAINTAINER= dereckson@gmail.com
+COMMENT= SOAP and XML-RPC support for TCL library
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${LOCALBASE}/lib/TclxmlConfig.sh:${PORTSDIR}/devel/tclxml
+
+USES= tcl:wrapper,build
+USE_AUTOTOOLS= autoconf:autoconf
+WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/net/tclsoap/distinfo b/net/tclsoap/distinfo
new file mode 100644
index 000000000000..d77e9fc71f56
--- /dev/null
+++ b/net/tclsoap/distinfo
@@ -0,0 +1,2 @@
+SHA256 (TclSOAP-1.6.7.tar.gz) = aeb448de846f392b44b8309615b694081cf98340edabdb2dad4a71cdc49e03be
+SIZE (TclSOAP-1.6.7.tar.gz) = 149661
diff --git a/net/tclsoap/files/patch-Makefile.in b/net/tclsoap/files/patch-Makefile.in
new file mode 100644
index 000000000000..d774920b7894
--- /dev/null
+++ b/net/tclsoap/files/patch-Makefile.in
@@ -0,0 +1,13 @@
+diff --git Makefile.in Makefile.in
+index 7c62305..fe8e602 100644
+--- Makefile.in
++++ Makefile.in
+@@ -56,7 +56,7 @@ docdir = @docdir@
+
+ DESTDIR =
+
+-pkglibdir = $(libdir)/@PACKAGE@@VERSION@
++pkglibdir = $(libdir)/@PACKAGE@
+
+ top_builddir = .
+
diff --git a/net/tclsoap/files/patch-SOAP.tcl b/net/tclsoap/files/patch-SOAP.tcl
new file mode 100644
index 000000000000..cc3a37a43c11
--- /dev/null
+++ b/net/tclsoap/files/patch-SOAP.tcl
@@ -0,0 +1,21 @@
+diff --git SOAP.tcl SOAP.tcl
+index 4ba871e..1aaa071 100644
+--- SOAP.tcl
++++ SOAP.tcl
+@@ -22,12 +22,11 @@ package require rpcvar; # TclSOAP
+
+ namespace eval ::SOAP {variable domVersion}
+ if {[catch {package require SOAP::dom 1.0} ::SOAP::domVersion]} {
+- if { [catch {package require dom 2.0} ::SOAP::domVersion]} {
+- if { [catch {package require dom 1.6} ::SOAP::domVersion]} {
+- error "require dom package greater than 1.6"
+- }
+- package require SOAP::xpath; # TclSOAP
++ if {[catch {package require dom} ::SOAP::domVersion] || [package vcompare $::SOAP::domVersion 1.6] < 0} {
++ error "require dom package greater than 1.6"
+ }
++ package require SOAP::xpath; # TclSOAP
++
+ proc ::SOAP::createDocument {name} {
+ set doc [dom::DOMImplementation create]
+ return [dom::document createElement $doc $name]
diff --git a/net/tclsoap/files/patch-pkgIndex.tcl b/net/tclsoap/files/patch-pkgIndex.tcl
new file mode 100644
index 000000000000..cfca7115e8ca
--- /dev/null
+++ b/net/tclsoap/files/patch-pkgIndex.tcl
@@ -0,0 +1,14 @@
+diff --git pkgIndex.tcl pkgIndex.tcl
+index b7fb4e3..ebdf78f 100644
+--- pkgIndex.tcl
++++ pkgIndex.tcl
+@@ -11,8 +11,7 @@
+ package ifneeded SOAP 1.6.7 [list source [file join $dir SOAP.tcl]]
+ package ifneeded SOAP::CGI 1.0 [list source [file join $dir SOAP-CGI.tcl]]
+ package ifneeded SOAP::Domain 1.4 [list source [file join $dir SOAP-domain.tcl]]
+-package ifneeded SOAP::Service 0.4 [list source [file join $dir SOAP-service.tcl]]
+-package ifneeded SOAP::Utils 1.0 [list source [file join $dir utils.tcl]]
++package ifneeded SOAP::Utils 1.0.1 [list source [file join $dir utils.tcl]]
+ package ifneeded SOAP::ftp 1.0 [list source [file join $dir ftp.tcl]]
+ package ifneeded SOAP::http 1.0 [list source [file join $dir http.tcl]]
+ package ifneeded SOAP::https 1.0 [list source [file join $dir https.tcl]]
diff --git a/net/tclsoap/files/patch-xpath.tcl b/net/tclsoap/files/patch-xpath.tcl
new file mode 100644
index 000000000000..18450999beb6
--- /dev/null
+++ b/net/tclsoap/files/patch-xpath.tcl
@@ -0,0 +1,17 @@
+diff --git xpath.tcl xpath.tcl
+index 14b0334..f33e02c 100644
+--- xpath.tcl
++++ xpath.tcl
+@@ -14,10 +14,9 @@
+ # for more details.
+ # -------------------------------------------------------------------------
+
+-if { [catch {package require dom 2.0}] } {
+- if { [catch {package require dom 1.6}] } {
++namespace eval ::SOAP {variable domVersion}
++if { [catch {package require dom} ::SOAP::domVersion] || [package vcompare $::SOAP::domVersion 1.6] < 0} {
+ error "require dom package greater than 1.6"
+- }
+ }
+
+ namespace eval SOAP::xpath {
diff --git a/net/tclsoap/pkg-descr b/net/tclsoap/pkg-descr
new file mode 100644
index 000000000000..c64afed9478b
--- /dev/null
+++ b/net/tclsoap/pkg-descr
@@ -0,0 +1,6 @@
+tclsoap provides support for building clients and servers
+for the SOAP remote procedure call protocol from Tcl. SOAP
+is an XML based RPC mechanism which provides cross-platform
+cross language compatability.
+
+WWW: http://tclsoap.sourceforge.net/
diff --git a/net/tclsoap/pkg-plist b/net/tclsoap/pkg-plist
new file mode 100644
index 000000000000..229f22fc3195
--- /dev/null
+++ b/net/tclsoap/pkg-plist
@@ -0,0 +1,20 @@
+lib/tclsoap/SOAP-CGI.tcl
+lib/tclsoap/SOAP-domain.tcl
+lib/tclsoap/SOAP.tcl
+lib/tclsoap/XMLRPC.tcl
+lib/tclsoap/beep.tcl
+lib/tclsoap/ftp.tcl
+lib/tclsoap/http.tcl
+lib/tclsoap/https.tcl
+lib/tclsoap/interop/pkgIndex.tcl
+lib/tclsoap/interop/silab.tcl
+lib/tclsoap/interop/soapinterop.tcl
+lib/tclsoap/interop/soapinteropB.tcl
+lib/tclsoap/interop/soapinteropC.tcl
+lib/tclsoap/pkgIndex.tcl
+lib/tclsoap/rpcvar.tcl
+lib/tclsoap/smtp.tcl
+lib/tclsoap/utils.tcl
+lib/tclsoap/xpath.tcl
+@dirrmtry lib/tclsoap/interop
+@dirrmtry lib/tclsoap