aboutsummaryrefslogtreecommitdiff
path: root/net/zerotier/Makefile
diff options
context:
space:
mode:
authorDave Cottlehuber <dch@FreeBSD.org>2018-07-03 13:08:59 +0000
committerDave Cottlehuber <dch@FreeBSD.org>2018-07-03 13:08:59 +0000
commitbade39ee47ca90514bf7de1963c30b0b1aa4fd11 (patch)
treeb267cae141a30a9e44cca0dd0a118b34d4fa4612 /net/zerotier/Makefile
parent7326e29c82616906061df08671bb9e36e7bc81f8 (diff)
downloadports-bade39ee47ca90514bf7de1963c30b0b1aa4fd11.tar.gz
ports-bade39ee47ca90514bf7de1963c30b0b1aa4fd11.zip
net/zerotier: update 1.2.8 to 1.2.10
include 3 upstream bugs related to large environments: - Fix bug loading moons.d/ files for federated root operation. - Fix compile problem with ZT_DEBUG on some versions of clang - Fix slow network startup bug related to loading of networks.d/ cache files improve daemon functionality: - improve rc.d dependencies by requiring devfs instead of netif - use daemon(8) to capture debug logging to syslog if > FreeBSD 11.1R and if compiled with debugging option - let rc.d script load if_tap if not already present - add reminder for users about sysctls to avoid race conditions at boot time Reviewed by: mat Approved by: jrm Differential Revision: https://reviews.freebsd.org/D15534
Notes
Notes: svn path=/head/; revision=473828
Diffstat (limited to 'net/zerotier/Makefile')
-rw-r--r--net/zerotier/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/net/zerotier/Makefile b/net/zerotier/Makefile
index f2a982dea996..ed411f23c382 100644
--- a/net/zerotier/Makefile
+++ b/net/zerotier/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= zerotier
-DISTVERSION= 1.2.8
+DISTVERSION= 1.2.10
CATEGORIES= net
MAINTAINER= dch@FreeBSD.org
@@ -29,10 +29,21 @@ DBG_ALL_TARGET= debug
PLIST_FILES= bin/zerotier-cli bin/zerotier-idtool sbin/zerotier-one
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == "FreeBSD"
+# log output via syslog when daemon(8) supports it
+.if ((${OSVERSION} >= 1100513 && ${OSVERSION} < 1200000) || ${OSVERSION} >= 1200015)
+SUB_LIST+= ZEROTIER_SYSLOG="-s debug -T zerotier"
+.else
+SUB_LIST+= ZEROTIER_SYSLOG=""
+.endif
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/zerotier-one ${STAGEDIR}${PREFIX}/sbin/
.for l in zerotier-cli zerotier-idtool
- ${LN} -sf ../sbin/zerotier-one ${STAGEDIR}${PREFIX}/bin/${l}
+ ${RLN} ${STAGEDIR}${PREFIX}/sbin/zerotier-one ${STAGEDIR}${PREFIX}/bin/${l}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>