aboutsummaryrefslogtreecommitdiff
path: root/net/zerotier
diff options
context:
space:
mode:
authorDave Cottlehuber <dch@FreeBSD.org>2018-09-13 11:48:34 +0000
committerDave Cottlehuber <dch@FreeBSD.org>2018-09-13 11:48:34 +0000
commita901f2f8510b60e08b9b3ec8aa67ed17cadcb179 (patch)
treea5d8fefe2cda3dadfb2dd4837d41d752e1eab76b /net/zerotier
parent9ec8831421f74234983ee6e1d087bc25dc3bd297 (diff)
downloadports-a901f2f8510b60e08b9b3ec8aa67ed17cadcb179.tar.gz
ports-a901f2f8510b60e08b9b3ec8aa67ed17cadcb179.zip
net/zerotier: build on arm and 10.4 x86/x64 & improve compiler settings
- use improved C++14 settings contributed by jbeich@ - correct LICENSE_FILES via mat@ and jbeich@ - fixes ARM build from PR#231335 - submitted by Vincent Milum <freebsd@darkain.com> - upstream https://github.com/zerotier/ZeroTierOne/pull/848 Submitted by: Vincent Milum <freebsd@darkain.com> Reported by: jbeich Approved by: jrm (mentor) Obtained from: https://github.com/zerotier/ZeroTierOne/pull/848 Differential Revision: https://reviews.freebsd.org/D16880
Notes
Notes: svn path=/head/; revision=479671
Diffstat (limited to 'net/zerotier')
-rw-r--r--net/zerotier/Makefile11
-rw-r--r--net/zerotier/files/patch-Makefile11
-rw-r--r--net/zerotier/files/patch-ext_arm32-neon-salsa2012-asm_salsa2012.h14
-rw-r--r--net/zerotier/files/patch-make-bsd.mk4
4 files changed, 32 insertions, 8 deletions
diff --git a/net/zerotier/Makefile b/net/zerotier/Makefile
index f025661f6c03..79d1dbfb576e 100644
--- a/net/zerotier/Makefile
+++ b/net/zerotier/Makefile
@@ -3,21 +3,20 @@
PORTNAME= zerotier
DISTVERSION= 1.2.12
+PORTREVISION= 1
CATEGORIES= net
MAINTAINER= dch@FreeBSD.org
COMMENT= Network virtualization everywhere
-LICENSE= GPLv3 MIT PD BSD3CLAUSE APACHE20
+LICENSE= GPLv3+ MIT PD
LICENSE_COMB= multi
-LICENSE_FILE= ${WRKSRC}/LICENSE.GPL-3
+LICENSE_FILE_GPLv3+ =${WRKSRC}/LICENSE.GPL-3
+LICENSE_FILE_MIT=${WRKSRC}/ext/json/LICENSE.MIT
-BROKEN_armv6= fails to link: Source object ext/arm32-neon-salsa2012-asm/salsa2012.o has EABI version 0, but target zerotier-one has EABI version 5
-BROKEN_armv7= fails to link: Source object ext/arm32-neon-salsa2012-asm/salsa2012.o has EABI version 0, but target zerotier-one has EABI version 5
BROKEN_powerpc64= fails to compile: clang: not found
-BROKEN_FreeBSD_10_i386= fails to compile: clang++: error: unable to execute command: Segmentation fault (core dumped)
-USES= gmake compiler:c11
+USES= gmake compiler:c++14-lang
USE_RC_SUBR= zerotier
USE_GITHUB= yes
diff --git a/net/zerotier/files/patch-Makefile b/net/zerotier/files/patch-Makefile
new file mode 100644
index 000000000000..92da0851926d
--- /dev/null
+++ b/net/zerotier/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2018-09-13 09:39:16 UTC
++++ Makefile
+@@ -11,8 +11,6 @@ ifeq ($(OSTYPE),Linux)
+ endif
+
+ ifeq ($(OSTYPE),FreeBSD)
+- CC=clang
+- CXX=clang++
+ ZT_BUILD_PLATFORM=7
+ include make-bsd.mk
+ endif
diff --git a/net/zerotier/files/patch-ext_arm32-neon-salsa2012-asm_salsa2012.h b/net/zerotier/files/patch-ext_arm32-neon-salsa2012-asm_salsa2012.h
new file mode 100644
index 000000000000..7b5b738eba56
--- /dev/null
+++ b/net/zerotier/files/patch-ext_arm32-neon-salsa2012-asm_salsa2012.h
@@ -0,0 +1,14 @@
+--- ext/arm32-neon-salsa2012-asm/salsa2012.h.orig 2018-07-27 21:14:09 UTC
++++ ext/arm32-neon-salsa2012-asm/salsa2012.h
+@@ -5,8 +5,10 @@
+ #include <sys/auxv.h>
+ #include <asm/hwcap.h>
+ #define zt_arm_has_neon() ((getauxval(AT_HWCAP) & HWCAP_NEON) != 0)
+-#else
++#elif defined(__ARM_NEON__) || defined(__ARM_NEON)
+ #define zt_arm_has_neon() (true)
++#else
++#define zt_arm_has_neon() (false)
+ #endif
+
+ #ifdef __cplusplus
diff --git a/net/zerotier/files/patch-make-bsd.mk b/net/zerotier/files/patch-make-bsd.mk
index c7ef859cbe74..57fa00b4ca55 100644
--- a/net/zerotier/files/patch-make-bsd.mk
+++ b/net/zerotier/files/patch-make-bsd.mk
@@ -1,11 +1,11 @@
---- make-bsd.mk.orig 2018-05-18 08:50:17 UTC
+--- make-bsd.mk.orig 2018-09-13 10:12:22 UTC
+++ make-bsd.mk
@@ -159,7 +159,7 @@ clean:
rm -rf *.a *.o node/*.o controller/*.o osdep/*.o service/*.o ext/http-parser/*.o build-* zerotier-one zerotier-idtool zerotier-selftest zerotier-cli $(ONE_OBJS) $(CORE_OBJS)
debug: FORCE
- gmake -j 4 ZT_DEBUG=1
-+ $(MAKE) -j ZT_DEBUG=1
++ $(MAKE) -j 4 ZT_DEBUG=1
install: one
rm -f /usr/local/sbin/zerotier-one