aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2002-01-22 00:43:03 +0000
committerMartin Blapp <mbr@FreeBSD.org>2002-01-22 00:43:03 +0000
commitcb151ad3211654ef5eeeafe5cf523e45b0b91252 (patch)
treec73a7f85d9e31b88218ece48b039696a2bc38f28 /net
parent0f601033c423c530e531e1dd563bdfeef4a94b3d (diff)
downloadports-cb151ad3211654ef5eeeafe5cf523e45b0b91252.tar.gz
ports-cb151ad3211654ef5eeeafe5cf523e45b0b91252.zip
Fix the plugin install. Look if there is a linux netscape installed
and use it's plugin dir to install. PR: ports/33318
Notes
Notes: svn path=/head/; revision=53497
Diffstat (limited to 'net')
-rw-r--r--net/citrix_ica/Makefile28
-rw-r--r--net/citrix_ica/files/patch-linuxx86::hinst36
-rw-r--r--net/citrix_xenapp/Makefile28
-rw-r--r--net/citrix_xenapp/files/patch-linuxx86::hinst36
4 files changed, 112 insertions, 16 deletions
diff --git a/net/citrix_ica/Makefile b/net/citrix_ica/Makefile
index 46a2c57bab1a..b988519800fd 100644
--- a/net/citrix_ica/Makefile
+++ b/net/citrix_ica/Makefile
@@ -26,6 +26,14 @@ NO_BUILD= yes
CDIR= ${PREFIX}/ICAClient
BINDIR= ${PREFIX}/bin
+NSCP= /usr/local/libexec/netscape \
+ /usr/local/libexec/netscape-linux \
+ /usr/local/netscape \
+ /usr/local/netscape-linux \
+ /usr/local/lib/netscape \
+ /usr/local/lib/netscape-linux \
+ ${MOZILLA_HOME}
+
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX})
@@ -43,14 +51,18 @@ do-install:
${ECHO} "-----------------------------------------------------------" ; \
${FALSE} ; \
fi
- @if (test -d "/usr/lib/netscape"\
- || test -d "/usr/local/netscape"\
- || test -d "/usr/local/lib/netscape") ; \
- then \
- ${ECHO} -e "1\n${CDIR}\ny\ny\ny\n3" > ${WRKSRC}/response ; \
- else \
- ${ECHO} -e "1\n${CDIR}\ny\ny\ny\ny\n3" > ${WRKSRC}/response ; \
- fi
+
+ @${ECHO} -e "1\n${CDIR}\ny\ny\ny\ny\n3" > ${WRKSRC}/response ;
+ @for dir in ${NSCP}; do \
+ if [ -e $${dir}/plugins/libnullplugin.so ]; then \
+ BIN=`${FILE} $${dir}/plugins/libnullplugin.so | ${AWK} '{print $$11}'` ; \
+ case $${BIN} in \
+ \(SYSV\),) \
+ ${ECHO} -e "1\n${CDIR}\ny\ny\ny\n3" > ${WRKSRC}/response ; \
+ esac \
+ fi \
+ done
+
${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/wfcmgr \
> ${WRKSRC}/wfcmgr.x
${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/wfica \
diff --git a/net/citrix_ica/files/patch-linuxx86::hinst b/net/citrix_ica/files/patch-linuxx86::hinst
new file mode 100644
index 000000000000..4c57dafd8c24
--- /dev/null
+++ b/net/citrix_ica/files/patch-linuxx86::hinst
@@ -0,0 +1,36 @@
+--- linuxx86/hinst.orig Wed Sep 5 16:47:26 2001
++++ linuxx86/hinst Tue Jan 22 00:15:59 2002
+@@ -1965,10 +1965,31 @@
+ #
+ ###############################################################################
+
++check_for_ns() {
++ BIN=`/usr/bin/file $1/plugins/libnullplugin.so | /usr/bin/awk '{print $11}'`
++ case ${BIN} in
++ \(SYSV\),)
++ NETSCAPE_DIR="$1"
++ PLUGIN_PATH="$s/plugins"
++ esac
++}
++
++NSCP="/usr/local/libexec/netscape \
++ /usr/local/libexec/netscape-linux \
++ /usr/local/netscape \
++ /usr/local/netscape-linux \
++ /usr/local/lib/netscape \
++ /usr/local/lib/netscape-linux \
++ $MOZILLA_HOME"
++
++for dir in ${NSCP}; do
++ if [ -e $dir/plugins/libnullplugin.so ]; then
++ check_for_ns $dir;
++ fi
++done
++
+ INST_DIR=$ICAInstDir
+ TMP_NAME=/tmp/ICAnetscape.$$
+-NETSCAPE_DIR="/usr/local/lib/netscape"
+-PLUGIN_PATH="/usr/local/netscape/plugins"
+ PLUGIN_NAME=npica.so
+ PLUGIN_CLASS=ICAClObj.class
+
diff --git a/net/citrix_xenapp/Makefile b/net/citrix_xenapp/Makefile
index 46a2c57bab1a..b988519800fd 100644
--- a/net/citrix_xenapp/Makefile
+++ b/net/citrix_xenapp/Makefile
@@ -26,6 +26,14 @@ NO_BUILD= yes
CDIR= ${PREFIX}/ICAClient
BINDIR= ${PREFIX}/bin
+NSCP= /usr/local/libexec/netscape \
+ /usr/local/libexec/netscape-linux \
+ /usr/local/netscape \
+ /usr/local/netscape-linux \
+ /usr/local/lib/netscape \
+ /usr/local/lib/netscape-linux \
+ ${MOZILLA_HOME}
+
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX})
@@ -43,14 +51,18 @@ do-install:
${ECHO} "-----------------------------------------------------------" ; \
${FALSE} ; \
fi
- @if (test -d "/usr/lib/netscape"\
- || test -d "/usr/local/netscape"\
- || test -d "/usr/local/lib/netscape") ; \
- then \
- ${ECHO} -e "1\n${CDIR}\ny\ny\ny\n3" > ${WRKSRC}/response ; \
- else \
- ${ECHO} -e "1\n${CDIR}\ny\ny\ny\ny\n3" > ${WRKSRC}/response ; \
- fi
+
+ @${ECHO} -e "1\n${CDIR}\ny\ny\ny\ny\n3" > ${WRKSRC}/response ;
+ @for dir in ${NSCP}; do \
+ if [ -e $${dir}/plugins/libnullplugin.so ]; then \
+ BIN=`${FILE} $${dir}/plugins/libnullplugin.so | ${AWK} '{print $$11}'` ; \
+ case $${BIN} in \
+ \(SYSV\),) \
+ ${ECHO} -e "1\n${CDIR}\ny\ny\ny\n3" > ${WRKSRC}/response ; \
+ esac \
+ fi \
+ done
+
${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/wfcmgr \
> ${WRKSRC}/wfcmgr.x
${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/wfica \
diff --git a/net/citrix_xenapp/files/patch-linuxx86::hinst b/net/citrix_xenapp/files/patch-linuxx86::hinst
new file mode 100644
index 000000000000..4c57dafd8c24
--- /dev/null
+++ b/net/citrix_xenapp/files/patch-linuxx86::hinst
@@ -0,0 +1,36 @@
+--- linuxx86/hinst.orig Wed Sep 5 16:47:26 2001
++++ linuxx86/hinst Tue Jan 22 00:15:59 2002
+@@ -1965,10 +1965,31 @@
+ #
+ ###############################################################################
+
++check_for_ns() {
++ BIN=`/usr/bin/file $1/plugins/libnullplugin.so | /usr/bin/awk '{print $11}'`
++ case ${BIN} in
++ \(SYSV\),)
++ NETSCAPE_DIR="$1"
++ PLUGIN_PATH="$s/plugins"
++ esac
++}
++
++NSCP="/usr/local/libexec/netscape \
++ /usr/local/libexec/netscape-linux \
++ /usr/local/netscape \
++ /usr/local/netscape-linux \
++ /usr/local/lib/netscape \
++ /usr/local/lib/netscape-linux \
++ $MOZILLA_HOME"
++
++for dir in ${NSCP}; do
++ if [ -e $dir/plugins/libnullplugin.so ]; then
++ check_for_ns $dir;
++ fi
++done
++
+ INST_DIR=$ICAInstDir
+ TMP_NAME=/tmp/ICAnetscape.$$
+-NETSCAPE_DIR="/usr/local/lib/netscape"
+-PLUGIN_PATH="/usr/local/netscape/plugins"
+ PLUGIN_NAME=npica.so
+ PLUGIN_CLASS=ICAClObj.class
+