aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-21 17:06:38 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-21 17:06:38 +0000
commit65b20c0e1a6fe9d907243d4a22794d480fe1b55f (patch)
treedcc5cda68ae33c50e5c3c015ba8a705a76922a17 /net
parentbe517ef4a4de1f2703b258c873811dabf3c357bb (diff)
downloadports-65b20c0e1a6fe9d907243d4a22794d480fe1b55f.tar.gz
ports-65b20c0e1a6fe9d907243d4a22794d480fe1b55f.zip
net/rubygem-grpc: Update to 1.57.0
Diffstat (limited to 'net')
-rw-r--r--net/rubygem-grpc/Makefile2
-rw-r--r--net/rubygem-grpc/distinfo6
-rw-r--r--net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb30
3 files changed, 26 insertions, 12 deletions
diff --git a/net/rubygem-grpc/Makefile b/net/rubygem-grpc/Makefile
index 64cde8475015..9a2add151eec 100644
--- a/net/rubygem-grpc/Makefile
+++ b/net/rubygem-grpc/Makefile
@@ -1,5 +1,5 @@
PORTNAME= grpc
-PORTVERSION= 1.56.0
+PORTVERSION= 1.57.0
CATEGORIES= net rubygems
MASTER_SITES= RG
diff --git a/net/rubygem-grpc/distinfo b/net/rubygem-grpc/distinfo
index a2be1a78c479..b345c09c1db1 100644
--- a/net/rubygem-grpc/distinfo
+++ b/net/rubygem-grpc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1688167134
-SHA256 (rubygem/grpc-1.56.0.gem) = e183a35d0772af44f801e272cef801324eb0b57cad8f459e7dd7a68aa953db2f
-SIZE (rubygem/grpc-1.56.0.gem) = 6249984
+TIMESTAMP = 1692211989
+SHA256 (rubygem/grpc-1.57.0.gem) = ef4c93ae7da64094dd89cc06875d8b358d3908033733e2a6a05619a1064eefd8
+SIZE (rubygem/grpc-1.57.0.gem) = 6344192
diff --git a/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb b/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
index c325a069f189..c061d0c14e0b 100644
--- a/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
+++ b/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
@@ -1,11 +1,11 @@
---- src/ruby/ext/grpc/extconf.rb.orig 2023-02-26 18:56:37 UTC
+--- src/ruby/ext/grpc/extconf.rb.orig 2023-08-19 01:12:29 UTC
+++ src/ruby/ext/grpc/extconf.rb
-@@ -69,11 +69,11 @@ if apple_toolchain && !cross_compiling
+@@ -68,11 +68,11 @@ if apple_toolchain && !cross_compiling
end
# Don't embed on TruffleRuby (constant-time crypto is unsafe with Sulong, slow build times)
-ENV['EMBED_OPENSSL'] = (RUBY_ENGINE != 'truffleruby').to_s
-+ENV['EMBED_OPENSSL'] = 'false'
++ENV['EMBED_OPENSSL'] = 'false'
# Don't embed on TruffleRuby (the system zlib is already linked for the zlib C extension, slow build times)
-ENV['EMBED_ZLIB'] = (RUBY_ENGINE != 'truffleruby').to_s
+ENV['EMBED_ZLIB'] = 'false'
@@ -15,9 +15,9 @@
ENV['ARCH_FLAGS'] = RbConfig::CONFIG['ARCH_FLAG']
if apple_toolchain && !cross_compiling
-@@ -94,25 +94,6 @@ output_dir = File.expand_path(RbConfig::CONFIG['topdir
- grpc_lib_dir = File.join(output_dir, 'libs', grpc_config)
- ENV['BUILDDIR'] = output_dir
+@@ -97,36 +97,6 @@ ENV['BUILDDIR'] = output_dir
+ strip_tool = RbConfig::CONFIG['STRIP']
+ strip_tool += ' -x' if apple_toolchain
-unless windows
- puts 'Building internal gRPC into ' + grpc_lib_dir
@@ -33,6 +33,17 @@
- puts "Building grpc native library: #{cmd}"
- system(cmd)
- exit 1 unless $? == 0
+-
+- if grpc_config == 'opt'
+- rm_obj_cmd = "rm -rf #{File.join(output_dir, 'objs')}"
+- puts "Removing grpc object files: #{rm_obj_cmd}"
+- system(rm_obj_cmd)
+- exit 1 unless $? == 0
+- strip_cmd = "#{strip_tool} #{grpc_lib_dir}/*.a"
+- puts "Stripping grpc native library: #{strip_cmd}"
+- system(strip_cmd)
+- exit 1 unless $? == 0
+- end
-end
-
-$CFLAGS << ' -DGRPC_RUBY_WINDOWS_UCRT' if windows_ucrt
@@ -41,12 +52,15 @@
def have_ruby_abi_version()
return true if RUBY_ENGINE == 'truffleruby'
# ruby_abi_version is only available in development versions: https://github.com/ruby/ruby/pull/6231
-@@ -141,10 +122,8 @@ def ext_export_filename()
+@@ -155,13 +125,12 @@ def ext_export_filename()
end
ext_export_file = File.join(grpc_root, 'src', 'ruby', 'ext', 'grpc', ext_export_filename())
-$LDFLAGS << ' -Wl,--version-script="' + ext_export_file + '.gcc"' if linux
--$LDFLAGS << ' -Wl,-exported_symbols_list,"' + ext_export_file + '.clang"' if apple_toolchain
+ if apple_toolchain
+ $LDFLAGS << ' -weak_framework CoreFoundation' if RUBY_PLATFORM =~ /arm64/
+ $LDFLAGS << ' -Wl,-exported_symbols_list,"' + ext_export_file + '.clang"'
+ end
-$LDFLAGS << ' ' + File.join(grpc_lib_dir, 'libgrpc.a') unless windows
+$LDFLAGS << ' -lgrpc' unless windows