aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2010-10-25 13:13:41 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2010-10-25 13:13:41 +0000
commitc4d658de2e91d6826215a9eb4b58458a7d97a26f (patch)
tree2eaa99e9990cbf818df2a33acc42f8569b53d3a0 /net
parentde31d97d735ee18a1a2580c2d50919dbb697bc79 (diff)
downloadports-c4d658de2e91d6826215a9eb4b58458a7d97a26f.tar.gz
ports-c4d658de2e91d6826215a9eb4b58458a7d97a26f.zip
HexInject is a very versatile packet injector and sniffer, that provide a
command-line framework for raw network access. It's designed to work together with others command-line utilities, and for this reason it facilitates the creation of powerful shell scripts capable of reading, intercepting and modifying network traffic in a transparent manner. WWW: http://hexinject.sourceforge.net PR: ports/151670 Submitted by: Sofian Brabez <sbrabez at gmail.com>
Notes
Notes: svn path=/head/; revision=263567
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/hexinject/Makefile24
-rw-r--r--net/hexinject/distinfo3
-rw-r--r--net/hexinject/files/patch-hexinject.c11
-rw-r--r--net/hexinject/pkg-descr8
5 files changed, 47 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 165e8b0f4cd5..abf8b486106b 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -220,6 +220,7 @@
SUBDIR += haproxy-devel
SUBDIR += hawknl
SUBDIR += hawknl-devel
+ SUBDIR += hexinject
SUBDIR += hf6to4
SUBDIR += hidentd
SUBDIR += hinfo
diff --git a/net/hexinject/Makefile b/net/hexinject/Makefile
new file mode 100644
index 000000000000..6abd2ef31bdc
--- /dev/null
+++ b/net/hexinject/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: hexinject
+# Date created: 2010-10-24
+# Whom: Sofian Brabez <sbrabez@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hexinject
+PORTVERSION= 1.1
+CATEGORIES= net security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= sbrabez@gmail.com
+COMMENT= HexInject is a very versatile packet injector and sniffer
+
+PLIST_FILES= bin/${PORTNAME}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/hexinject/distinfo b/net/hexinject/distinfo
new file mode 100644
index 000000000000..6eccc0e059e4
--- /dev/null
+++ b/net/hexinject/distinfo
@@ -0,0 +1,3 @@
+MD5 (hexinject-1.1.tar.gz) = 8542411cc5d31101e2a8f56b73dd6fa1
+SHA256 (hexinject-1.1.tar.gz) = 050852f89ea501c7bad768a694f8fd2d5f0c3de68da82647a1cb7aeb68e96e27
+SIZE (hexinject-1.1.tar.gz) = 4470
diff --git a/net/hexinject/files/patch-hexinject.c b/net/hexinject/files/patch-hexinject.c
new file mode 100644
index 000000000000..0f1510501617
--- /dev/null
+++ b/net/hexinject/files/patch-hexinject.c
@@ -0,0 +1,11 @@
+--- ./hexinject.c.orig 2010-10-24 06:23:57.000000000 +0200
++++ ./hexinject.c 2010-10-24 06:24:17.000000000 +0200
+@@ -424,7 +424,7 @@
+ if ( (fp = pcap_open_live( options.device, // name of the device
+ BUFSIZ, // portion of the packet to capture
+ 1, // promiscuous mode
+- -1, // read timeout
++ 1000, // read timeout
+ errbuf // error buffer
+ )) == NULL)
+
diff --git a/net/hexinject/pkg-descr b/net/hexinject/pkg-descr
new file mode 100644
index 000000000000..8ddb4416f058
--- /dev/null
+++ b/net/hexinject/pkg-descr
@@ -0,0 +1,8 @@
+HexInject is a very versatile packet injector and sniffer, that provide a
+command-line framework for raw network access.
+
+It's designed to work together with others command-line utilities, and for this
+reason it facilitates the creation of powerful shell scripts capable of reading,
+intercepting and modifying network traffic in a transparent manner.
+
+WWW: http://hexinject.sourceforge.net