aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg-devel/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-03-17 14:16:11 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-03-17 14:16:11 +0000
commit098b598e0387c22b24ebc0537c968fed024dedb2 (patch)
tree9e81c54875dcf32a36e2b028a56b31406f0317ed /ports-mgmt/pkg-devel/Makefile
parentba91d6745c19b62c746ff8210586d8b0d64e4de1 (diff)
downloadports-098b598e0387c22b24ebc0537c968fed024dedb2.tar.gz
ports-098b598e0387c22b24ebc0537c968fed024dedb2.zip
update to 1.16.99.3:
The main big change is the switch of the package extension to .pkg This is done so we can change compression format without having to modify the tools each time to adapt to the new extension While here adapt the ports tree to the new .pkg extension and prepare the pkg-devel ports to swicth the package compression format to zstd in FreeBSD 14 in a month to give time to upgrade to a version which have the bootstrap knowing about .pkg. Changes from 1.16.99.2 to 1.16.99.3 - lua update to 5.4.2 - pkg repo accept now all supported formats mixed without config - pkg now default on creating .pkg files with backward compatible symlinks - backward compatible symlinks are now an option - make the default comprpession format a config option - set the default compression level for zstd to 19 - make the default compression level a config option - Update libucl to latest version
Notes
Notes: svn path=/head/; revision=568662
Diffstat (limited to 'ports-mgmt/pkg-devel/Makefile')
-rw-r--r--ports-mgmt/pkg-devel/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/ports-mgmt/pkg-devel/Makefile b/ports-mgmt/pkg-devel/Makefile
index c78fc0d56c68..533b848c0c2f 100644
--- a/ports-mgmt/pkg-devel/Makefile
+++ b/ports-mgmt/pkg-devel/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= pkg
-DISTVERSION= 1.16.99.2
+DISTVERSION= 1.16.99.3
_PKG_VERSION= ${DISTVERSION}
CATEGORIES= ports-mgmt
PKGNAMESUFFIX= -devel
@@ -13,7 +13,7 @@ LICENSE= BSD2CLAUSE
USE_GITHUB= yes
GH_ACCOUNT= freebsd
-GH_TAGNAME= c1aba2b2
+GH_TAGNAME= deae242d
CFLAGS+= -O0 -g -Wno-error
USE_LDCONFIG= ${PREFIX}/lib/compat/pkg
@@ -35,6 +35,11 @@ EXTRA_PATCHES= ${FILESDIR}/extra-patch-docs_pkg.8
.include <bsd.port.pre.mk>
+# TODO: activate in april 2021
+#.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1400000
+#CONFIGURE_ARGS+= --default-format=tzst
+#.endif
+
.if !exists(/usr/libdata/pkgconfig/liblzma.pc)
LIBLZMA_LIBS= -llzma
.else