aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portscout
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2007-01-21 23:43:09 +0000
committerShaun Amott <shaun@FreeBSD.org>2007-01-21 23:43:09 +0000
commitd7813d9326aeb211645c5277067907dc0d1a1014 (patch)
tree8c462f49e6c796f1491c5cc7e4c9ab27556b342d /ports-mgmt/portscout
parentf39690fc84ae9ae1abc73737eb069ac055408209 (diff)
downloadports-d7813d9326aeb211645c5277067907dc0d1a1014.tar.gz
ports-d7813d9326aeb211645c5277067907dc0d1a1014.zip
portscout is a tool which looks for new versions of software in the
FreeBSD ports tree, and potentially other software repositories. Various factors make this task a bit more difficult than it might initially seem. In particular, the array of weird and wonderful versioning schemes software vendors manage to come up with. portscout spawns several child processes and does its version checking in parallel, while attempting to best-guess strange-looking version numbers, navigate around unhelpful sites and web servers, and contend with the CPU-heavy rapidly-expanding FreeBSD ports system. In addition to all this, it is possible to generate nice HTML reports and send reminder mails to interested parties. This should probably be considered beta until v1.0 is released.
Notes
Notes: svn path=/head/; revision=182924
Diffstat (limited to 'ports-mgmt/portscout')
-rw-r--r--ports-mgmt/portscout/Makefile88
-rw-r--r--ports-mgmt/portscout/distinfo3
-rw-r--r--ports-mgmt/portscout/pkg-descr20
-rw-r--r--ports-mgmt/portscout/pkg-plist13
4 files changed, 124 insertions, 0 deletions
diff --git a/ports-mgmt/portscout/Makefile b/ports-mgmt/portscout/Makefile
new file mode 100644
index 000000000000..0d0dae071517
--- /dev/null
+++ b/ports-mgmt/portscout/Makefile
@@ -0,0 +1,88 @@
+# New ports collection makefile for: portscout
+# Date created: 2006-05-15
+# Whom: Shaun Amott <shaun@inerd.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= portscout
+PORTVERSION= 0.7
+CATEGORIES= sysutils
+MASTER_SITES= http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/ \
+ http://www.inerd.com/software/${PORTNAME}/
+
+MAINTAINER= shaun@FreeBSD.org
+COMMENT= A tool to scan for new versions of FreeBSD ports
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+PORTDOCS= README
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/Proc/Queue.pm:${PORTSDIR}/devel/p5-Proc-Queue \
+ ${SITE_PERL}/Net/FTP.pm:${PORTSDIR}/net/p5-Net \
+ ${SITE_PERL}/MIME/Lite.pm:${PORTSDIR}/mail/p5-MIME-Lite \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+
+.if defined(WITH_MYSQL)
+WITHOUT_PGSQL= true
+.endif
+
+.if !defined(WITHOUT_PGSQL)
+USE_PGSQL= yes
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+.elif defined(WITH_MYSQL)
+USE_MYSQL= yes
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER:S/323//}
+.endif
+
+pre-everything::
+.if defined(WITH_MYSQL)
+ @${ECHO_MSG} "+-------------------------------------------------------------+"
+ @${ECHO_MSG} "| Warning! portscout has only been tested with PostgreSQL. |"
+ @${ECHO_MSG} "| The author makes no guarantee that anything else will work, |"
+ @${ECHO_MSG} "| but always welcomes success/bug reports, and/or patches. |"
+ @${ECHO_MSG} "+-------------------------------------------------------------+"
+.endif
+
+post-patch:
+.if defined(WITH_MYSQL)
+ @${REINPLACE_CMD} 's/DBI:Pg/DBI:mysql/g' ${WRKSRC}/portscout.conf
+.endif
+ @${REINPLACE_CMD} -e "s#^\(templates .*\)/etc#\1/share#" \
+ -e "s#^prefix\( *= *\).*#prefix\1${PREFIX}#" \
+ ${WRKSRC}/portscout.conf
+ @${REINPLACE_CMD} -e "s#^\(.*PREFIX.*=> *\)'.*'#\1'${PREFIX}'#" \
+ ${WRKSRC}/portscout.pl
+ @${REINPLACE_CMD} -e "s#portscout\.pl#portscout#" \
+ ${WRKSRC}/README
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/portscout.pl ${PREFIX}/bin/portscout
+
+ @${MKDIR} ${DATADIR}/templates
+ cd ${WRKSRC}/templates \
+ && ${INSTALL_DATA} * ${DATADIR}/templates
+
+ @${MKDIR} ${DATADIR}/sql
+ cd ${WRKSRC}/sql && ${INSTALL_DATA} *.sql ${DATADIR}/sql
+
+ ${INSTALL_DATA} ${WRKSRC}/portscout.conf ${PREFIX}/etc/portscout.conf.sample
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/portscout.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/portscout.conf.sample ${PREFIX}/etc/portscout.conf; \
+ fi
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6 or above. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/ports-mgmt/portscout/distinfo b/ports-mgmt/portscout/distinfo
new file mode 100644
index 000000000000..8e2856349559
--- /dev/null
+++ b/ports-mgmt/portscout/distinfo
@@ -0,0 +1,3 @@
+MD5 (portscout-0.7.tar.gz) = 0ea25cc656549aa2865e73e500ccb843
+SHA256 (portscout-0.7.tar.gz) = 6a30f636e9cd5cc7f7b0ecf68523d8b3f5beaa69705ac396c5f96e0b550aa408
+SIZE (portscout-0.7.tar.gz) = 28355
diff --git a/ports-mgmt/portscout/pkg-descr b/ports-mgmt/portscout/pkg-descr
new file mode 100644
index 000000000000..9df9a5e9312b
--- /dev/null
+++ b/ports-mgmt/portscout/pkg-descr
@@ -0,0 +1,20 @@
+portscout is a tool which looks for new versions of software in the
+FreeBSD ports tree, and potentially other software repositories.
+
+Various factors make this task a bit more difficult than it might
+initially seem. In particular, the array of weird and wonderful
+versioning schemes software vendors manage to come up with.
+
+portscout spawns several child processes and does its version checking
+in parallel, while attempting to best-guess strange-looking version
+numbers, navigate around unhelpful sites and web servers, and contend
+with the CPU-heavy rapidly-expanding FreeBSD ports system.
+
+In addition to all this, it is possible to generate nice HTML reports
+and send reminder mails to interested parties.
+
+Regularly updated results can be found at:
+ http://beta.inerd.com/portscout/
+
+
+WWW: http://www.inerd.com/software/portscout/
diff --git a/ports-mgmt/portscout/pkg-plist b/ports-mgmt/portscout/pkg-plist
new file mode 100644
index 000000000000..657e79ea12bd
--- /dev/null
+++ b/ports-mgmt/portscout/pkg-plist
@@ -0,0 +1,13 @@
+bin/portscout
+@unexec cmp -s %D/etc/portscout.conf.sample %D/etc/portscout.conf && rm -f %D/etc/portscout.conf
+@exec [ ! -f %D/etc/portscout.conf ] && cp -p %D/etc/portscout.conf.sample %D/etc/portscout.conf
+etc/portscout.conf.sample
+%%DATADIR%%/templates/index.html
+%%DATADIR%%/templates/maintainer.html
+%%DATADIR%%/templates/reminder.mail
+%%DATADIR%%/templates/restricted-ports.html
+%%DATADIR%%/sql/pgsql_init.sql
+%%DATADIR%%/sql/pgsql_destroy.sql
+@dirrm %%DATADIR%%/templates
+@dirrm %%DATADIR%%/sql
+@dirrm %%DATADIR%%