aboutsummaryrefslogtreecommitdiff
path: root/print/hplip-plugin/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-03-11 11:53:42 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-03-11 11:53:42 +0000
commit59272d10178066cdfa1d1aea23c915a09473d798 (patch)
tree923210657ff3819220d9f901a4ae5748d77b8564 /print/hplip-plugin/Makefile
parentfc9825be880916c415aad3c9a9483fd377323fdf (diff)
downloadports-59272d10178066cdfa1d1aea23c915a09473d798.tar.gz
ports-59272d10178066cdfa1d1aea23c915a09473d798.zip
Combine print/cups-base, print/cups-client and print/cups-image into
print/cups and update it to 2.1.3. Also remove print/cups-pstoraster, improve print/cups-filters, print/foomatic-* and update print/hplip to 3.16.2. Long description: First some background. When you hand a file to cups it sets up a chain of filter programs that converts the file to something a printer understands. Each filter has a cost associated with it and cups tries to find the cheapest chain. Costs used to be configured in such a way that files were first converted to PostScript. This could then be manipulated further (e.g. putting multiple pages on one sheet) before finally being sent to a PostScript printer or another filter like pstoraster which produces a raster format understood by non-PostScript printer drivers. Nowadays most filters have been moved from cups to cups-filters and they have been configured to use PDF as an intermediate format instead of PostScript. Merging of cups-base, cups-client and cups-image into print/cups: - cups-image provides a library to work with the cups raster format. It is only used to implement filters and printer drivers and these only exist in the context of a cups server so there's no need to separate this from cups-base. - cups-client provides a library that allows applications to print via cups. It is possible to use the library to access a remote cups server without running a local cups server, but such a setup is discouraged and the configuration file to set this up has been marked deprecated. It is better to run a local cups server and let that talk to the remote cups server because then you have the benefits of local job queuing in case the remote server is down or busy. Given this and the fact that without filters cups-base is now smaller than it used to be it makes sense to merge the ports. The patch also adds options IPPTOOL, DOCS and NLS which when disabled make the new cups package smaller than the current cups-client package. Merging the ports also prevents problems with options like ZEROCONF being configured differently in both ports. - print/cups was a metaport that depended on cups-base and some filters. There isn't really a need for such a metaport so cups-base can be renamed to cups. The filters can be depended on by printer drivers such as hplip if they need them. Additional changes to the new print/cups: - Clean up the patches. They seem to have been regenerated with post-patch changes included. - Add a patch to prevent intermediate conversion to PDF when a PostScript file is sent to a PostScript printer when cups-filters is installed. - Fix the PAM configuration file. - Add a patch to let the server search /usr/local/share/ppd like on Linux so other ports don't have to add links to it. - Remove ulpt(4) helper scripts. The port uses libusb with ugen(4). - Remove support for mDNSResponder. cups-filters only supports Avahi. - Combine ICONS and XDG_OPEN options into an X11 option to support WITHOUT_X11. - Optionally depend on colord for ICC profile support. - Various smaller changes. Changes to print/cups-filters: - Let the cups_browsed rc.d script depend on cupsd and avahi_daemon instead of LOGIN. - Development of foomatic-filters has been moved to cups-filters so let this port install foomatic related files and add foomatic-filters to CONFLICTS. - Fix location of liblouis tables. - Add patch to fix ICC support. Changes to print/cups-pstoraster: This port is essentially an old version of Ghostscript plus a cups filter. It's no longer developed. This commit removes it and changes existing dependencies to print/cups-filters which depends on print/ghostscript* and includes a gstoraster filter that can handle both PostScript and PDF. Changes to print/foomatic-db*: Remove old MASTER_SITES and dependencies and eliminate PKGNAMEPREFIX. Changes to print/foomatic-filters: Install beh backend with its original name again and add cups-filters to CONFLICTS. Changes to print/hplip: - Stop installing hpijs/foomatic-rip support. This is no longer supported upstream. - Stop installing hpcups PPDs. These are now automatically generated. The bundled PPDs are generated for an older version of cups. - Rename the QT option to X11 to support WITHOUT_X11. - Simplify the patches now that ports are installed in a staging area. - Add a patch to set SO_REUSEPORT (next to SO_REUSEADDR) on the mDNS socket like avahi-daemon does. This fixes Zeroconf support for HP network printers. PR: 207746 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=410825
Diffstat (limited to 'print/hplip-plugin/Makefile')
-rw-r--r--print/hplip-plugin/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/print/hplip-plugin/Makefile b/print/hplip-plugin/Makefile
index 0f79df14b040..ba5f1952055f 100644
--- a/print/hplip-plugin/Makefile
+++ b/print/hplip-plugin/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= hplip-plugin
-PORTVERSION= 3.14.10
+PORTVERSION= 3.16.2
CATEGORIES= print
MASTER_SITES= http://hplipopensource.com/hplip-web/plugin/
DISTNAME= hplip-${DISTVERSION}-plugin
@@ -25,6 +25,7 @@ ONLY_FOR_ARCHS= amd64 i386
PLUGIN_LINKS= fax/plugins/fax_marvell \
prnt/plugins/hbpl1 \
prnt/plugins/lj \
+ scan/plugins/bb_escl \
scan/plugins/bb_marvell \
scan/plugins/bb_soap \
scan/plugins/bb_soapht
@@ -47,14 +48,14 @@ LINARCH= x86_64
do-extract:
@${MKDIR} ${WRKDIR}
- @cd ${WRKDIR} && ${SH} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} --keep --noexec
+ @(cd ${WRKDIR} && ${SH} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} \
+ --keep --noexec --nox11)
post-patch:
- ${REINPLACE_CMD} -e 's|ok, ans = tui.enter_yes_no.*|ok, ans = 1, 1|' \
- ${WRKSRC}/plugin_install.py
- ${REINPLACE_CMD} -e 's|rules,||;s|rules_alt,||' ${WRKSRC}/plugin.spec
- ${REINPLACE_CMD} -e 's|/etc/hp|${HPLIP_FAKEDIR}|g' \
- ${WRKSRC}/plugin_install.py
+ @${REINPLACE_CMD} -e 's|ok, ans = tui.enter_yes_no.*|ok, ans = 1, 1|' \
+ -e 's|/etc/hp|${HPLIP_FAKEDIR}|' \
+ ${WRKSRC}/plugin_install.py \
+ ${WRKSRC}/installPlugin.py
do-install:
# fake hplip installation
@@ -72,7 +73,8 @@ do-install:
${MKDIR} ${STAGEDIR}/var/lib/hp
# install hplip-plugin
${MKDIR} ${PLUGIN_DIRS:S,^,${STAGEDIR}${PREFIX}/share/hplip/,}
- (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} -B plugin_install.py)
+ (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} -B \
+ plugin_install.py -i)
.for i in ${PLUGIN_LINKS}
${LN} -sf ${i:T}-${LINARCH}.so ${STAGEDIR}${PREFIX}/share/hplip/${i}.so
.endfor