aboutsummaryrefslogtreecommitdiff
path: root/science/orthanc-mysql/Makefile
diff options
context:
space:
mode:
authorFrank Scholl <maintainer.freebsd@xpoundit.com>2021-10-15 09:46:33 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2021-10-15 09:48:25 +0000
commit83a3ec5958d0638476ac0771122ee5fb0410f71a (patch)
treee3bf076795574d12fa0e5f548a498c2cb59ce65f /science/orthanc-mysql/Makefile
parentb2314a73df314c982cf4c62ad52339f9a6af6673 (diff)
downloadports-83a3ec5958d0638476ac0771122ee5fb0410f71a.tar.gz
ports-83a3ec5958d0638476ac0771122ee5fb0410f71a.zip
science/orthanc-mysql: Update to 4.3
Diffstat (limited to 'science/orthanc-mysql/Makefile')
-rw-r--r--science/orthanc-mysql/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/science/orthanc-mysql/Makefile b/science/orthanc-mysql/Makefile
index c63b5c716eb9..6b41ad68762e 100644
--- a/science/orthanc-mysql/Makefile
+++ b/science/orthanc-mysql/Makefile
@@ -1,7 +1,7 @@
# Created by: maintainer.freebsd@xpoundit.com
PORTNAME= orthanc-mysql
-DISTVERSION= 4.0
+DISTVERSION= 4.3
CATEGORIES= science
MASTER_SITES= https://www.orthanc-server.com/downloads/get.php?path=/plugin-mysql/:main \
https://www.orthanc-server.com/downloads/get.php?path=/orthanc/:framework \
@@ -30,12 +30,14 @@ USES= cmake localbase mysql:client python:build ssl
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/OrthancMySQL-${PORTVERSION}
-CMAKE_SOURCE_PATH= ${WRKSRC}/MySQL
-CMAKE_OFF= DBUILD_UNIT_TESTS USE_SYSTEM_ORTHANC_SDK USE_SYSTEM_UUID
+
CMAKE_ARGS= -DORTHANC_FRAMEWORK_ROOT=${WRKSRC}/MySQL/ThirdPartyDownloads/Orthanc-1.9.3/OrthancFramework/Sources \
-DORTHANC_FRAMEWORK_SOURCE=path
-CXXFLAGS+= -I${LOCALBASE}/include -DNDEBUG
+CMAKE_OFF= DBUILD_UNIT_TESTS USE_SYSTEM_ORTHANC_SDK USE_SYSTEM_UUID
+CMAKE_SOURCE_PATH= ${WRKSRC}/MySQL
+
CFLAGS+= -DORTHANC_ENABLE_LOGGING_PLUGIN -DNDEBUG
+CXXFLAGS+= -I${LOCALBASE}/include -DNDEBUG
PLIST_SUB= DISTVERSION=${DISTVERSION}