aboutsummaryrefslogtreecommitdiff
path: root/security/krb5/Makefile
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2014-08-13 18:32:02 +0000
committerCy Schubert <cy@FreeBSD.org>2014-08-13 18:32:02 +0000
commit5b227e8cf8eeb8c96ea5b323cd973a14679eaf62 (patch)
treeb58ffaaf4557d2e2243b76c5038382aafb9f8153 /security/krb5/Makefile
parenta6b7c72ea409c597f8f26604cb3e3c2010f3d0df (diff)
downloadports-5b227e8cf8eeb8c96ea5b323cd973a14679eaf62.tar.gz
ports-5b227e8cf8eeb8c96ea5b323cd973a14679eaf62.zip
Update 1.12.1 --> 1.12.2.
Add readline non-default option.
Notes
Notes: svn path=/head/; revision=364798
Diffstat (limited to 'security/krb5/Makefile')
-rw-r--r--security/krb5/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/security/krb5/Makefile b/security/krb5/Makefile
index f449d1cf639b..28cf6403c062 100644
--- a/security/krb5/Makefile
+++ b/security/krb5/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= krb5
-PORTVERSION= 1.12.1
-PORTREVISION= 4
+PORTVERSION= 1.12.2
CATEGORIES= security
MASTER_SITES= http://web.mit.edu/kerberos/dist/${PORTNAME}/${PORTVERSION:C/^[0-9]*\.[0-9]*/&X/:C/X\.[0-9]*$//:C/X//}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-signed
@@ -26,13 +25,13 @@ KERBEROSV_URL= http://web.mit.edu/kerberos/
USE_PERL5= build
USE_LDCONFIG= yes
USE_CSTD= gnu99
-USE_AUTOTOOLS= libtool
-USES= gettext gmake perl5
+GNU_CONFIGURE= yes
+USES= gettext gmake perl5 libtool:build
CONFIGURE_ARGS?= --enable-shared --without-system-verto
CONFIGURE_ENV= INSTALL="${INSTALL}" YACC="${YACC}"
MAKE_ARGS= INSTALL="${INSTALL}"
-OPTIONS_DEFINE= KRB5_PDF KRB5_HTML DNS_FOR_REALM LDAP
+OPTIONS_DEFINE= KRB5_PDF KRB5_HTML DNS_FOR_REALM LDAP READLINE
OPTIONS_DEFAULT= KRB5_PDF KRB5_HTML
KRB5_PDF_DESC= Install krb5 PDF documentation
KRB5_HTML_DESC= Install krb5 HTML documentation
@@ -68,6 +67,11 @@ PLIST_SUB+= LDAP=""
PLIST_SUB+= LDAP="@comment "
.endif
+.if ${PORT_OPTIONS:MREADLINE}
+USES+= readline:port
+CONFIGURE_ARGS+= --with-readline
+.endif
+
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
.if defined(PROGRAM_TRANSFORM_NAME) && ${PROGRAM_TRANSFORM_NAME} != ""