aboutsummaryrefslogtreecommitdiff
path: root/security/metasploit/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-12-05 11:02:49 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-12-05 11:02:49 +0000
commit062a2f35e3cd8622bc6a6f03a551c27c89f8bd1d (patch)
treec87065240c65cb347f4d0f05e19cbcad84d4df40 /security/metasploit/Makefile
parent369ca89d17cfa147d48bc06a4ae76d02470548b8 (diff)
downloadports-062a2f35e3cd8622bc6a6f03a551c27c89f8bd1d.tar.gz
ports-062a2f35e3cd8622bc6a6f03a551c27c89f8bd1d.zip
Update security/metasploit to 4.10.2
Add new ports needed by this version: security/rubygem-metasploit-concern security/rubygem-metasploit-credential security/rubygem-metasploit-model security/rubygem-meterpreter_bins security/rubygem-recog
Notes
Notes: svn path=/head/; revision=374007
Diffstat (limited to 'security/metasploit/Makefile')
-rw-r--r--security/metasploit/Makefile63
1 files changed, 45 insertions, 18 deletions
diff --git a/security/metasploit/Makefile b/security/metasploit/Makefile
index a4966ff4346c..8a6189d66937 100644
--- a/security/metasploit/Makefile
+++ b/security/metasploit/Makefile
@@ -2,11 +2,9 @@
# $FreeBSD$
PORTNAME= metasploit
-PORTVERSION= 4.9.3
-PORTREVISION= 1
+PORTVERSION= 4.10.2
CATEGORIES= security
-MASTER_SITES= http://downloads.metasploit.com/data/releases/archive/
-DISTNAME= framework-${DISTVERSION}
+MASTER_SITES= GH
MAINTAINER= tanawts@gmail.com
COMMENT= Exploit-Framework for Penetration-Testing
@@ -14,22 +12,35 @@ COMMENT= Exploit-Framework for Penetration-Testing
RUN_DEPENDS= nasm:${PORTSDIR}/devel/nasm \
nmap:${PORTSDIR}/security/nmap \
rubygem-activesupport>=3.0.0:${PORTSDIR}/devel/rubygem-activesupport \
- rubygem-bcrypt-ruby>=0:${PORTSDIR}/security/rubygem-bcrypt-ruby \
+ rubygem-actionpack>=0:${PORTSDIR}/www/rubygem-actionpack \
+ rubygem-bcrypt>=0:${PORTSDIR}/security/rubygem-bcrypt \
+ rubygem-bundler>=0:${PORTSDIR}/sysutils/rubygem-bundler \
+ rubygem-jsobfu>=0.2.0:${PORTSDIR}/www/rubygem-jsobfu \
rubygem-json>=0:${PORTSDIR}/devel/rubygem-json \
+ rubygem-metasploit-concern>=0.3.0:${PORTSDIR}/security/rubygem-metasploit-concern \
+ rubygem-metasploit-model>=0.28.0:${PORTSDIR}/security/rubygem-metasploit-model \
+ rubygem-meterpreter_bins>=0.0.11:${PORTSDIR}/security/rubygem-meterpreter_bins \
rubygem-msgpack>=0:${PORTSDIR}/devel/rubygem-msgpack \
rubygem-nokogiri>=0:${PORTSDIR}/textproc/rubygem-nokogiri \
rubygem-network_interface>=0.0.1:${PORTSDIR}/net/rubygem-network_interface \
- rubygem-packetfu>=1.1.8:${PORTSDIR}/net/rubygem-packetfu \
+ rubygem-packetfu>=1.1.9:${PORTSDIR}/net/rubygem-packetfu \
rubygem-pcaprub>=0:${PORTSDIR}/net/rubygem-pcaprub \
- rubygem-rkelly-remix>=0:${PORTSDIR}/www/rubygem-rkelly-remix \
+ rubygem-railties>=3.0.0:${PORTSDIR}/www/rubygem-railties \
+ rubygem-recog>=1.0:${PORTSDIR}/security/rubygem-recog \
+ rubygem-rb-readline>=0:${PORTSDIR}/devel/rubygem-rb-readline \
rubygem-robots>=0:${PORTSDIR}/www/rubygem-robots \
- rubygem-sqlite3>=0:${PORTSDIR}/databases/rubygem-sqlite3
+ rubygem-rubyzip>=1.1:${PORTSDIR}/archivers/rubygem-rubyzip \
+ rubygem-sqlite3>=0:${PORTSDIR}/databases/rubygem-sqlite3 \
+ rubygem-tzinfo03>=0:${PORTSDIR}/devel/rubygem-tzinfo03
-WRKSRC= ${WRKDIR}/msf3
SCRIPTS= msfbinscan msfcli msfconsole msfd msfelfscan msfencode \
msfmachscan msfpayload msfpescan msfrop msfrpc msfrpcd msfvenom
-NO_BUILD= yes
+USE_GITHUB= yes
+GH_ACCOUNT= rapid7
+GH_PROJECT= metasploit-framework
+GH_COMMIT= 286827c
+
USES= ncurses:port tar:bzip2
USE_RUBY= yes
USE_RUBY_FEATURES= iconv
@@ -38,27 +49,43 @@ OPTIONS_DEFINE= DB
OPTIONS_DEFAULT=DB
DB_DESC= Database support
-DB_RUN_DEPENDS= rubygem-activerecord>=0:${PORTSDIR}/databases/rubygem-activerecord \
- rubygem-metasploit_data_models>=0.17.0:${PORTSDIR}/security/rubygem-metasploit_data_models \
+DB_RUN_DEPENDS= rubygem-activerecord>=3.0.0:${PORTSDIR}/databases/rubygem-activerecord \
+ rubygem-metasploit-credential>=0.13.3:${PORTSDIR}/security/rubygem-metasploit-credential \
+ rubygem-metasploit_data_models>=0.21.1:${PORTSDIR}/security/rubygem-metasploit_data_models \
rubygem-pg>=0.11:${PORTSDIR}/databases/rubygem-pg
+.include <bsd.port.options.mk>
+
post-patch:
- ${REINPLACE_CMD} 's|bundler/setup|rubygems|' ${WRKSRC}/lib/msfenv.rb
+ ${REINPLACE_CMD} 's,git ls-files,find . ! -type d ! -ipath "config/*" | sed "s|^./||", ; \
+ /packetfu/s/1.1.9/>= 1.1.9/' ${WRKSRC}/metasploit-framework.gemspec
+
+do-build:
+ ${RM} ${WRKSRC}/Gemfile.lock
+ ${MKDIR} ${WRKSRC}/log
+ ${TOUCH} ${WRKSRC}/Gemfile.lock ${WRKSRC}/log/production.log
+ ${CHMOD} 666 ${WRKSRC}/Gemfile.lock ${WRKSRC}/log/production.log
+ ${REINPLACE_CMD} '/^group :development/,/^end/d ; /^group :test/,/^end/d' \
+ ${WRKSRC}/Gemfile
+.if ! ${PORT_OPTIONS:MDB}
+ ${REINPLACE_CMD} '/^group :db do/,/^end/d' ${WRKSRC}/Gemfile
+.endif
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${CP} -Rp ${WRKSRC}/ ${STAGEDIR}${DATADIR}
.for f in ${SCRIPTS}
- ${LN} -s ${DATADIR}/${f} ${STAGEDIR}${PREFIX}/bin/${f}
+ ${PRINTF} '#!/bin/sh\ncd ${DATADIR} && ./${f} "$$@"\n' > ${STAGEDIR}${PREFIX}/bin/${f}
+ ${CHMOD} ${BINMODE} ${STAGEDIR}${PREFIX}/bin/${f}
.endfor
post-install:
.for f in ${SCRIPTS}
${ECHO} "bin/${f}" >> ${TMPPLIST}
.endfor
- @${FIND} ${STAGEDIR}${DATADIR} -type f | ${SED} 's,${STAGEDIR}${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${STAGEDIR}${DATADIR} -type l | ${SED} 's,${STAGEDIR}${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${STAGEDIR}${DATADIR} -type d | ${SORT} -r | \
- ${SED} 's,${STAGEDIR}${PREFIX}/,, ; s,^,@dirrm ,' >> ${TMPPLIST}
+ @${FIND} ${STAGEDIR}${DATADIR} ! -type d | \
+ ${SED} 's,${STAGEDIR}${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} -ds ${STAGEDIR}${DATADIR} -type d -empty | \
+ ${SED} 's,${STAGEDIR}${PREFIX}/,, ; s,^,@dir ,' >> ${TMPPLIST}
.include <bsd.port.mk>