aboutsummaryrefslogtreecommitdiff
path: root/security/p5-MD5
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-10-31 02:15:29 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-10-31 02:15:29 +0000
commit1be969103d836d9d1774325e85e5db187b147d0c (patch)
tree7d68bb1bc7aeb99173dcca63f5d4f1432e555c93 /security/p5-MD5
parent1762f5f1ad4e5f5421af683cbc93ab7d945062e5 (diff)
downloadports-1be969103d836d9d1774325e85e5db187b147d0c.tar.gz
ports-1be969103d836d9d1774325e85e5db187b147d0c.zip
- Reformat pkg-descr, add WWW.
- Take maintainership. PR: ports/104235 Submitted by: Thomas Abthorpe <thomas@goodking.ca>
Notes
Notes: svn path=/head/; revision=175590
Diffstat (limited to 'security/p5-MD5')
-rw-r--r--security/p5-MD5/Makefile4
-rw-r--r--security/p5-MD5/pkg-descr44
2 files changed, 27 insertions, 21 deletions
diff --git a/security/p5-MD5/Makefile b/security/p5-MD5/Makefile
index 2cc43c3650cf..4ed912d0ec5b 100644
--- a/security/p5-MD5/Makefile
+++ b/security/p5-MD5/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= MD5/GAAS
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= thomas@goodking.ca
COMMENT= Perl5 interface to MD5 Message-Digest Algorithm
PERL_CONFIGURE= yes
@@ -23,7 +23,7 @@ MAN3= MD5.3
.if ${PERL_LEVEL} < 500800
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
.endif
.include <bsd.port.post.mk>
diff --git a/security/p5-MD5/pkg-descr b/security/p5-MD5/pkg-descr
index 71497090f35b..86fd685a0da5 100644
--- a/security/p5-MD5/pkg-descr
+++ b/security/p5-MD5/pkg-descr
@@ -1,24 +1,30 @@
- The MD5 module allows you to use the RSA Data Security Inc. MD5 Message
-Digest algorithm from within Perl programs.
- A new MD5 context object is created with the new operation. Multiple
-simultaneous digest contexts can be maintained, if desired. The context is
+The MD5 module allows you to use the RSA Data Security Inc. MD5 Message Digest
+algorithm from within Perl programs.
+
+A new MD5 context object is created with the new operation. Multiple
+simultaneous digest contexts can be maintained, if desired. The context is
updated with the add operation which adds the strings contained in the LIST
parameter. Note, however, that add('foo', 'bar'), add('foo') followed by
add('bar') and add('foobar') should all give the same result.
- The final message digest value is returned by the digest operation as a
+
+The final message digest value is returned by the digest operation as a
16-byte binary string. This operation delivers the result of add operations
-since the last new or reset operation. Note that the digest operation is
-effectively a destructive, read-once operation. Once it has been performed, the
-context must be reset before being used to calculate another digest value.
- Several convenience functions are also provided. The addfile operation
-takes an open file-handle and reads it until end-of file in 1024 byte blocks
-adding the contents to the context. The file-handle can either be specified by
-name or passed as a type-glob reference. The hexdigest operation calls digest
-and returns the result as a printable string of hexdecimal digits.
- The hash operation can act as either a static member function (you
-invoke it on the MD5 class) or as a normal virtual function. In both cases it
-performs the complete MD5 cycle (reset, add, digest) on the supplied scalar
-value. This is convenient for handling small quantities of data. When invoked on
-the class a temporary context is created. When invoked through an already
-created context object, this context is used. The latter form is slightly more
+since the last new or reset operation. Note that the digest operation is
+effectively a destructive, read-once operation. Once it has been performed,
+the context must be reset before being used to calculate another digest value.
+
+Several convenience functions are also provided. The addfile operation takes
+an open file-handle and reads it until end-of file in 1024 byte blocks adding
+the contents to the context. The file-handle can either be specified by name
+or passed as a type-glob reference. The hexdigest operation calls digest and
+returns the result as a printable string of hexdecimal digits.
+
+The hash operation can act as either a static member function (you invoke it
+on the MD5 class) or as a normal virtual function. In both cases it performs
+the complete MD5 cycle (reset, add, digest) on the supplied scalar value. This
+is convenient for handling small quantities of data. When invoked on the class
+a temporary context is created. When invoked through an already created
+context object, this context is used. The latter form is slightly more
efficient. The hexhash operation is analogous to hexdigest.
+
+WWW: http://search.cpan.org/~gaas/MD5-2.03/