aboutsummaryrefslogtreecommitdiff
path: root/security/py-m2crypto/files/patch-setup.py
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-03-19 22:25:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-03-19 22:25:17 +0000
commit5e67312f669149cea8cbe93ff4fbf69b26d775a4 (patch)
treed240a86a77d5b94664dd87c730ed3e012e31a488 /security/py-m2crypto/files/patch-setup.py
parentab01e5a9a1d046064d1ec891a9855231877d4d45 (diff)
downloadports-5e67312f669149cea8cbe93ff4fbf69b26d775a4.tar.gz
ports-5e67312f669149cea8cbe93ff4fbf69b26d775a4.zip
- Update to 0.13.1
- Take maintainership PR: ports/79003 Submitted by: Marcus Grando <marcus@corp.grupos.com.br>
Notes
Notes: svn path=/head/; revision=131669
Diffstat (limited to 'security/py-m2crypto/files/patch-setup.py')
-rw-r--r--security/py-m2crypto/files/patch-setup.py59
1 files changed, 59 insertions, 0 deletions
diff --git a/security/py-m2crypto/files/patch-setup.py b/security/py-m2crypto/files/patch-setup.py
new file mode 100644
index 000000000000..3848aa024d10
--- /dev/null
+++ b/security/py-m2crypto/files/patch-setup.py
@@ -0,0 +1,59 @@
+--- setup.py.orig Sun Mar 28 08:06:59 2004
++++ setup.py Fri Mar 18 22:44:10 2005
+@@ -12,56 +12,6 @@
+ from distutils.core import setup, Extension
+ from distutils.command import build_ext
+
+-# This copy of swig_sources is from Python 2.2.
+-
+-def swig_sources (self, sources):
+-
+- """Walk the list of source files in 'sources', looking for SWIG
+- interface (.i) files. Run SWIG on all that are found, and
+- return a modified 'sources' list with SWIG source files replaced
+- by the generated C (or C++) files.
+- """
+-
+- new_sources = []
+- swig_sources = []
+- swig_targets = {}
+-
+- # XXX this drops generated C/C++ files into the source tree, which
+- # is fine for developers who want to distribute the generated
+- # source -- but there should be an option to put SWIG output in
+- # the temp dir.
+-
+- if self.swig_cpp:
+- target_ext = '.cpp'
+- else:
+- target_ext = '.c'
+-
+- for source in sources:
+- (base, ext) = os.path.splitext(source)
+- if ext == ".i": # SWIG interface file
+- new_sources.append(base + target_ext)
+- swig_sources.append(source)
+- swig_targets[source] = new_sources[-1]
+- else:
+- new_sources.append(source)
+-
+- if not swig_sources:
+- return new_sources
+-
+- swig = self.find_swig()
+- swig_cmd = [swig, "-python", "-ISWIG"]
+- if self.swig_cpp:
+- swig_cmd.append("-c++")
+-
+- for source in swig_sources:
+- target = swig_targets[source]
+- self.announce("swigging %s to %s" % (source, target))
+- self.spawn(swig_cmd + ["-o", target, source])
+-
+- return new_sources
+-
+-build_ext.build_ext.swig_sources = swig_sources
+-
+ my_inc = os.path.join(os.getcwd(), 'SWIG')
+
+ if os.name == 'nt':