aboutsummaryrefslogtreecommitdiff
path: root/security/srp/files/patch-telnet::telnetd::sys_term.c
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>2002-01-22 22:40:36 +0000
committerJacques Vidrine <nectar@FreeBSD.org>2002-01-22 22:40:36 +0000
commitc49659f44d12b180ad82e1335ab53afcdede08fb (patch)
tree5296d6422d081fbe43d66a66d937d6ee079cb504 /security/srp/files/patch-telnet::telnetd::sys_term.c
parent91a02f9b6d88ac2604d8bb98014388e9f4d1dcff (diff)
downloadports-c49659f44d12b180ad82e1335ab53afcdede08fb.tar.gz
ports-c49659f44d12b180ad82e1335ab53afcdede08fb.zip
Fix broken pkg-plist: the docs snuck in there, but they are also added
by the port at build-time. Fix for FreeBSD-CURRENT: = Remove use of malloc.h = A fragment of this port actually provides its own prototype for time(), and probably only gets it right on DEC and HP systems. PR: ports/34183 Reported by: Trish Lynch <trish@bsdunix.net>
Notes
Notes: svn path=/head/; revision=53611
Diffstat (limited to 'security/srp/files/patch-telnet::telnetd::sys_term.c')
-rw-r--r--security/srp/files/patch-telnet::telnetd::sys_term.c13
1 files changed, 11 insertions, 2 deletions
diff --git a/security/srp/files/patch-telnet::telnetd::sys_term.c b/security/srp/files/patch-telnet::telnetd::sys_term.c
index 3c83e23f68c9..60fc3b88348b 100644
--- a/security/srp/files/patch-telnet::telnetd::sys_term.c
+++ b/security/srp/files/patch-telnet::telnetd::sys_term.c
@@ -1,5 +1,5 @@
---- telnet/telnetd/sys_term.c.orig Tue Aug 21 09:02:37 2001
-+++ telnet/telnetd/sys_term.c Tue Aug 21 09:03:33 2001
+--- telnet/telnetd/sys_term.c.orig Tue Jul 31 01:27:05 2001
++++ telnet/telnetd/sys_term.c Tue Jan 22 16:31:27 2002
@@ -111,6 +111,9 @@
# else
char wtmpf[] = "/usr/adm/wtmp";
@@ -10,3 +10,12 @@
# ifdef UTMP_FILE
char utmpf[] = UTMP_FILE;
# else
+@@ -1473,7 +1476,7 @@
+ {
+ register int i;
+ int syncpipe[2];
+-#if defined(OSF) || defined(ultrix) || defined(__hpux)
++#if defined(OSF) || defined(ultrix) || defined(__hpux) || defined(__FreeBSD__)
+ time_t time();
+ #else
+ long time();