aboutsummaryrefslogtreecommitdiff
path: root/security/sssd/files/patch-src__external__pac_responder.m4
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-04-15 10:52:38 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-04-16 17:06:28 +0000
commit11964e74b9165c24b41ac8e6960f727d36ac4241 (patch)
treecae9fc58af5553f94b91f04f26a21313d2479402 /security/sssd/files/patch-src__external__pac_responder.m4
parent7e8c7e0b65421657a900eacb88af4f1532736dfc (diff)
downloadports-11964e74b9165c24b41ac8e6960f727d36ac4241.tar.gz
ports-11964e74b9165c24b41ac8e6960f727d36ac4241.zip
security/sssd: Fix package with SMB=on
While here, add comment in security/krb5 to remember the obscure dependency in security/sssd so it does not break again. PR: 244778 Reported by: tommyhp2@gmail.com Tested by: tommyhp2@gmail.com MFH: 2021Q2 (build fix)
Diffstat (limited to 'security/sssd/files/patch-src__external__pac_responder.m4')
-rw-r--r--security/sssd/files/patch-src__external__pac_responder.m49
1 files changed, 4 insertions, 5 deletions
diff --git a/security/sssd/files/patch-src__external__pac_responder.m4 b/security/sssd/files/patch-src__external__pac_responder.m4
index a870a179c34c..870b900c8acf 100644
--- a/security/sssd/files/patch-src__external__pac_responder.m4
+++ b/security/sssd/files/patch-src__external__pac_responder.m4
@@ -1,6 +1,4 @@
-diff --git src/external/pac_responder.m4 src/external/pac_responder.m4
-index dc986a1b8..09efdb139 100644
---- src/external/pac_responder.m4
+--- src/external/pac_responder.m4.orig 2020-03-17 13:31:28 UTC
+++ src/external/pac_responder.m4
@@ -7,7 +7,7 @@ AC_ARG_ENABLE([pac-responder],
krb5_version_ok=no
@@ -11,13 +9,14 @@ index dc986a1b8..09efdb139 100644
AC_MSG_CHECKING(for supported MIT krb5 version)
KRB5_VERSION="`$KRB5_CONFIG --version`"
case $KRB5_VERSION in
-@@ -19,7 +19,8 @@
+@@ -19,7 +19,9 @@ then
Kerberos\ 5\ release\ 1.14* | \
Kerberos\ 5\ release\ 1.15* | \
Kerberos\ 5\ release\ 1.16* | \
- Kerberos\ 5\ release\ 1.17*)
+ Kerberos\ 5\ release\ 1.17* | \
-+ Kerberos\ 5\ release\ 1.18*)
++ Kerberos\ 5\ release\ 1.18* | \
++ Kerberos\ 5\ release\ 1.19*)
krb5_version_ok=yes
AC_MSG_RESULT([yes])
;;