aboutsummaryrefslogtreecommitdiff
path: root/security/tor/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-02-15 18:50:34 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-02-15 18:50:34 +0000
commit1387321eaab72ab6faab81ae6a0ecfa3c367d0ea (patch)
tree662e0d30d2e5bf85e123c6956503e411bdb758d5 /security/tor/Makefile
parent601f956e3be9d0f40553a4ae6f0ecf751348a3c2 (diff)
downloadports-1387321eaab72ab6faab81ae6a0ecfa3c367d0ea.tar.gz
ports-1387321eaab72ab6faab81ae6a0ecfa3c367d0ea.zip
security/tor: Update 0.4.4.7 -> 0.4.5.6
Changelog: https://lists.torproject.org/pipermail/tor-announce/2021-February/000214.html - contains major and minor bugfixes and new features. Port options LTTNG,USDT,LOG_DEBUG backported from security/tor-devel. LIB_DEPENDS is fixes in STATIC_TOR option. Reported by: upstream notification
Notes
Notes: svn path=/head/; revision=565324
Diffstat (limited to 'security/tor/Makefile')
-rw-r--r--security/tor/Makefile29
1 files changed, 23 insertions, 6 deletions
diff --git a/security/tor/Makefile b/security/tor/Makefile
index ff869f4cc8c1..dffcae46aaec 100644
--- a/security/tor/Makefile
+++ b/security/tor/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tor
-DISTVERSION= 0.4.4.7
+DISTVERSION= 0.4.5.6
CATEGORIES= security net
MASTER_SITES= TOR
@@ -23,13 +23,15 @@ CONFIGURE_ENV= TOR_CPPFLAGS_libevent="-I${LOCALBASE}/include" \
TOR_LIBEVENT_LIBS="${TOR_LIBEVENT_LIBS}"
OPTIONS_DEFINE= MANPAGES DOCS STATIC_TOR TCMALLOC
-OPTIONS_GROUP= COMPRESSION
-OPTIONS_GROUP_COMPRESSION=ZSTD LZMA
+OPTIONS_GROUP= COMPRESSION TRACING
+OPTIONS_GROUP_COMPRESSION= ZSTD LZMA
+OPTIONS_GROUP_TRACING= LTTNG USDT LOG_DEBUG
OPTIONS_DEFAULT=MANPAGES ZSTD LZMA
OPTIONS_SUB= yes
STATIC_TOR_DESC= Build a static tor
TCMALLOC_DESC= Use the tcmalloc memory allocation library
COMPRESSION_DESC= Supported compression libraries
+TRACING_DESC= Tracing
USE_RC_SUBR= tor
SUB_FILES= pkg-message
@@ -44,10 +46,23 @@ CONFLICTS_INSTALL= tor-devel
STATIC_TOR_USES= ssl:build
STATIC_TOR_USES_OFF= ssl
+# compression options
ZSTD_CONFIGURE_ENABLE= zstd
ZSTD_CONFIGURE_ENV=TOR_ZSTD_LIBS="${TOR_ZSTD_LIBS}"
LZMA_CONFIGURE_ENABLE= lzma
+# tracing options
+LTTNG_DESC= Build with LTTng-UST instrumentation
+LTTNG_USES= localbase
+LTTNG_CONFIGURE_ENABLE= tracing-instrumentation-lttng
+LTTNG_LIB_DEPENDS= liblttng-ust.so:sysutils/lttng-ust
+USDT_DESC= Build with tracing USDT instrumentation
+USDT_CONFIGURE_ENABLE= tracing-instrumentation-usdt
+USDT_LIB_DEPENDS= liblttng-ust.so:sysutils/lttng-ust
+USDT_BROKEN= error: use of undeclared identifier 'tor_circuit': https://gitlab.torproject.org/tpo/core/tor/-/issues/40174#note_2714275
+LOG_DEBUG_DESC= Build with tracing event to debug log
+LOG_DEBUG_CONFIGURE_ENABLE= tracing-instrumentation-log-debug
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS} || ${PORT_OPTIONS:MMANPAGES}
@@ -71,6 +86,7 @@ TOR_LIBEVENT_LIBS= ${LOCALBASE}/lib/libevent.a
. if ${PORT_OPTIONS:MZSTD}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libzstd.a:archivers/zstd
TOR_ZSTD_LIBS= ${LOCALBASE}/lib/libzstd.a
+LDFLAGS+= -lelf # needed by libexecinfo.a
. endif
.else
CONFIGURE_ARGS+= --enable-linker-hardening
@@ -85,7 +101,8 @@ TOR_ZSTD_LIBS= -lzstd
.if ${PORT_OPTIONS:MTCMALLOC}
CONFIGURE_ARGS+= --with-malloc=tcmalloc
.if ${PORT_OPTIONS:MSTATIC_TOR}
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libtcmalloc.a:devel/google-perftools
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libtcmalloc.a:devel/google-perftools # for static 'tor' executable
+RUN_DEPENDS+= google-perftool>0:devel/google-perftools # for a still-dynamic 'tor-gencert' executable
LDFLAGS+= -lc++ -lm # required by libtcmalloc.a and isn't cocered by google-perftools' `pkg-config --libs libtcmalloc` output
.else
LIB_DEPENDS+= libtcmalloc.so:devel/google-perftools
@@ -101,8 +118,8 @@ post-patch:
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|lib/tor|db/tor|' \
${WRKSRC}/src/config/torrc.*.in \
- ${WRKSRC}/doc/tor.1.* \
- ${WRKSRC}/doc/tor.html.in
+ ${WRKSRC}/doc/man/tor.1.* \
+ ${WRKSRC}/doc/man/tor.html.in
post-install:
@${MKDIR} ${STAGEDIR}/var/log/tor ${STAGEDIR}/var/run/tor ${STAGEDIR}/var/db/tor