aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2010-06-17 21:29:20 +0000
committerDoug Barton <dougb@FreeBSD.org>2010-06-17 21:29:20 +0000
commit21ad6b9819405c295c53b59a358c76c6745063ed (patch)
treeba0cce6f8ca64ddaf240914b27fe4cab55cf90d4 /security
parent6f472dd19ef7cdd5558fb837116b154545702377 (diff)
downloadports-21ad6b9819405c295c53b59a358c76c6745063ed.tar.gz
ports-21ad6b9819405c295c53b59a358c76c6745063ed.zip
Upgrade to version 1.1.0, which has the following changes:
* Fixed a resource problem with LDAP CRLs. * Fixed a bad EOF detection with HTTP CRLs. * Made "dirmngr-client --url --load-crl URL" work. * New option --ignore-cert-extension. * Make use of libassuan 2.0 which is available as a DSO. For the port: * Add the verify target to check the PGP signature of the distfile * Since libassuan is now a shared lib, move it LIB_DEPENDS * The infrastructure for disabling NLS was already present, so add an OPTION Approved by: maintainer
Notes
Notes: svn path=/head/; revision=256630
Diffstat (limited to 'security')
-rw-r--r--security/dirmngr/Makefile18
-rw-r--r--security/dirmngr/distinfo9
2 files changed, 19 insertions, 8 deletions
diff --git a/security/dirmngr/Makefile b/security/dirmngr/Makefile
index b392deb1f12f..bb2b27a73ca6 100644
--- a/security/dirmngr/Makefile
+++ b/security/dirmngr/Makefile
@@ -6,17 +6,18 @@
#
PORTNAME= dirmngr
-PORTVERSION= 1.0.3
-PORTREVISION= 2
+PORTVERSION= 1.1.0
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= dirmngr
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= umq@ueo.co.jp
COMMENT= A client for managing and downloading certificate revocation lists
-BUILD_DEPENDS= libassuan-1>=1.0.5:${PORTSDIR}/security/libassuan-1
-LIB_DEPENDS= gcrypt.16:${PORTSDIR}/security/libgcrypt \
+LIB_DEPENDS= assuan.0:${PORTSDIR}/security/libassuan \
+ gcrypt.16:${PORTSDIR}/security/libgcrypt \
gpg-error.0:${PORTSDIR}/security/libgpg-error \
ksba.17:${PORTSDIR}/security/libksba \
pth:${PORTSDIR}/devel/pth
@@ -32,6 +33,10 @@ MAN1= dirmngr-client.1 dirmngr.1
CONFIGURE_ARGS+= --docdir=${DOCSDIR}
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+OPTIONS= NLS "National Language Support" off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
@@ -40,4 +45,7 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
-.include <bsd.port.mk>
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.sig
+
+.include <bsd.port.post.mk>
diff --git a/security/dirmngr/distinfo b/security/dirmngr/distinfo
index 05274c3688b4..bd1e435cb7b2 100644
--- a/security/dirmngr/distinfo
+++ b/security/dirmngr/distinfo
@@ -1,3 +1,6 @@
-MD5 (dirmngr-1.0.3.tar.bz2) = c1f2028d708e4d4ecbd6d6d647bd938b
-SHA256 (dirmngr-1.0.3.tar.bz2) = 4d22ce423686bcba0a9862bec9d0384a0433fd57e1acb09be4af2b265021c50d
-SIZE (dirmngr-1.0.3.tar.bz2) = 556184
+MD5 (dirmngr-1.1.0.tar.bz2) = f2570f0248f5947daac200e85291b328
+SHA256 (dirmngr-1.1.0.tar.bz2) = eb76d92749d8f9314094376dc3896871c441b0f34b57f25a446c6178a16c93cf
+SIZE (dirmngr-1.1.0.tar.bz2) = 556406
+MD5 (dirmngr-1.1.0.tar.bz2.sig) = fc343a9450dff9222f646d87336c1129
+SHA256 (dirmngr-1.1.0.tar.bz2.sig) = fa19e7a45db57492094e72610db7f46f72402c6b6f1fa02c074d9de79929d0e6
+SIZE (dirmngr-1.1.0.tar.bz2.sig) = 158