aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-11-13 12:54:57 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-11-13 12:54:57 +0000
commitf725dc8ef5848b5e69ebefdc7c1f1517f26643fb (patch)
tree61e738084a4bfbaac41e371a863552bfb8c6ed2a /security
parent985ad018658ea12b1f67b9a76f8252fac0982438 (diff)
downloadports-f725dc8ef5848b5e69ebefdc7c1f1517f26643fb.tar.gz
ports-f725dc8ef5848b5e69ebefdc7c1f1517f26643fb.zip
Use the FIND and XARGS macros introduced in bsd.port.mk 1.391.
Notes
Notes: svn path=/head/; revision=93885
Diffstat (limited to 'security')
-rw-r--r--security/gcipher/Makefile4
-rw-r--r--security/l0phtcrack/Makefile2
-rw-r--r--security/skip/Makefile8
3 files changed, 7 insertions, 7 deletions
diff --git a/security/gcipher/Makefile b/security/gcipher/Makefile
index d67ee0fd8afa..5a9ae341ea7f 100644
--- a/security/gcipher/Makefile
+++ b/security/gcipher/Makefile
@@ -42,7 +42,7 @@ do-install:
(cd ${WRKSRC}/src; \
${INSTALL_SCRIPT} gcipher ${PREFIX}/bin/gcipher; \
${INSTALL_DATA} gcipher.desktop ${PREFIX}/share/gnome/applications; \
- for i in `find . -name '*.py' \
+ for i in `${FIND} . -name '*.py' \
-o -name '*.pyc' \
-o -name '*.glade' \
-o -name '*.gladep'`; do \
@@ -50,7 +50,7 @@ do-install:
done)
(cd ${WRKSRC}/plugins; \
- for i in `find . -name '*.py' \
+ for i in `${FIND} . -name '*.py' \
-o -name '*.glade' \
-o -name '*.gladep'`; do \
${INSTALL_DATA} "$$i" "${GCIPHER_PREFIX}/plugins/$$i"; \
diff --git a/security/l0phtcrack/Makefile b/security/l0phtcrack/Makefile
index bb24f79f37c8..a375b7f56cc2 100644
--- a/security/l0phtcrack/Makefile
+++ b/security/l0phtcrack/Makefile
@@ -32,7 +32,7 @@ do-build:
pre-install:
${ECHO_CMD} bin/lc_CLI > ${PLIST}
.if !defined(NOPORTDOCS)
- for i in `find ${WRKDIR} -name '*txt'`; \
+ for i in `${FIND} ${WRKDIR} -name '*txt'`; \
do ${ECHO_CMD} ${DOCDIR}/`${BASENAME} $${i}` >> ${PLIST}; \
done
${ECHO_CMD} @dirrm ${DOCDIR} >> ${PLIST}
diff --git a/security/skip/Makefile b/security/skip/Makefile
index 49dad581c95f..078f760c5e5d 100644
--- a/security/skip/Makefile
+++ b/security/skip/Makefile
@@ -49,15 +49,15 @@ MAN4= skipd.conf.4 raw_keys.4
# Also, we remove all the "#pragma ident" lines that generate
# a bazillion warnings from the compiler.
post-patch:
- @find ${WRKSRC} -name '*.orig' -print | xargs ${RM}
+ @${FIND} ${WRKSRC} -name '*.orig' -print | ${XARGS} ${RM}
@cd ${WRKSRC}; \
- FILES=`find . -type f -print | xargs ${GREP} -l @@PREFIX@@`; \
+ FILES=`${FIND} . -type f -print | ${XARGS} ${GREP} -l @@PREFIX@@`; \
for FILE in $$FILES; do \
${SED} 's!@@PREFIX@@!${PREFIX}!g' < $$FILE > $$FILE.new ; \
${MV} $$FILE.new $$FILE; \
done; \
- FILES=`find . -type f -name '*.[cCh]' -print \
- | xargs ${GREP} -l '^#pragma ident'`; \
+ FILES=`${FIND} . -type f -name '*.[cCh]' -print \
+ | ${XARGS} ${GREP} -l '^#pragma ident'`; \
for FILE in $$FILES; do \
${SED} '/^#pragma ident/d' < $$FILE > $$FILE.new ; \
${MV} $$FILE.new $$FILE; \