aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-09-26 09:05:59 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-09-26 09:05:59 +0000
commitb34b62504270f2292763071ad4b569292d128eab (patch)
treebd48bdb15c434819e5cee08284fec6bc335e2120 /security
parent3e566dc59013cd5a8f50ca845c296fc562148fbb (diff)
downloadports-b34b62504270f2292763071ad4b569292d128eab.tar.gz
ports-b34b62504270f2292763071ad4b569292d128eab.zip
Convert to USES=pear
Notes
Notes: svn path=/head/; revision=369311
Diffstat (limited to 'security')
-rw-r--r--security/pear-Auth/Makefile64
-rw-r--r--security/pear-Auth_HTTP/Makefile9
-rw-r--r--security/pear-Auth_OpenID/Makefile22
-rw-r--r--security/pear-Auth_PrefManager/Makefile9
-rw-r--r--security/pear-Auth_SASL/Makefile10
-rw-r--r--security/pear-Crypt_Blowfish/Makefile14
-rw-r--r--security/pear-Crypt_CBC/Makefile9
-rw-r--r--security/pear-Crypt_CHAP/Makefile10
-rw-r--r--security/pear-Crypt_DiffieHellman/Makefile10
-rw-r--r--security/pear-Crypt_GPG/Makefile9
-rw-r--r--security/pear-Crypt_HMAC2/Makefile9
-rw-r--r--security/pear-Crypt_MicroID/Makefile9
-rw-r--r--security/pear-Crypt_RC4/Makefile9
-rw-r--r--security/pear-Crypt_RSA/Makefile17
-rw-r--r--security/pear-Crypt_XXTEA/Makefile9
-rw-r--r--security/pear-File_HtAccess/Makefile9
-rw-r--r--security/pear-File_Passwd/Makefile15
-rw-r--r--security/pear-File_SMBPasswd/Makefile6
-rw-r--r--security/pear-HTML_Crypt/Makefile9
-rw-r--r--security/pear-Horde_Auth/Makefile4
-rw-r--r--security/pear-Horde_Crypt/Makefile9
-rw-r--r--security/pear-LiveUser/Makefile36
-rw-r--r--security/pear-LiveUser_Admin/Makefile35
-rw-r--r--security/pear-Net_Portscan/Makefile9
-rw-r--r--security/pear-Text_Password/Makefile6
25 files changed, 82 insertions, 275 deletions
diff --git a/security/pear-Auth/Makefile b/security/pear-Auth/Makefile
index 6fa1fffc560b..bd6e70a282ba 100644
--- a/security/pear-Auth/Makefile
+++ b/security/pear-Auth/Makefile
@@ -8,11 +8,8 @@ CATEGORIES= security pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class for creating an authentication system
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-LATEST_LINK= pear-Auth
OPTIONS_DEFINE= PEAR_LOG PEAR_FILE_PASSWD PEAR_NET_POP3 PEAR_DB PEAR_MDB \
PEAR_MDB2 PEAR_AUTH_RADIUS PEAR_CRYPT_CHAP PEAR_FILE_SMBPASSWD \
PEAR_SOAP PEAR_NET_VPOPMAILD
@@ -28,54 +25,19 @@ PEAR_FILE_SMBPASSWD_DESC= PEAR::File_SMBPasswd support
PEAR_SOAP_DESC= PEAR::SOAP support
PEAR_NET_VPOPMAILD_DESC= PEAR::Net_Vpopmaild support
+PEAR_LOG_RUN_DEPENDS= ${PEARDIR}/Log/syslog.php:${PORTSDIR}/sysutils/pear-Log
+PEAR_FILE_PASSWD_RUN_DEPENDS= ${PEARDIR}/File/Passwd.php:${PORTSDIR}/security/pear-File_Passwd
+PEAR_CRYPT_CHAP_RUN_DEPENDS= ${PEARDIR}/Crypt/CHAP.php:${PORTSDIR}/security/pear-Crypt_CHAP
+PEAR_NET_POP3_RUN_DEPENDS= ${PEARDIR}/Net/POP3.php:${PORTSDIR}/net/pear-Net_POP3
+PEAR_DB_RUN_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+PEAR_MDB_RUN_DEPENDS= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
+PEAR_MDB2_RUN_DEPENDS= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+PEAR_AUTH_RADIUS_RUN_DEPENDS= ${PEARDIR}/Auth/RADIUS.php:${PORTSDIR}/net/pear-Auth_RADIUS
+PEAR_FILE_SMBPASSWD_RUN_DEPENDS= ${PEARDIR}/File/SMBPasswd.php:${PORTSDIR}/security/pear-File_SMBPasswd
+PEAR_SOAP_RUN_DEPENDS= ${PEARDIR}/SOAP/Base.php:${PORTSDIR}/net/pear-SOAP
+PEAR_NET_VPOPMAILD_RUN_DEPENDS= ${PEARDIR}/Net/Vpopmaild.php:${PORTSDIR}/net/pear-Net_Vpopmaild
+
post-extract:
@${REINPLACE_CMD} -e "s|@version@|${PORTVERSION}|" ${WRKSRC}/Auth.php
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPEAR_LOG}
-RUN_DEPENDS+= ${PEARDIR}/Log/syslog.php:${PORTSDIR}/sysutils/pear-Log
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_FILE_PASSWD}
-RUN_DEPENDS+= ${PEARDIR}/File/Passwd.php:${PORTSDIR}/security/pear-File_Passwd
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_CRYPT_CHAP}
-RUN_DEPENDS+= ${PEARDIR}/Crypt/CHAP.php:${PORTSDIR}/security/pear-Crypt_CHAP
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_NET_POP3}
-RUN_DEPENDS+= ${PEARDIR}/Net/POP3.php:${PORTSDIR}/net/pear-Net_POP3
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_DB}
-RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_MDB}
-RUN_DEPENDS+= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_MDB2}
-RUN_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_AUTH_RADIUS}
-RUN_DEPENDS+= ${PEARDIR}/Auth/RADIUS.php:${PORTSDIR}/net/pear-Auth_RADIUS
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_FILE_SMBPASSWD}
-RUN_DEPENDS+= ${PEARDIR}/File/SMBPasswd.php:${PORTSDIR}/security/pear-File_SMBPasswd
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_SOAP}
-RUN_DEPENDS+= ${PEARDIR}/SOAP/Base.php:${PORTSDIR}/net/pear-SOAP
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_NET_VPOPMAILD}
-RUN_DEPENDS+= ${PEARDIR}/Net/Vpopmaild.php:${PORTSDIR}/net/pear-Net_Vpopmaild
-.endif
-
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.mk>
diff --git a/security/pear-Auth_HTTP/Makefile b/security/pear-Auth_HTTP/Makefile
index e4a1df4384bb..032c4a3250f8 100644
--- a/security/pear-Auth_HTTP/Makefile
+++ b/security/pear-Auth_HTTP/Makefile
@@ -7,11 +7,6 @@ CATEGORIES= security www pear
MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR HTTP authentication
-BUILD_DEPENDS= ${PEARDIR}/Auth/Auth.php:${PORTSDIR}/security/pear-Auth
-RUN_DEPENDS= ${PEARDIR}/Auth/Auth.php:${PORTSDIR}/security/pear-Auth
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-Auth_OpenID/Makefile b/security/pear-Auth_OpenID/Makefile
index 45c12021e5a9..4cb444628efd 100644
--- a/security/pear-Auth_OpenID/Makefile
+++ b/security/pear-Auth_OpenID/Makefile
@@ -10,16 +10,13 @@ DISTNAME= php-openid-${PORTVERSION}
MAINTAINER= miwi@FreeBSD.org
COMMENT= PHP OpenID library v2 for PEAR
-RUN_DEPENDS= pear:${PORTSDIR}/devel/pear
-BUILD_DEPENDS:= ${RUN_DEPENDS}
-
CONFLICTS= php-Auth_OpenID-1.*
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= tar:bzip2
-LATEST_LINK= pear-Auth_OpenID
+
+USES= tar:bzip2 pear python:build
WRKSRC= ${WRKDIR}/php-openid-${PORTVERSION}
@@ -28,12 +25,11 @@ BCMATH_DESC= Use bcmath instead of libgmp
PEAR_DB_DESC= Support SQL stores
USE_PHP= curl dom
-USE_PYTHON_BUILD= yes
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-EXTRACT_SUFX= .tar.bz2
+PEAR_DB_BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+PEAR_DB_RUN_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MBCMATH}
USE_PHP+= bcmath
@@ -41,12 +37,8 @@ USE_PHP+= bcmath
USE_PHP+= gmp
.endif
-.if ${PORT_OPTIONS:MPEAR_DB}
-BUILD_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
-RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
-.endif
post-configure:
@cd ${WRKSRC}/admin && ${PYTHON_CMD} packagexml.py ${PORTVERSION} package2.xml ../CHANGELOG > ${WRKDIR}/package.xml
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-Auth_PrefManager/Makefile b/security/pear-Auth_PrefManager/Makefile
index 8042810386ae..6d2c68d9c6fd 100644
--- a/security/pear-Auth_PrefManager/Makefile
+++ b/security/pear-Auth_PrefManager/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= security www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR preferences management class
-BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
-RUN_DEPENDS:= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-Auth_SASL/Makefile b/security/pear-Auth_SASL/Makefile
index cc756b2fe886..8fc7190536f1 100644
--- a/security/pear-Auth_SASL/Makefile
+++ b/security/pear-Auth_SASL/Makefile
@@ -10,11 +10,9 @@ COMMENT= PEAR abstraction of various SASL mechanism responses
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= ${PEARDIR}/Auth/Auth.php:${PORTSDIR}/security/pear-Auth
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+USES= pear
-PEAR_AUTOINSTALL= yes
+BUILD_DEPENDS= ${PEARDIR}/Auth/Auth.php:${PORTSDIR}/security/pear-Auth
+RUN_DEPENDS= ${PEARDIR}/Auth/Auth.php:${PORTSDIR}/security/pear-Auth
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-Crypt_Blowfish/Makefile b/security/pear-Crypt_Blowfish/Makefile
index d29f14f68b0b..fc6ca608cc63 100644
--- a/security/pear-Crypt_Blowfish/Makefile
+++ b/security/pear-Crypt_Blowfish/Makefile
@@ -9,14 +9,12 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/RC/}
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class for blowfish encryption
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
+OPTIONS_DEFINE= MCRYPT
+MCRYPT_DESC= Additional MCrypt PHP support
-.if defined(WITH_PHP_MCRYPT)
-USE_PHP=mcrypt
-.endif
+MCRYPT_USE= PHP=mcrypt
pre-fetch:
@${ECHO_CMD} ""
@@ -29,6 +27,4 @@ post-patch:
@${REINPLACE_CMD} -e "s|@package_version@|${PORTVERSION}|" ${WRKSRC}/${file}
.endfor
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-Crypt_CBC/Makefile b/security/pear-Crypt_CBC/Makefile
index 86a1735c7e61..d473b434b444 100644
--- a/security/pear-Crypt_CBC/Makefile
+++ b/security/pear-Crypt_CBC/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= security www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class to emulate Perl's Crypt::CBC module
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-Crypt_CHAP/Makefile b/security/pear-Crypt_CHAP/Makefile
index 9acc12d9e1e2..a810aaec3545 100644
--- a/security/pear-Crypt_CHAP/Makefile
+++ b/security/pear-Crypt_CHAP/Makefile
@@ -8,13 +8,7 @@ CATEGORIES= security www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class for generating CHAP packets
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-
+USES= pear
USE_PHP= mcrypt mhash
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-Crypt_DiffieHellman/Makefile b/security/pear-Crypt_DiffieHellman/Makefile
index 7b91fb6809e9..f74bb06894d7 100644
--- a/security/pear-Crypt_DiffieHellman/Makefile
+++ b/security/pear-Crypt_DiffieHellman/Makefile
@@ -8,13 +8,7 @@ CATEGORIES= security www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class implementing Diffie-Hellman Key Exchange protocol for PHP5
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-
+USES= pear
USE_PHP= bcmath mbstring gmp
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-Crypt_GPG/Makefile b/security/pear-Crypt_GPG/Makefile
index c21d480eefa6..728a32889320 100644
--- a/security/pear-Crypt_GPG/Makefile
+++ b/security/pear-Crypt_GPG/Makefile
@@ -8,12 +8,7 @@ CATEGORIES= security www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= GNU Privacy Guard (GPG)
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-
+USES= pear
USE_PHP= posix
-PEAR_AUTOINSTALL=yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-Crypt_HMAC2/Makefile b/security/pear-Crypt_HMAC2/Makefile
index 8b2ab8295f40..91d204ca35e4 100644
--- a/security/pear-Crypt_HMAC2/Makefile
+++ b/security/pear-Crypt_HMAC2/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= security www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Implementation of Hashed Message Authentication Code for PHP5
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-Crypt_MicroID/Makefile b/security/pear-Crypt_MicroID/Makefile
index e130c920e1a7..f19f690c9833 100644
--- a/security/pear-Crypt_MicroID/Makefile
+++ b/security/pear-Crypt_MicroID/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= security www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PHP MicroID library
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-Crypt_RC4/Makefile b/security/pear-Crypt_RC4/Makefile
index 09adf8509276..eb306551d19e 100644
--- a/security/pear-Crypt_RC4/Makefile
+++ b/security/pear-Crypt_RC4/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= security www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR encryption class for RC4 encryption
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-Crypt_RSA/Makefile b/security/pear-Crypt_RSA/Makefile
index 255587711304..a3d67a9931ac 100644
--- a/security/pear-Crypt_RSA/Makefile
+++ b/security/pear-Crypt_RSA/Makefile
@@ -9,24 +9,13 @@ CATEGORIES= security www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class allows you to use two-key strong cryptography
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
OPTIONS_DEFINE= BCMATH GMP
BCMATH_DESC= PHP BCMath extension support
GMP_DESC= PHP GMP extension support
-LATEST_LINK= pear-${PORTNAME}
+BCMATH_USE= PHP=bcmath
+GMP_USE= PHP=gmp
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.options.mk>
-
-.for opt in BCMATH GMP
-. if ${PORT_OPTIONS:M${opt}}
-USE_PHP+= ${opt:tl}
-. endif
-.endfor
-
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.mk>
diff --git a/security/pear-Crypt_XXTEA/Makefile b/security/pear-Crypt_XXTEA/Makefile
index 13fcfadd1cb3..272d51e31c8d 100644
--- a/security/pear-Crypt_XXTEA/Makefile
+++ b/security/pear-Crypt_XXTEA/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= security www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR XXTEA encryption algorithm
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-File_HtAccess/Makefile b/security/pear-File_HtAccess/Makefile
index e1911a88933f..9dd3f38b7700 100644
--- a/security/pear-File_HtAccess/Makefile
+++ b/security/pear-File_HtAccess/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= security www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class to manipulate .htaccess files
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-File_Passwd/Makefile b/security/pear-File_Passwd/Makefile
index 764fca887353..a0b84d46873e 100644
--- a/security/pear-File_Passwd/Makefile
+++ b/security/pear-File_Passwd/Makefile
@@ -8,20 +8,11 @@ CATEGORIES= security pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class to manipulate many kinds of password files
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-LATEST_LINK= pear-File_Passwd
OPTIONS_DEFINE= PEAR_CRYPT_CHAP
PEAR_CRYPT_CHAP_DESC= PEAR::Crypt_CHAP support
-PEAR_AUTOINSTALL= yes
+PEAR_CRYPT_CHAP_RUN_DEPENDS= ${PEARDIR}/Crypt/CHAP.php:${PORTSDIR}/security/pear-Crypt_CHAP
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MPEAR_CRYPT_CHAP}
-RUN_DEPENDS+= ${PEARDIR}/Crypt/CHAP.php:${PORTSDIR}/security/pear-Crypt_CHAP
-.endif
-
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-File_SMBPasswd/Makefile b/security/pear-File_SMBPasswd/Makefile
index e44ab869a376..c752352e2f4d 100644
--- a/security/pear-File_SMBPasswd/Makefile
+++ b/security/pear-File_SMBPasswd/Makefile
@@ -11,9 +11,7 @@ COMMENT= PEAR class for managing SAMBA style password files
BUILD_DEPENDS= ${PEARDIR}/Crypt/CHAP.php:${PORTSDIR}/security/pear-Crypt_CHAP
RUN_DEPENDS= ${PEARDIR}/Crypt/CHAP.php:${PORTSDIR}/security/pear-Crypt_CHAP
+USES= pear
USE_PHP= mhash
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-HTML_Crypt/Makefile b/security/pear-HTML_Crypt/Makefile
index df0a5554109d..70d71dcf738e 100644
--- a/security/pear-HTML_Crypt/Makefile
+++ b/security/pear-HTML_Crypt/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= security www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Encrypts text which is later decoded using JavaScript on the client side
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-Horde_Auth/Makefile b/security/pear-Horde_Auth/Makefile
index fdcd2b390360..28a8901a0175 100644
--- a/security/pear-Horde_Auth/Makefile
+++ b/security/pear-Horde_Auth/Makefile
@@ -10,6 +10,4 @@ COMMENT= Horde Authentication API
USE_HORDE_RUN= Horde_Exception Horde_Util
USE_PHP= hash
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-Horde_Crypt/Makefile b/security/pear-Horde_Crypt/Makefile
index b3f114c4d512..1e026e4400e6 100644
--- a/security/pear-Horde_Crypt/Makefile
+++ b/security/pear-Horde_Crypt/Makefile
@@ -19,11 +19,6 @@ USE_HORDE_RUN= Horde_Exception \
Horde_Util
USE_PHP= hash openssl
-.include <bsd.port.pre.mk>
+BCMATH_USE= PHP=bcmath
-.if ${PORT_OPTIONS:MBCMATH}
-USE_PHP+= bcmath
-.endif
-
-.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-LiveUser/Makefile b/security/pear-LiveUser/Makefile
index a34bf53174a0..b7f5021f348a 100644
--- a/security/pear-LiveUser/Makefile
+++ b/security/pear-LiveUser/Makefile
@@ -13,7 +13,7 @@ RUN_DEPENDS= ${PEARDIR}/Event/Dispatcher.php:${PORTSDIR}/devel/pear-Event_Dispat
PORTSCOUT= skipv:0.61
-LATEST_LINK= pear-LiveUser
+USES= pear
OPTIONS_DEFINE= PEAD_DB PEAR_MDB PEAR_MDB2 PEAR_LOG PEAR_XML_TREE PEAR_CRYPT_RC4
PEAR_DB_DESC= PEAR::DB support
@@ -23,33 +23,11 @@ PEAR_LOG_DESC= PEAR::Log support
PEAR_XML_TREE_DESC= PEAR::XML_Tree support
PEAR_CRYPT_RC4_DESC= PEAR::Crypt_RC4 support
-PEAR_AUTOINSTALL=yes
+PEAR_DB_RUN_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+PEAR_MDB_RUN_DEPENDS= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
+PEAR_MDB2_RUN_DEPENDS= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+PEAR_LOG_RUN_DEPENDS= ${PEARDIR}/Log/null.php:${PORTSDIR}/sysutils/pear-Log
+PEAR_XML_TREE_RUN_DEPENDS= ${PEARDIR}/XML/Tree.php:${PORTSDIR}/devel/pear-XML_Tree
+PEAR_CRYPT_RC4_RUN_DEPENDS= ${PEARDIR}/Crypt/Rc4.php:${PORTSDIR}/security/pear-Crypt_RC4
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPEAR_DB}
-RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_MDB}
-RUN_DEPENDS+= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_MDB2}
-RUN_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_LOG}
-RUN_DEPENDS+= ${PEARDIR}/Log/null.php:${PORTSDIR}/sysutils/pear-Log
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_XML_TREE}
-RUN_DEPENDS+= ${PEARDIR}/XML/Tree.php:${PORTSDIR}/devel/pear-XML_Tree
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_CRYPT_RC4}
-RUN_DEPENDS+= ${PEARDIR}/Crypt/Rc4.php:${PORTSDIR}/security/pear-Crypt_RC4
-.endif
-
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.mk>
diff --git a/security/pear-LiveUser_Admin/Makefile b/security/pear-LiveUser_Admin/Makefile
index 052b01d80636..6ef365333747 100644
--- a/security/pear-LiveUser_Admin/Makefile
+++ b/security/pear-LiveUser_Admin/Makefile
@@ -12,7 +12,6 @@ COMMENT= PEAR user authentication and permission management framework
BUILD_DEPENDS= ${PEARDIR}/LiveUser.php:${PORTSDIR}/security/pear-LiveUser
RUN_DEPENDS= ${PEARDIR}/LiveUser.php:${PORTSDIR}/security/pear-LiveUser
-LATEST_LINK= pear-LiveUser_Admin
OPTIONS_DEFINE= PEAR_DB PEAR_MDB PEAR_MDB2 PEAR_LOG PEAR_XML_TREE PEAR_CRYPT_RC4
PEAR_DB_DESC= PEAR::DB support
@@ -22,33 +21,13 @@ PEAR_LOG_DESC= PEAR::Log support
PEAR_XML_TREE_DESC= PEAR::XML_Tree support
PEAR_CRYPT_RC4_DESC= PEAR::Crypt_RC4 support
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.options.mk>
+PEAR_DB_RUN_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+PEAR_MDB_RUN_DEPENDS= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
+PEAR_MDB2_RUN_DEPENDS= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+PEAR_LOG_RUN_DEPENDS= ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
+PEAR_XML_TREE_RUN_DEPENDS= ${PEARDIR}/XML/Tree.php:${PORTSDIR}/devel/pear-XML_Tree
+PEAR_CRYPT_RC4_RUN_DEPENDS= ${PEARDIR}/Crypt/Rc4.php:${PORTSDIR}/security/pear-Crypt_RC4
-.if ${PORT_OPTIONS:MPEAR_DB}
-RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_MDB}
-RUN_DEPENDS+= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_MDB2}
-RUN_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_LOG}
-RUN_DEPENDS+= ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_XML_TREE}
-RUN_DEPENDS+= ${PEARDIR}/XML/Tree.php:${PORTSDIR}/devel/pear-XML_Tree
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_CRYPT_RC4}
-RUN_DEPENDS+= ${PEARDIR}/Crypt/Rc4.php:${PORTSDIR}/security/pear-Crypt_RC4
-.endif
-
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.mk>
diff --git a/security/pear-Net_Portscan/Makefile b/security/pear-Net_Portscan/Makefile
index a0df42e07f8d..fb5be8e63dc7 100644
--- a/security/pear-Net_Portscan/Makefile
+++ b/security/pear-Net_Portscan/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= security pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Provides an API for scanning ports
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pear-Text_Password/Makefile b/security/pear-Text_Password/Makefile
index b65b4b63ba75..4c4d40c836da 100644
--- a/security/pear-Text_Password/Makefile
+++ b/security/pear-Text_Password/Makefile
@@ -9,9 +9,7 @@ MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR random password creator
USE_PHP= yes
-PEAR_AUTOINSTALL= yes
+USES= pear
WRKSRC= ${WRKDIR}/Text_Password-${PORTVERSION}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>