aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2019-01-13 21:22:06 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2019-01-13 21:22:06 +0000
commitb48ed2e966e3918af26f3b2b39679a4306f3e3b8 (patch)
tree7bb4bf558b2da3587f3c95ed524f9f97aa626f44 /security
parent708788889cd6ee1227715b5b791ca15c2757ab42 (diff)
downloadports-b48ed2e966e3918af26f3b2b39679a4306f3e3b8.tar.gz
ports-b48ed2e966e3918af26f3b2b39679a4306f3e3b8.zip
Deprecate everything that depends on net/GeoIP and everything that depends
on those ports.
Notes
Notes: svn path=/head/; revision=490213
Diffstat (limited to 'security')
-rw-r--r--security/barnyard2/Makefile7
-rw-r--r--security/bro/Makefile3
-rw-r--r--security/broccoli/Makefile3
-rw-r--r--security/modsecurity3/Makefile3
-rw-r--r--security/sguil/Makefile3
-rw-r--r--security/snort/Makefile5
-rw-r--r--security/snortreport/Makefile6
7 files changed, 30 insertions, 0 deletions
diff --git a/security/barnyard2/Makefile b/security/barnyard2/Makefile
index 4cf7f5484f97..70ce33ad7587 100644
--- a/security/barnyard2/Makefile
+++ b/security/barnyard2/Makefile
@@ -68,6 +68,13 @@ PORT_PCAP_LIB_DEPENDS= libpcap.so.1:net/libpcap
PORT_PCAP_CONFIGURE_ON= --with-libpcap-includes=${LOCALBASE}/include \
--with-libpcap-libraries=${LOCALBASE}/lib
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MBRO}
+DEPRECATED= Uses legacy GeoIP 1 format which no longer works; switch to GeoIP 2 where possible
+EXPIRATION_DATE=2019-02-15
+.endif
+
post-patch:
@${REINPLACE_CMD} 's|/etc|${LOCALBASE}/etc|' \
${WRKSRC}/etc/barnyard2.conf
diff --git a/security/bro/Makefile b/security/bro/Makefile
index e313a5adc081..255141a1447a 100644
--- a/security/bro/Makefile
+++ b/security/bro/Makefile
@@ -16,6 +16,9 @@ BROKEN_powerpc64= Does not build: error: zero-size array 'names'
LIB_DEPENDS= libGeoIP.so:net/GeoIP
+DEPRECATED= Uses legacy GeoIP 1 format which no longer works; switch to GeoIP 2 where possible
+EXPIRATION_DATE=2019-02-15
+
USES= bison cmake compiler:c++11-lang gettext-runtime ninja perl5 python shebangfix ssl
CMAKE_ARGS+= -DPYTHON_EXECUTABLE:PATH=${PYTHON_CMD}
diff --git a/security/broccoli/Makefile b/security/broccoli/Makefile
index cfc93ad4bf7c..8601bd104946 100644
--- a/security/broccoli/Makefile
+++ b/security/broccoli/Makefile
@@ -16,6 +16,9 @@ LICENSE= BSD3CLAUSE
BUILD_DEPENDS= swig3.0:devel/swig30
LIB_DEPENDS= libGeoIP.so:net/GeoIP
+DEPRECATED= Uses legacy GeoIP 1 format which no longer works; switch to GeoIP 2 where possible
+EXPIRATION_DATE=2019-02-15
+
EXTRACT_AFTER_ARGS= ${DISTNAME}/aux/broccoli
USES= cmake ssl bison
diff --git a/security/modsecurity3/Makefile b/security/modsecurity3/Makefile
index 2a6006e07e5b..e380d077b5c3 100644
--- a/security/modsecurity3/Makefile
+++ b/security/modsecurity3/Makefile
@@ -14,6 +14,9 @@ COMMENT= Intrusion detection and prevention engine
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Uses legacy GeoIP 1 format which no longer works; switch to GeoIP 2 where possible
+EXPIRATION_DATE=2019-02-15
+
LIB_DEPENDS= libcurl.so:ftp/curl \
libpcre.so:devel/pcre \
libyajl.so:devel/yajl \
diff --git a/security/sguil/Makefile b/security/sguil/Makefile
index 625568de371c..282a414984db 100644
--- a/security/sguil/Makefile
+++ b/security/sguil/Makefile
@@ -93,6 +93,9 @@ SUB_FILES= pkg-message-server
.endif
.if ${PORT_OPTIONS:MSENSOR}
+DEPRECATED= Uses legacy GeoIP 1 format which no longer works; switch to GeoIP 2 where possible
+EXPIRATION_DATE=2019-02-15
+
USE_RC_SUBR+= pcap_agent snort_agent
SUB_FILES= pkg-message-sensor
WITH_PCRE= true
diff --git a/security/snort/Makefile b/security/snort/Makefile
index dfeb95129df9..0342e1f71035 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -85,6 +85,11 @@ APPID_CONFIGURE_ENV+= luajit_CFLAGS="-I${LOCALBASE}/include/luajit-2.0" \
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MBARNYARD}
+DEPRECATED= Uses legacy GeoIP 1 format which no longer works; switch to GeoIP 2 where possible
+EXPIRATION_DATE=2019-02-15
+.endif
+
CONFIG_FILES= classification.config gen-msg.map reference.config \
snort.conf threshold.conf unicode.map file_magic.conf
diff --git a/security/snortreport/Makefile b/security/snortreport/Makefile
index 7827b6335f58..f0a167c0bf64 100644
--- a/security/snortreport/Makefile
+++ b/security/snortreport/Makefile
@@ -29,6 +29,12 @@ USES= php:web
MYSQL_USE= php=mysql
PGSQL_USE= php=pgsql
+.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MBARNYARD}
+DEPRECATED= Uses legacy GeoIP 1 format which no longer works; switch to GeoIP 2 where possible
+EXPIRATION_DATE=2019-02-15
+.endif
+
pre-everything::
@${ECHO} ""
@${ECHO} "You have to configure PHP either with MySQL or PostgreSQL"