aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-09-05 17:34:18 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-09-05 17:34:22 +0000
commitb717c5de9107bb3b4b8ab131bc1018def14be5ef (patch)
treea16d4176113439b3dddd6af33dc38ec5c617a1e4 /security
parent135d071fb4846c5e44253e896d9d14bfda14b393 (diff)
downloadports-b717c5de9107bb3b4b8ab131bc1018def14be5ef.tar.gz
ports-b717c5de9107bb3b4b8ab131bc1018def14be5ef.zip
security/sks: unbreak against safe-by-default strings in OCaml 4.06+.
Diffstat (limited to 'security')
-rw-r--r--security/sks/Makefile2
-rw-r--r--security/sks/files/patch-Makefile12
2 files changed, 12 insertions, 2 deletions
diff --git a/security/sks/Makefile b/security/sks/Makefile
index 93a60784edcb..823a8822b3e4 100644
--- a/security/sks/Makefile
+++ b/security/sks/Makefile
@@ -33,6 +33,8 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e '/^CC=/d; /^CFLAGS=/s/=/+=/' ${WRKSRC}/bdb/Makefile
+ @${REINPLACE_CMD} -E '/^\+OCAML(C|OPT)=/s,$$, -unsafe-string,' \
+ ${WRKSRC}/cryptokit-1.7-sks.patch
pre-build:
@cd ${WRKSRC} && test -f .depend || ${MAKE_CMD} dep
diff --git a/security/sks/files/patch-Makefile b/security/sks/files/patch-Makefile
index 86d7c495fa7a..f7071a5b7447 100644
--- a/security/sks/files/patch-Makefile
+++ b/security/sks/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2019-06-06 15:28:32 UTC
+--- Makefile.orig 2021-09-05 17:11:36 UTC
+++ Makefile
-@@ -15,9 +15,8 @@
+@@ -15,16 +15,15 @@
# USA
#
CINCLUDES=-I`ocamlc -where`
@@ -11,6 +11,14 @@
CXXFLAGS=-O3 $(CINCLUDES) -I .
ifndef OCAMLC
+ OCAMLC=ocamlc
+ endif
+ ifndef OCAMLOPT
+- OCAMLOPT=ocamlopt
++ OCAMLOPT=ocamlopt -unsafe-string
+ endif
+ ifndef CAMLP4O
+ CAMLP4O=camlp4o
@@ -135,16 +134,16 @@ keyMerge.cmx: keyMerge.ml
# Special targets