aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hal
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2011-07-02 18:21:45 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2011-07-02 18:21:45 +0000
commit80cd28094be8f47784bc46f2031d384acda6787f (patch)
treee65c6c13457492723f0605fdb6aff11fbc0982cb /sysutils/hal
parentcbdb33d26abc306e4392bcca6f68e63155992cb2 (diff)
downloadports-80cd28094be8f47784bc46f2031d384acda6787f.tar.gz
ports-80cd28094be8f47784bc46f2031d384acda6787f.zip
Fix some minor issues with USB device properties.
Submitted by: hps
Notes
Notes: svn path=/head/; revision=276922
Diffstat (limited to 'sysutils/hal')
-rw-r--r--sysutils/hal/Makefile2
-rw-r--r--sysutils/hal/files/patch-hald_freebsd_probe-usb2-device.c32
2 files changed, 33 insertions, 1 deletions
diff --git a/sysutils/hal/Makefile b/sysutils/hal/Makefile
index 5e97f9e9a43d..356b4bb40542 100644
--- a/sysutils/hal/Makefile
+++ b/sysutils/hal/Makefile
@@ -8,7 +8,7 @@
PORTNAME= hal
DISTVERSION= 0.5.14
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= sysutils
MASTER_SITES= http://hal.freedesktop.org/releases/
diff --git a/sysutils/hal/files/patch-hald_freebsd_probe-usb2-device.c b/sysutils/hal/files/patch-hald_freebsd_probe-usb2-device.c
new file mode 100644
index 000000000000..35a8690095d8
--- /dev/null
+++ b/sysutils/hal/files/patch-hald_freebsd_probe-usb2-device.c
@@ -0,0 +1,32 @@
+--- hald/freebsd/probing/probe-usb2-device.c.orig 2011-06-30 13:46:55.000000000 +0200
++++ hald/freebsd/probing/probe-usb2-device.c 2011-06-30 13:49:19.000000000 +0200
+@@ -148,15 +148,16 @@
+ bcdspeed = 0x01200;
+ break;
+ case LIBUSB20_SPEED_HIGH:
++ case LIBUSB20_SPEED_VARIABLE:
+ speed = 480.0;
+ bcdspeed = 0x48000;
+ break;
+ case LIBUSB20_SPEED_SUPER:
+- speed = 4800.0;
+- bcdspeed = 0x480000;
++ speed = 5000.0;
++ bcdspeed = 0x500000;
+ break;
+ default:
+- ;
++ break;
+ }
+
+ libhal_device_set_property_double(hfp_ctx, hfp_udi, "usb_device.speed",
+@@ -169,6 +170,9 @@
+ case UD_USB_2_0:
+ version = 2.0;
+ break;
++ case 0x0250:
++ version = 2.5;
++ break;
+ case UD_USB_3_0:
+ version = 3.0;
+ break;