aboutsummaryrefslogtreecommitdiff
path: root/sysutils/libg15render/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2020-12-15 22:04:05 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2020-12-15 22:04:05 +0000
commitaa68fe71b1cb0bf0ad4a3e261c83b09f0d9733f2 (patch)
tree897bffd88d8e99060f6074270c9f54b8618970d1 /sysutils/libg15render/Makefile
parent41148365febee7271d3bcc397a242fe1cc8a596a (diff)
downloadports-aa68fe71b1cb0bf0ad4a3e261c83b09f0d9733f2.tar.gz
ports-aa68fe71b1cb0bf0ad4a3e261c83b09f0d9733f2.zip
Add sysutils/libg15 and sysutils/libg15render:
API and library for control of LCD and the extra keys on Logitech keyboards. PR: 250429 PR: 250430 Submitted by: Daniel Menelkir
Notes
Notes: svn path=/head/; revision=558187
Diffstat (limited to 'sysutils/libg15render/Makefile')
-rw-r--r--sysutils/libg15render/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/sysutils/libg15render/Makefile b/sysutils/libg15render/Makefile
new file mode 100644
index 000000000000..3848a9bc3080
--- /dev/null
+++ b/sysutils/libg15render/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= libg15render
+PORTVERSION= 1.2
+CATEGORIES= sysutils
+MASTER_SITES= SF/g15tools/libg15render/${PORTVERSION}
+
+MAINTAINER= menelkir@itroll.org
+COMMENT= Library to render the LCD screen on Logitech keyboards
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libg15.so:sysutils/libg15
+
+USES= compiler:gcc-c++11-lib gmake libtool tar:bzip2
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>