aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ntfsprogs
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-03-21 13:15:45 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-03-21 13:15:45 +0000
commite2401df6fb09851667fe6d021d40d47cf90c27b7 (patch)
tree58828705a8daac0133ba45b11d30f7d952b457ec /sysutils/ntfsprogs
parent087dc5cd5a5cb8fa485225dabc2b20745e868eaa (diff)
downloadports-e2401df6fb09851667fe6d021d40d47cf90c27b7.tar.gz
ports-e2401df6fb09851667fe6d021d40d47cf90c27b7.zip
- Fix ntfsprogs by removing fcntl(2) locks.
PR: ports/74233 Submitted by: Geoff Buckingham <geoff.buckingham@reuters.com> Reviewed by: Jilles Tjoelker <jilles@stack.nl>
Notes
Notes: svn path=/head/; revision=131834
Diffstat (limited to 'sysutils/ntfsprogs')
-rw-r--r--sysutils/ntfsprogs/Makefile1
-rw-r--r--sysutils/ntfsprogs/files/patch-libntfs::unix_io.c30
2 files changed, 31 insertions, 0 deletions
diff --git a/sysutils/ntfsprogs/Makefile b/sysutils/ntfsprogs/Makefile
index c2e479ffd573..a8d2028d702e 100644
--- a/sysutils/ntfsprogs/Makefile
+++ b/sysutils/ntfsprogs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ntfsprogs
PORTVERSION= 1.9.4
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= linux-ntfs
diff --git a/sysutils/ntfsprogs/files/patch-libntfs::unix_io.c b/sysutils/ntfsprogs/files/patch-libntfs::unix_io.c
new file mode 100644
index 000000000000..d91955b16f15
--- /dev/null
+++ b/sysutils/ntfsprogs/files/patch-libntfs::unix_io.c
@@ -0,0 +1,30 @@
+--- libntfs/unix_io.c.orig Mon Mar 21 12:16:42 2005
++++ libntfs/unix_io.c Mon Mar 21 12:17:19 2005
+@@ -72,6 +72,7 @@
+ flk.l_type = F_WRLCK;
+ flk.l_whence = SEEK_SET;
+ flk.l_start = flk.l_len = 0LL;
++#if 0
+ if (fcntl(DEV_FD(dev), F_SETLK, &flk)) {
+ err = errno;
+ Dprintf("ntfs_device_unix_io_open: Could not lock %s for %s: "
+@@ -83,6 +84,7 @@
+ strerror(errno));
+ goto err_out;
+ }
++#endif
+ /* Set our open flag. */
+ NDevSetOpen(dev);
+ return 0;
+@@ -108,9 +110,11 @@
+ flk.l_type = F_UNLCK;
+ flk.l_whence = SEEK_SET;
+ flk.l_start = flk.l_len = 0LL;
++#if 0
+ if (fcntl(DEV_FD(dev), F_SETLK, &flk))
+ Dprintf("ntfs_device_unix_io_close: Warning: Could not unlock "
+ "%s: %s\n", dev->d_name, strerror(errno));
++#endif
+ /* Close the file descriptor and clear our open flag. */
+ if (close(DEV_FD(dev)))
+ return -1;