aboutsummaryrefslogtreecommitdiff
path: root/sysutils/reptyr
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-07-17 18:57:42 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-07-17 18:57:42 +0000
commit5524af9551f0c199dd3d3c3e8ee7659b5d351dad (patch)
tree8cabce7e28fd9f323cc66a19d6c800eb3f83d496 /sysutils/reptyr
parent848ceb79401f23abc6e4dcc2ca158061de4e10fc (diff)
downloadports-5524af9551f0c199dd3d3c3e8ee7659b5d351dad.tar.gz
ports-5524af9551f0c199dd3d3c3e8ee7659b5d351dad.zip
New port: sysutils/reptyr
reptyr is a utility for taking an existing running program and attaching it to a new terminal. Started a long-running process over ssh, but have to leave and don't want to interrupt it? Just start a screen, use reptyr to grab it, and then kill the ssh session and head on home. WWW: http://github.com/nelhage/reptyr PR: 200720 Submitted by: Andrey Cherkashin <andoriyu@gmail.com>
Notes
Notes: svn path=/head/; revision=392394
Diffstat (limited to 'sysutils/reptyr')
-rw-r--r--sysutils/reptyr/Makefile42
-rw-r--r--sysutils/reptyr/distinfo2
-rw-r--r--sysutils/reptyr/files/patch-Makefile23
-rw-r--r--sysutils/reptyr/pkg-descr7
-rw-r--r--sysutils/reptyr/pkg-plist5
5 files changed, 79 insertions, 0 deletions
diff --git a/sysutils/reptyr/Makefile b/sysutils/reptyr/Makefile
new file mode 100644
index 000000000000..5230d5fc2671
--- /dev/null
+++ b/sysutils/reptyr/Makefile
@@ -0,0 +1,42 @@
+# Created by: Andrey Cherkashin <andoriyu@gmail.com>
+# $FreeBSD$
+
+PORTNAME= reptyr
+PORTVERSION= 0.6.3a
+CATEGORIES= sysutils
+
+MAINTAINER= andoriyu@gmail.com
+COMMENT= Reparent a running program to a new terminal
+
+LICENSE= MIT
+
+USE_GITHUB= yes
+GH_ACCOUNT= nelhage
+GH_TAGNAME= 6fb15adb4552e170bcd5e648803da83dba57283b
+
+USES= gmake
+
+OPTIONS_DEFINE= BASH
+OPTIONS_SUB= yes
+
+ONLY_FOR_ARCHS= i386 amd64
+
+.include <bsd.port.pre.mk>
+.if ${PORT_OPTIONS:MBASH}
+BUILD_DEPENDS= ${LOCALBASE}/share/bash-completion/bash_completion:${PORTSDIR}/shells/bash-completion
+.endif
+
+BROKEN_FreeBSD_8= Not supported on FreeBSD older than 10.0
+BROKEN_FreeBSD_9= Not supported on FreeBSD older than 10.0
+
+post-install:
+.if ${PORT_OPTIONS:MBASH}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d
+ ${INSTALL_SCRIPT} ${WRKSRC}/reptyr.bash \
+ ${STAGEDIR}${PREFIX}/etc/bash_completion.d/reptyr
+.endif
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/reptyr
+ ${GZIP_CMD} ${STAGEDIR}${PREFIX}/share/man/man1/reptyr.1
+ ${GZIP_CMD} ${STAGEDIR}${PREFIX}/share/man/fr/man1/reptyr.1
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/reptyr/distinfo b/sysutils/reptyr/distinfo
new file mode 100644
index 000000000000..352793920d8f
--- /dev/null
+++ b/sysutils/reptyr/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nelhage-reptyr-0.6.3a-6fb15adb4552e170bcd5e648803da83dba57283b_GH0.tar.gz) = 9ee7983de2f4ab8bb56e3fdbcaad20d03733e75befb34003f95eddaface655f8
+SIZE (nelhage-reptyr-0.6.3a-6fb15adb4552e170bcd5e648803da83dba57283b_GH0.tar.gz) = 28883
diff --git a/sysutils/reptyr/files/patch-Makefile b/sysutils/reptyr/files/patch-Makefile
new file mode 100644
index 000000000000..9ec540889357
--- /dev/null
+++ b/sysutils/reptyr/files/patch-Makefile
@@ -0,0 +1,23 @@
+--- Makefile.orig 2015-06-05 21:41:48 UTC
++++ Makefile
+@@ -43,7 +43,7 @@ ptrace.o: ptrace.h platform/platform.h $
+ clean:
+ rm -f reptyr $(OBJS) test/victim.o test/victim
+
+-BASHCOMPDIR ?= $(shell $(PKG_CONFIG) --variable=completionsdir bash-completion 2>/dev/null)
++BASHCOMPDIR ?= /usr/local/share/bash-completion/completions
+
+ install: reptyr
+ install -d -m 755 $(DESTDIR)$(BINDIR)
+@@ -52,9 +52,7 @@ install: reptyr
+ install -m 644 reptyr.1 $(DESTDIR)$(MANDIR)/man1/reptyr.1
+ install -d -m 755 $(DESTDIR)$(MANDIR)/fr/man1
+ install -m 644 reptyr.fr.1 $(DESTDIR)$(MANDIR)/fr/man1/reptyr.1
+- bashcompdir=$(BASHCOMPDIR) ; \
+- test -z "$$bashcompdir" && bashcompdir=/etc/bash_completion.d ; \
+- install -d -m 755 $(DESTDIR)$$bashcompdir ; \
+- install -m 644 reptyr.bash $(DESTDIR)$$bashcompdir/reptyr
++ install -d -m 755 $(DESTDIR)$(BASHCOMPDIR)
++ install -m 644 reptyr.bash $(DESTDIR)$(BASHCOMPDIR)/reptyr
+
+ .PHONY: PHONY
diff --git a/sysutils/reptyr/pkg-descr b/sysutils/reptyr/pkg-descr
new file mode 100644
index 000000000000..83ea636b837e
--- /dev/null
+++ b/sysutils/reptyr/pkg-descr
@@ -0,0 +1,7 @@
+reptyr is a utility for taking an existing running program and
+attaching it to a new terminal. Started a long-running process over
+ssh, but have to leave and don't want to interrupt it? Just start
+a screen, use reptyr to grab it, and then kill the ssh session and
+head on home.
+
+WWW: http://github.com/nelhage/reptyr
diff --git a/sysutils/reptyr/pkg-plist b/sysutils/reptyr/pkg-plist
new file mode 100644
index 000000000000..0e8f6f11e77a
--- /dev/null
+++ b/sysutils/reptyr/pkg-plist
@@ -0,0 +1,5 @@
+%%BASH%%etc/bash_completion.d/reptyr
+%%BASH%%share/bash-completion/completions/reptyr
+bin/reptyr
+share/man/fr/man1/reptyr.1.gz
+share/man/man1/reptyr.1.gz