aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-16 12:04:08 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-16 12:04:08 +0000
commit454c8b425b28bb2cece5c12ffffc87dffb6a6d06 (patch)
treee19078ac149cf96ba599b39484ee177d210c02b9 /sysutils
parent4d1bf4d39d724e27af6584f64f57503447e3605b (diff)
downloadports-454c8b425b28bb2cece5c12ffffc87dffb6a6d06.tar.gz
ports-454c8b425b28bb2cece5c12ffffc87dffb6a6d06.zip
sysutils/fluent-bit: fix build on powerpc
/usr/local/bin/ld: bss-plt forced due to ../lib/libluajit.a(lj_vm.o) /usr/local/bin/ld: ../library/libcmetrics.a(cmt_atomic_gcc.c.o): in function `cmt_atomic_compare_exchange': cmt_atomic_gcc.c:(.text+0x50): undefined reference to `__atomic_compare_exchange_8' /usr/local/bin/ld: ../library/libcmetrics.a(cmt_atomic_gcc.c.o): in function `cmt_atomic_store': cmt_atomic_gcc.c:(.text+0x8c): undefined reference to `__atomic_store_8' /usr/local/bin/ld: ../library/libcmetrics.a(cmt_atomic_gcc.c.o): in function `cmt_atomic_load': cmt_atomic_gcc.c:(.text+0xc8): undefined reference to `__atomic_load_8'
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/fluent-bit/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/sysutils/fluent-bit/Makefile b/sysutils/fluent-bit/Makefile
index e810bc4ea752..47b4cb649c12 100644
--- a/sysutils/fluent-bit/Makefile
+++ b/sysutils/fluent-bit/Makefile
@@ -43,6 +43,7 @@ USE_RC_SUBR= ${PORTNAME}
.if ${ARCH:Mpowerpc64*}
CMAKE_ARGS+= -DFLB_LUAJIT:BOOL=OFF
.elif ${ARCH} == powerpc
+LDFLAGS+= -latomic
USES+= compiler:gcc-c++11-lib
.else
USES+= compiler:c11