aboutsummaryrefslogtreecommitdiff
path: root/textproc/chm2pdf
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2007-12-20 10:51:14 +0000
committerKevin Lo <kevlo@FreeBSD.org>2007-12-20 10:51:14 +0000
commitfe29d9adb78dd3ce5d79593bcd9ad55e071b5943 (patch)
tree22ea8df104e22576e2b1238399242548f8c84d5c /textproc/chm2pdf
parentd4a35bc5ce2a235d30af0811cc9a87295bfb3e30 (diff)
downloadports-fe29d9adb78dd3ce5d79593bcd9ad55e071b5943.tar.gz
ports-fe29d9adb78dd3ce5d79593bcd9ad55e071b5943.zip
Initial import of chm2pdf 0.9.
It is a simple Python script that converts CHM files into PDF files.
Notes
Notes: svn path=/head/; revision=204195
Diffstat (limited to 'textproc/chm2pdf')
-rw-r--r--textproc/chm2pdf/Makefile24
-rw-r--r--textproc/chm2pdf/distinfo3
-rw-r--r--textproc/chm2pdf/pkg-descr3
3 files changed, 30 insertions, 0 deletions
diff --git a/textproc/chm2pdf/Makefile b/textproc/chm2pdf/Makefile
new file mode 100644
index 000000000000..7773836b1c1e
--- /dev/null
+++ b/textproc/chm2pdf/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: chm2pdf
+# Date created: 20 December 2007
+# Whom: Kevin Lo <kevlo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= chm2pdf
+PORTVERSION= 0.9
+CATEGORIES= textproc python
+MASTER_SITES= http://chm2pdf.googlecode.com/files/
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= A Python script that converts CHM files into PDF files
+
+RUN_DEPENDS= htmldoc:${PORTSDIR}/textproc/htmldoc \
+ ${PYTHON_SITELIBDIR}/chm/chm.py:${PORTSDIR}/textproc/pychm
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= bin/chm2pdf
+
+.include <bsd.port.mk>
diff --git a/textproc/chm2pdf/distinfo b/textproc/chm2pdf/distinfo
new file mode 100644
index 000000000000..73b88e6de7e1
--- /dev/null
+++ b/textproc/chm2pdf/distinfo
@@ -0,0 +1,3 @@
+MD5 (chm2pdf-0.9.tar.gz) = 1bf69f901533ac9909d262a2253386cd
+SHA256 (chm2pdf-0.9.tar.gz) = 7152328d28aed322e41394e706609e81aa96eaf2cef4654494a1279a97528d07
+SIZE (chm2pdf-0.9.tar.gz) = 16699
diff --git a/textproc/chm2pdf/pkg-descr b/textproc/chm2pdf/pkg-descr
new file mode 100644
index 000000000000..3d6999c55dc9
--- /dev/null
+++ b/textproc/chm2pdf/pkg-descr
@@ -0,0 +1,3 @@
+A simple Python script that converts CHM files into PDF files.
+
+WWW: http://code.google.com/p/chm2pdf/