aboutsummaryrefslogtreecommitdiff
path: root/textproc/ibus-qt/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /textproc/ibus-qt/Makefile
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'textproc/ibus-qt/Makefile')
-rw-r--r--textproc/ibus-qt/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/textproc/ibus-qt/Makefile b/textproc/ibus-qt/Makefile
index ff21813d036a..ffa09d649d19 100644
--- a/textproc/ibus-qt/Makefile
+++ b/textproc/ibus-qt/Makefile
@@ -21,8 +21,8 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
GH_ACCOUNT= ibus
-USE_QT4= gui dbus moc_build qmake_build moc_build uic_build rcc_build
-USES= cmake compiler:c++11-lib pkgconfig
+USE_QT= gui dbus moc_build qmake_build moc_build uic_build rcc_build
+USES= cmake compiler:c++11-lib pkgconfig qt:4
CMAKE_ARGS= -DDOCDIR=${PREFIX}/share/doc/ibus-qt -DLIBDIR=lib
USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include