aboutsummaryrefslogtreecommitdiff
path: root/textproc/liblrdf/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-08-22 21:55:54 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-08-22 21:55:54 +0000
commitab3f3864e69f2e59b6e843881b1d479127687213 (patch)
treec8152aea1f233845621506fbbc2af04bb58fc8d9 /textproc/liblrdf/Makefile
parentd21b9348bf5f0974adf4e5626f2e5bcf1ad65f64 (diff)
downloadports-ab3f3864e69f2e59b6e843881b1d479127687213.tar.gz
ports-ab3f3864e69f2e59b6e843881b1d479127687213.zip
Make the port build if textproc/raptor is installed.
Both textproc/raptor and textproc/raptor2 provide a raptor.h header; the former puts it in ${LOCALBASE}/include, whereas the latter puts it into ${LOCALBASE}/include/raptor2. The way CPPFLAGS and LDFLAGS were changed so far, -I${LOCALBASE}/include was passed to the compiler before -I${LOCALBASE}/include/raptor2, so the raptor1 headers were picked up and the build failed. The fix is consists of several separate adjustments: - The port only depends on raptor2 (and obtains the required compiler and linker flags via pkg-config) and optionally on OpenSSL from ports in case one has installed it. We thus need USE_OPENSSL and OPENSSLINC/OPENSSLLIB. - Due to the other the CFLAGS are defined in the port's configure.ac, we need to make raptor2's CFLAGS be passed before the rest, so -I${LOCALBASE}/include/raptor2 is passed to the compiler before other paths such as the infamous ${LOCALBASE}/include. - We need to change CFLAGS instead of CPPFLAGS, otherwise the OpenSSL CFLAGS still come before the actual CFLAGS and the problem persists.
Notes
Notes: svn path=/head/; revision=302968
Diffstat (limited to 'textproc/liblrdf/Makefile')
-rw-r--r--textproc/liblrdf/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/textproc/liblrdf/Makefile b/textproc/liblrdf/Makefile
index 52370f7a880b..df7c210b0ac7 100644
--- a/textproc/liblrdf/Makefile
+++ b/textproc/liblrdf/Makefile
@@ -23,9 +23,10 @@ GNU_CONFIGURE= yes
USE_GNOME= gnomehack
GNOME_MAKEFILEIN= Makefile.am
USE_LDCONFIG= yes
+USE_OPENSSL= yes
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CFLAGS+= -I${OPENSSLINC} ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${OPENSSLLIB} ${PTHREAD_LIBS}
WRKSRC= ${WRKDIR}/swh-LRDF-7ebc032