aboutsummaryrefslogtreecommitdiff
path: root/textproc/openjade/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2003-07-01 06:21:09 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2003-07-01 06:21:09 +0000
commit7464f336e31fd80c931c3eb1c4c62776e4e3f7f1 (patch)
tree967c3aa47957c6218b6c16c34cfdf4261490cfc6 /textproc/openjade/Makefile
parentd7f26aaaed78fb07382fa672754350cb37ec40e0 (diff)
downloadports-7464f336e31fd80c931c3eb1c4c62776e4e3f7f1.tar.gz
ports-7464f336e31fd80c931c3eb1c4c62776e4e3f7f1.zip
Switch to using xmlcatmgr from mkcatalog.
# Maintainers, please let me know if I break something in your port. Submitted by: hrs PR: ports/53819, ports/53820, ports/53821, ports/53822, ports/53823, ports/53824, ports/53825, ports/53826, ports/53827, ports/53828, ports/53829, ports/53830, ports/53831, ports/53832, ports/53833, ports/53834, ports/53835, ports/53836, ports/53837
Notes
Notes: svn path=/head/; revision=83949
Diffstat (limited to 'textproc/openjade/Makefile')
-rw-r--r--textproc/openjade/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/textproc/openjade/Makefile b/textproc/openjade/Makefile
index 0823386c1b8d..ebfcba3cc086 100644
--- a/textproc/openjade/Makefile
+++ b/textproc/openjade/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openjade
PORTVERSION= 1.3.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,7 +16,7 @@ MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Object-oriented SGML/XML parser toolkit and DSSSL engine
LIB_DEPENDS= osp.3:${PORTSDIR}/textproc/opensp
-RUN_DEPENDS= ${MKCATALOG}:${PORTSDIR}/textproc/mkcatalog
+RUN_DEPENDS= ${XMLCATMGR}:${PORTSDIR}/textproc/xmlcatmgr
USE_GMAKE= YES
USE_LIBTOOL= YES
@@ -24,13 +24,15 @@ USE_PERL5= yes
CONFIGURE_ARGS= --enable-default-catalog=${PREFIX}/share/sgml/catalog \
--datadir=${PREFIX}/share/sgml/openjade
INSTALLS_SHLIB= yes
-PLIST_SUB= MKCATALOG=${MKCATALOG}
+PLIST_SUB= XMLCATMGR=${XMLCATMGR}
+PLIST_SUB+= CATALOG_PORTS_SGML=${CATALOG_PORTS_SGML}
-MKCATALOG= ${PREFIX}/sbin/mkcatalog
+CATALOG_PORTS_SGML= ${PREFIX}/share/sgml/catalog.ports
+XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
post-install:
@${INSTALL_DATA} ${WRKSRC}/dsssl/* ${PREFIX}/share/sgml/openjade
- @${MKCATALOG} -q install openjade
+ @${XMLCATMGR} -sc ${CATALOG_PORTS_SGML} add CATALOG openjade/catalog
.include <bsd.port.pre.mk>