aboutsummaryrefslogtreecommitdiff
path: root/textproc/pdfgrep/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2018-08-16 23:01:37 +0000
committerWen Heping <wen@FreeBSD.org>2018-08-16 23:01:37 +0000
commit4a86e1731562bf3326bb383099bd48ac9c51bd21 (patch)
tree16afaf50af1cbff60f52387cdbf6941a7a181c11 /textproc/pdfgrep/Makefile
parent61b1eeed67b63126ec015612e93bab2b1dd23262 (diff)
downloadports-4a86e1731562bf3326bb383099bd48ac9c51bd21.tar.gz
ports-4a86e1731562bf3326bb383099bd48ac9c51bd21.zip
- Update to 2.1.1
- Add option to enable or disable Perl expressions PR: 230309 Submitted by: ndowens@yahoo.com Approved by: maintainer
Notes
Notes: svn path=/head/; revision=477381
Diffstat (limited to 'textproc/pdfgrep/Makefile')
-rw-r--r--textproc/pdfgrep/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/textproc/pdfgrep/Makefile b/textproc/pdfgrep/Makefile
index b6fb8c0f0c87..a8497b027364 100644
--- a/textproc/pdfgrep/Makefile
+++ b/textproc/pdfgrep/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pdfgrep
-PORTVERSION= 2.0.1
-PORTREVISION= 1
+PORTVERSION= 2.1.1
CATEGORIES= textproc
MASTER_SITES= https://pdfgrep.org/download/
@@ -13,9 +12,8 @@ COMMENT= Tool to search text in PDF files
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libpcre.so:devel/pcre \
+LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libpoppler.so:graphics/poppler \
- libgcrypt.so:security/libgcrypt \
libgpg-error.so:security/libgpg-error
BROKEN_powerpc64= fails to link: pdfgrep.cc: undefined reference to poppler::set_debug_error_function
@@ -27,4 +25,9 @@ PLIST_FILES= bin/pdfgrep man/man1/pdfgrep.1.gz \
share/bash-completion/completions/pdfgrep \
share/zsh/site-functions/_pdfgrep
+OPTIONS_DEFINE= LIBPCRE
+LIBPCRE_DESC= Enable Perl compatable expressions
+LIBPCRE_LIB_DEPENDS= libpcre.so:devel/pcre
+LIBPCRE_CONFIGURE_WITH= libpcre
+
.include <bsd.port.mk>