aboutsummaryrefslogtreecommitdiff
path: root/textproc/pdfgrep/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-12-15 08:14:48 +0000
committerWen Heping <wen@FreeBSD.org>2010-12-15 08:14:48 +0000
commitb11ec6a474c1f141d28d3529a314205a05c1c376 (patch)
tree3b447d0d86ffea9f7f924bc5d83f08df048b3e1a /textproc/pdfgrep/Makefile
parent072e0907a13f486b337e7faa401bc6c974b7e9dc (diff)
downloadports-b11ec6a474c1f141d28d3529a314205a05c1c376.tar.gz
ports-b11ec6a474c1f141d28d3529a314205a05c1c376.zip
Pdfgrep is a tool to search text in PDF files. It works similar to grep.
Features: * search for regular expressions. * support for some important grep options, including: o filename output. o page number output. o optional case insensitivity. o count occurrences. * and the most important feature: color output! WWW: http://pdfgrep.sourceforge.net/ PR: ports/152648 Submitted by: Michael Ranner <michael@ranner.eu>
Notes
Notes: svn path=/head/; revision=266331
Diffstat (limited to 'textproc/pdfgrep/Makefile')
-rw-r--r--textproc/pdfgrep/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/textproc/pdfgrep/Makefile b/textproc/pdfgrep/Makefile
new file mode 100644
index 000000000000..5d360b2001df
--- /dev/null
+++ b/textproc/pdfgrep/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: pdfgrep
+# Date created: 2010-11-28
+# Whom: Michael Ranner <michael@ranner.eu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdfgrep
+PORTVERSION= 1.1
+CATEGORIES= textproc
+MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= michael@ranner.eu
+COMMENT= A tool to search text in PDF files
+
+LIB_DEPENDS= poppler.6:${PORTSDIR}/graphics/poppler
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS= poppler_CFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/poppler"
+
+PLIST_FILES= bin/pdfgrep
+MAN1= pdfgrep.1
+
+.include <bsd.port.mk>