aboutsummaryrefslogtreecommitdiff
path: root/textproc/pear-Numbers_Words/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-10-07 19:58:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-10-07 19:58:32 +0000
commit59dbb8937246ebc98ff00b812ad9be1a65a116ab (patch)
treea1ca4aec83ac2c29bdad278a4e979134ffdba115 /textproc/pear-Numbers_Words/Makefile
parentb6aed003a906c2f9957c62e930f0079e043a17db (diff)
downloadports-59dbb8937246ebc98ff00b812ad9be1a65a116ab.tar.gz
ports-59dbb8937246ebc98ff00b812ad9be1a65a116ab.zip
With Numbers_Words class you can convert numbers written in arabic digits to
words in several languages. You can convert an integer between -infinity and infinity. If your system does not support such long numbers you can call Numbers_Words::toWords() with just a string. PR: ports/86893 Submitted by: Piotr Rybicki <meritus@innervision.pl>
Notes
Notes: svn path=/head/; revision=144526
Diffstat (limited to 'textproc/pear-Numbers_Words/Makefile')
-rw-r--r--textproc/pear-Numbers_Words/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/textproc/pear-Numbers_Words/Makefile b/textproc/pear-Numbers_Words/Makefile
new file mode 100644
index 000000000000..1adfc01b483b
--- /dev/null
+++ b/textproc/pear-Numbers_Words/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: pear-Numbers_Words
+# Date created: 05 October 2005
+# Whom: Piotr Rybicki (<meritus@innervision.pl>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Numbers_Words
+PORTVERSION= 0.14.0
+CATEGORIES= textproc pear
+
+MAINTAINER= meritus@innervision.pl
+COMMENT= PEAR package provides methods for spelling numerals in words
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+FILES= Words.php Words/lang.bg.php Words/lang.cs.php \
+ Words/lang.de.php Words/lang.dk.php Words/lang.ee.php \
+ Words/lang.en_100.php Words/lang.en_GB.php \
+ Words/lang.en_US.php Words/lang.es.php Words/lang.es_AR.php \
+ Words/lang.fr.php Words/lang.fr_BE.php Words/lang.he.php \
+ Words/lang.hu_HU.php Words/lang.id.php Words/lang.it_IT.php \
+ Words/lang.lt.php Words/lang.pl.php Words/lang.pt_BR.php \
+ Words/lang.ru.php Words/lang.sv.php
+TESTS= test-numbers-words.php clitest.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>