aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-pyx12/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-11 22:30:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-11 22:30:47 +0000
commit343608bb4112ee94ca8b506536c0dcc5e00b0055 (patch)
tree4b9256d4e0e33258e1b895c74384541123667743 /textproc/py-pyx12/Makefile
parent326fbd5630489250ab722401ee703e68ea285863 (diff)
downloadports-343608bb4112ee94ca8b506536c0dcc5e00b0055.tar.gz
ports-343608bb4112ee94ca8b506536c0dcc5e00b0055.zip
Add py-pyx12, a Python based HIPAA EDI transaction validator
and XML translator. PR: ports/62661 Submitted by: John Holland <jholland@kazoocmh.org>
Notes
Notes: svn path=/head/; revision=100719
Diffstat (limited to 'textproc/py-pyx12/Makefile')
-rw-r--r--textproc/py-pyx12/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/py-pyx12/Makefile b/textproc/py-pyx12/Makefile
new file mode 100644
index 000000000000..18954e65fe5a
--- /dev/null
+++ b/textproc/py-pyx12/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: pyx12
+# Date created: 29 Jan 2004
+# Whom: john@zoner.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyx12
+PORTVERSION= 1.0.1.b3
+CATEGORIES= textproc python
+MASTER_SITES= http://osdn.dl.sourceforge.net/sourceforge/pyx12/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyx12-${PORTVERSION:S/.b/b/}
+
+MAINTAINER= john@zoner.org
+COMMENT= Validate HIPAA X12 documents
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/libxml2
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_PYTHON_PREFIX= yes
+
+post-install:
+ ${WRKSRC}/bin/x12_build_pkl.py ${PREFIX}/share/pyx12/map/
+
+.include <bsd.port.mk>