aboutsummaryrefslogtreecommitdiff
path: root/textproc/xalan-c/files
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-07-01 08:37:21 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-07-01 08:37:21 +0000
commit6fb20cc85fb009eb153ce6cc5063f1e71188ac0e (patch)
tree6d3eba08a419c65cd7606449b2d405bf591fa218 /textproc/xalan-c/files
parent6b3890ee593dce092643e5e3fe3de0fe2ddc99f0 (diff)
downloadports-6fb20cc85fb009eb153ce6cc5063f1e71188ac0e.tar.gz
ports-6fb20cc85fb009eb153ce6cc5063f1e71188ac0e.zip
- Update to the new upstream release 1.12
- Maintainer is now an Apache person and upstream maintainer too - Switch the build to CMake, GC old cruft and MAKE_JOBS_UNSAFE - Require C++11-capable compiler for std::thread and other features - Allow to use ICU optionally (default to on since it affects EXSLT functionality if missing) - Patch missing header; opened issue upstream (https://issues.apache.org/jira/browse/XALANC-809) - Drop the older patch now as it's fixed upstream PR: 247072 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=540932
Diffstat (limited to 'textproc/xalan-c/files')
-rw-r--r--textproc/xalan-c/files/patch-src_xalanc_CMakeLists.txt10
-rw-r--r--textproc/xalan-c/files/patch-src_xalanc_PlatformSupport_XalanLocator.hpp11
2 files changed, 10 insertions, 11 deletions
diff --git a/textproc/xalan-c/files/patch-src_xalanc_CMakeLists.txt b/textproc/xalan-c/files/patch-src_xalanc_CMakeLists.txt
new file mode 100644
index 000000000000..f3a9012a728d
--- /dev/null
+++ b/textproc/xalan-c/files/patch-src_xalanc_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- src/xalanc/CMakeLists.txt.orig 2020-06-07 09:17:25 UTC
++++ src/xalanc/CMakeLists.txt
+@@ -832,6 +832,7 @@ set(xalantransformer_sources
+ XalanTransformer/XercesDOMWrapperParsedSource.cpp)
+
+ set(xalantransformer_headers
++ XalanTransformer/XalanCAPI.h
+ XalanTransformer/XalanCompiledStylesheetDefault.hpp
+ XalanTransformer/XalanCompiledStylesheet.hpp
+ XalanTransformer/XalanDefaultDocumentBuilder.hpp
diff --git a/textproc/xalan-c/files/patch-src_xalanc_PlatformSupport_XalanLocator.hpp b/textproc/xalan-c/files/patch-src_xalanc_PlatformSupport_XalanLocator.hpp
deleted file mode 100644
index 61f679c10581..000000000000
--- a/textproc/xalan-c/files/patch-src_xalanc_PlatformSupport_XalanLocator.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/xalanc/PlatformSupport/XalanLocator.hpp.orig 2012-09-27 06:59:33 UTC
-+++ src/xalanc/PlatformSupport/XalanLocator.hpp
-@@ -91,7 +91,7 @@ public:
- const XalanDOMChar* theAlternateId = getEmptyPtr())
- {
- return theLocator == 0 ? theAlternateId : (theLocator->getSystemId() ?
-- theLocator->getPublicId() : theAlternateId);
-+ theLocator->getSystemId() : theAlternateId);
- }
-
- /**