aboutsummaryrefslogtreecommitdiff
path: root/www/R-cran-gh/Makefile
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2021-04-18 23:05:10 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-04-18 23:05:10 +0000
commit4033966d3fa3842af174fa21fdb21fd4b0c1e00c (patch)
treed045a64ab85053ae10b7c7b164f33dd6e77c0ede /www/R-cran-gh/Makefile
parent9b429b80e033ec7dabf0c87a76df372e3de36f2a (diff)
downloadports-4033966d3fa3842af174fa21fdb21fd4b0c1e00c.tar.gz
ports-4033966d3fa3842af174fa21fdb21fd4b0c1e00c.zip
new port: www/R-cran-gh: GitHub API for R
Approved by: lwhsu
Diffstat (limited to 'www/R-cran-gh/Makefile')
-rw-r--r--www/R-cran-gh/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/www/R-cran-gh/Makefile b/www/R-cran-gh/Makefile
new file mode 100644
index 000000000000..ed8c2ccff4a9
--- /dev/null
+++ b/www/R-cran-gh/Makefile
@@ -0,0 +1,29 @@
+# Created by: Guangyuan Yang <ygy@FreeBSD.org>
+
+PORTNAME= gh
+DISTVERSION= 1.2.1
+CATEGORIES= www
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= ygy@FreeBSD.org
+COMMENT= GitHub API for R
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= R-cran-knitr>0:print/R-cran-knitr
+RUN_DEPENDS= R-cran-jsonlite>0:converters/R-cran-jsonlite \
+ R-cran-cli>=2.0.1:devel/R-cran-cli \
+ R-cran-ini>0:devel/R-cran-ini \
+ R-cran-gitcreds>0:security/R-cran-gitcreds \
+ R-cran-httr>=1.2:www/R-cran-httr
+TEST_DEPENDS= R-cran-covr>0:devel/R-cran-covr \
+ R-cran-rprojroot>0:devel/R-cran-rprojroot \
+ R-cran-testthat>=2.3.2:devel/R-cran-testthat \
+ R-cran-withr>0:devel/R-cran-withr \
+ R-cran-knitr>0:print/R-cran-knitr \
+ R-cran-rmarkdown>0:textproc/R-cran-rmarkdown
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>