aboutsummaryrefslogtreecommitdiff
path: root/www/awffull/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-11 17:42:14 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-11 17:42:14 +0000
commit36dbd96bef44421fd6850b6811e73d1b84873226 (patch)
tree0d5dfd0a7a10e36e7b5a2cff4343e676433d679a /www/awffull/Makefile
parent8c5b79937d99977f2513df3d1245d12f56c3e169 (diff)
downloadports-36dbd96bef44421fd6850b6811e73d1b84873226.tar.gz
ports-36dbd96bef44421fd6850b6811e73d1b84873226.zip
Install the bundled documentation, sample configuration files, instructions,
flags, and parsing scripts. Add an NLS option. Add LICENSE.
Notes
Notes: svn path=/head/; revision=364630
Diffstat (limited to 'www/awffull/Makefile')
-rw-r--r--www/awffull/Makefile35
1 files changed, 25 insertions, 10 deletions
diff --git a/www/awffull/Makefile b/www/awffull/Makefile
index e9df99e1c6d6..985cd5b7dfd1 100644
--- a/www/awffull/Makefile
+++ b/www/awffull/Makefile
@@ -3,13 +3,15 @@
PORTNAME= awffull
PORTVERSION= 3.10.2
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES?= www
MASTER_SITES= http://www.stedee.id.au/files/
MAINTAINER?= chad@wickdev.com
COMMENT= AWFFull is a webserver log analysis tool forked from Webalizer
+LICENSE= GPLv3
+
BUILD_DEPENDS= ${LOCALBASE}/lib/X11/fonts/bitstream-vera/Vera.ttf:${PORTSDIR}/x11-fonts/bitstream-vera
LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
libpng15.so:${PORTSDIR}/graphics/png \
@@ -21,7 +23,8 @@ CONFLICTS?= ja-awffull-[0-9]*
FONTDEFAULT?= ${LOCALBASE}/lib/X11/fonts/bitstream-vera/VeraBd.ttf
FONTLABEL?= ${LOCALBASE}/lib/X11/fonts/bitstream-vera/Vera.ttf
-OPTIONS_DEFINE= GEOIP
+OPTIONS_DEFINE= GEOIP DOCS EXAMPLES NLS
+OPTIONS_SUB= yes
USES= gettext iconv
@@ -33,13 +36,25 @@ CONFIGURE_ARGS+=--with-font-default=${FONTDEFAULT} \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGEOIP}
-LIB_DEPENDS+= libGeoIP.so:${PORTSDIR}/net/GeoIP
-CONFIGURE_ARGS+=--enable-geoip
-.else
-CONFIGURE_ARGS+=--disable-geoip
-.endif
+GEOIP_LIB_DEPENDS= libGeoIP.so:${PORTSDIR}/net/GeoIP
+GEOIP_CONFIGURE_ENABLE= geoip
+
+NLS_CONFIGURE_ENABLE= nls
+
+PORTDOCS= *
+PORTEXAMPLES= *
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} \
+ COPYING ChangeLog DNS.README PERFORMANCE_TIPS.txt \
+ README* TODO country-codes.txt \
+ ${STAGEDIR}${DOCSDIR})
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample* ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/contrib/*.pl ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/flags
+ ${INSTALL_DATA} ${WRKSRC}/flags/README ${WRKSRC}/flags/*.png \
+ ${STAGEDIR}${EXAMPLESDIR}/flags
.include <bsd.port.mk>