aboutsummaryrefslogtreecommitdiff
path: root/www/clearsilver
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-13 07:41:30 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-13 07:41:30 +0000
commit08f99179049da9f52c9b96d09f3b0a0e62551a43 (patch)
tree11bcf71a3a421a6b75c77a7ef7dcc57c78c9e1d3 /www/clearsilver
parent4e8d069e3f7458c644fc0beb54cf1c58698ec8e8 (diff)
downloadports-08f99179049da9f52c9b96d09f3b0a0e62551a43.tar.gz
ports-08f99179049da9f52c9b96d09f3b0a0e62551a43.zip
- Patch out $ python - print site.sitedirs invocation. According to perky:
"sys.sitedirs is not for external reference, it's even hidden and not available in Python 2.4" and replace it with ${PYTHON_SITELIBDIR}. This fixes installation of python module, which would otherwise always end up in /usr/X11R6/lib/python2.3/site-packages.
Notes
Notes: svn path=/head/; revision=113533
Diffstat (limited to 'www/clearsilver')
-rw-r--r--www/clearsilver/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/www/clearsilver/Makefile b/www/clearsilver/Makefile
index a00d89c73bd2..862dfc8371e3 100644
--- a/www/clearsilver/Makefile
+++ b/www/clearsilver/Makefile
@@ -74,5 +74,6 @@ post-patch:
@${REINPLACE_CMD} -E 's,(\$$\(PYTHON\)),CFLAGS="" \1,g' ${WRKSRC}/python/Makefile
@# Avoid rebuiling man pages
@${REINPLACE_CMD} -e 's,all man,all,g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|`$$python_bin -c "import site; print site.sitedirs\[0\]"`|"${PYTHON_SITELIBDIR}"|' ${WRKSRC}/configure
.include <bsd.port.post.mk>