aboutsummaryrefslogtreecommitdiff
path: root/www/dokuwiki-devel
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-06-16 08:00:25 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-06-16 08:00:25 +0000
commitb7af429d496254b2945f9e730f21306c5a81645a (patch)
treed02f9394f3c3103b038eb17745c99a7e7bfbd332 /www/dokuwiki-devel
parent79a38e026823540ef1c46bea70a356d0f079d438 (diff)
downloadports-b7af429d496254b2945f9e730f21306c5a81645a.tar.gz
ports-b7af429d496254b2945f9e730f21306c5a81645a.zip
- fix the path of PHP.
- Bump portrevision. Noticed by: Christian Marg <marg at rz.tu-clausthal.de>
Notes
Notes: svn path=/head/; revision=214941
Diffstat (limited to 'www/dokuwiki-devel')
-rw-r--r--www/dokuwiki-devel/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/www/dokuwiki-devel/Makefile b/www/dokuwiki-devel/Makefile
index ac3324112a4c..8312b7d79005 100644
--- a/www/dokuwiki-devel/Makefile
+++ b/www/dokuwiki-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dokuwiki
PORTVERSION= ${DIST_VER:S/${PORTNAME}//:S/-//g}
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= LOCAL/chinsan/${PORTNAME} \
http://dev.splitbrain.org/browse/snapshots/
@@ -26,6 +27,8 @@ DOKUWIKI_DIR?= www/${PORTNAME}
PLIST_SUB= DOKUWIKI_DIR=${DOKUWIKI_DIR}
TEMP_PLIST= ${WRKDIR}/temp-pkg-plist
+REINPLACE_ARGS= -i ''
+
.include <bsd.port.pre.mk>
# This target is only meant to be used by the port maintainer.
@@ -36,6 +39,10 @@ x-generate-plist:
${SED} -e 's|^|@dirrm %%DOKUWIKI_DIR%%/|' >> ${TEMP_PLIST} \
&& ${ECHO_CMD} "@dirrmtry %%DOKUWIKI_DIR%%" >> ${TEMP_PLIST}
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin|${LOCALBASE}/bin|' ${WRKSRC}/bin/*.php
+ @${FIND} ${WRKSRC}/bin -name '*.orig' -delete
+
do-install:
# Data files
-${MKDIR} ${PREFIX}/${DOKUWIKI_DIR}