aboutsummaryrefslogtreecommitdiff
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-05-01 00:51:37 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-05-01 00:51:37 +0000
commitfda179862d1da64ec4cd48af7731a48bab9c3938 (patch)
tree529a5e85eed7367e8f5d8cf4e7ed28ffa661c584 /www/firefox/Makefile
parent67b51682df71f13f70ac347b97093d29903a19c3 (diff)
downloadports-fda179862d1da64ec4cd48af7731a48bab9c3938.tar.gz
ports-fda179862d1da64ec4cd48af7731a48bab9c3938.zip
www/firefox: update to 60.0
- Add U2F support, required by Web Authentication [1] - Drop libv4l support to reduce maintenance Changes: https://www.mozilla.org/firefox/60.0/releasenotes/ PR: 226476 Tested by: tobik, jrm, D. Ebdrup, lwhsu Submitted by: Greg V [1] Security: 5aefc41e-d304-4ec8-8c82-824f84f08244 MFH: 2018Q2 Differential Revision: https://reviews.freebsd.org/D15186
Notes
Notes: svn path=/head/; revision=468751
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile26
1 files changed, 11 insertions, 15 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index faaa2eaf9756..12a7d1bf1705 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -2,28 +2,26 @@
# $FreeBSD$
PORTNAME= firefox
-DISTVERSION= 59.0.3
+DISTVERSION= 60.0
PORTEPOCH= 1
CATEGORIES= www ipv6
-MASTER_SITES= https://hg.mozilla.org/releases/mozilla-release/archive/
-MASTER_SITES+= LOCAL/${DIST_SUBDIR}/jbeich
-DISTNAME= ${MASTER_SITES:M*hg*:S,/archive/,,:T}-6b51784853e47e091d213d421a19cb623af718f0
-DISTFILES= ${DISTNAME:C/.*-//}${EXTRACT_SUFX}
-DIST_SUBDIR= firefox
+MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
+ MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
+DISTFILES= ${DISTNAME}.source${EXTRACT_SUFX}
MAINTAINER= gecko@FreeBSD.org
COMMENT= Web browser based on the browser portion of Mozilla
-BUILD_DEPENDS= nspr>=4.18:devel/nspr \
- nss>=3.35:security/nss \
+BUILD_DEPENDS= nspr>=4.19:devel/nspr \
+ nss>=3.36.1:security/nss \
icu>=59.1,1:devel/icu \
libevent>=2.1.8:devel/libevent \
- harfbuzz>=1.7.4:print/harfbuzz \
- graphite2>=1.3.10:graphics/graphite2 \
+ harfbuzz>=1.7.6:print/harfbuzz \
+ graphite2>=1.3.11:graphics/graphite2 \
png>=1.6.34:graphics/png \
- libvorbis>=1.3.5,3:audio/libvorbis \
+ libvorbis>=1.3.6,3:audio/libvorbis \
libvpx>=1.5.0:multimedia/libvpx \
- sqlite3>=3.21.0:databases/sqlite3 \
+ sqlite3>=3.22.0:databases/sqlite3 \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
v4l_compat>0:multimedia/v4l_compat \
autoconf-2.13:devel/autoconf213 \
@@ -31,15 +29,13 @@ BUILD_DEPENDS= nspr>=4.18:devel/nspr \
zip:archivers/zip
# soundtouch>=1.9.0:audio/soundtouch \
-LIB_DEPENDS= libv4l2.so:multimedia/libv4l
-
USE_GECKO= gecko
CONFLICTS_INSTALL= firefox-esr
MOZ_PKGCONFIG_FILES= # empty
USE_MOZILLA= -cairo -soundtouch
USE_GL= gl
-USES= tar:bz2
+USES= tar:xz
FIREFOX_ICON= ${MOZILLA}.png
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/browser/chrome/icons/default/default48.png