aboutsummaryrefslogtreecommitdiff
path: root/www/firefox
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-08-26 06:38:32 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-08-26 06:38:32 +0000
commitfd9ddf4a36fd0ab126d6c6d0948b99d335e84a31 (patch)
tree2326c0dcbe308c1ec8225b5c5da94be764aa4e34 /www/firefox
parente38f12c62c8796270f62a2482c9480f8bc657e2a (diff)
downloadports-fd9ddf4a36fd0ab126d6c6d0948b99d335e84a31.tar.gz
ports-fd9ddf4a36fd0ab126d6c6d0948b99d335e84a31.zip
gecko: add INTEGER_SAMPLES option
arm use S16 samples and libtremor since Firefox 34. So, adjust dependencies and make it controllable (for testing on x86). Note, arm is still BROKEN until ports/202642. https://bugzilla.mozilla.org/show_bug.cgi?id=1047791
Notes
Notes: svn path=/head/; revision=395349
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile.options8
-rw-r--r--www/firefox/files/patch-sample-type13
2 files changed, 18 insertions, 3 deletions
diff --git a/www/firefox/Makefile.options b/www/firefox/Makefile.options
index 1f8f8453cef9..fe10d379eeb1 100644
--- a/www/firefox/Makefile.options
+++ b/www/firefox/Makefile.options
@@ -1,10 +1,11 @@
# -*- makefile-bsdmake -*-
OPTIONS_DEFINE+= BUNDLED_CAIRO CANBERRA DBUS DEBUG DTRACE GCONF GIO \
- GNOMEUI GSTREAMER LIBPROXY LOGGING OPTIMIZED_CFLAGS \
- PGO PROFILE TEST
+ GNOMEUI GSTREAMER INTEGER_SAMPLES LIBPROXY LOGGING \
+ OPTIMIZED_CFLAGS PGO PROFILE TEST
-OPTIONS_DEFAULT+= ALSA DBUS GIO GSTREAMER LOGGING OPTIMIZED_CFLAGS
+OPTIONS_DEFAULT+= ALSA DBUS GIO GSTREAMER LOGGING OPTIMIZED_CFLAGS \
+ ${MACHINE_CPU:tu:MSOFTFP:S/SOFTFP/INTEGER_SAMPLES/}
OPTIONS_MULTI+= AUDIO
OPTIONS_MULTI_AUDIO= ALSA PULSEAUDIO
@@ -13,6 +14,7 @@ BUNDLED_CAIRO_DESC?= Use bundled fork of cairo-1.9.5
CANBERRA_DESC?= Sound theme alerts
ENIGMAIL_DESC?= Enigmail extension
GNOMEUI_DESC?= libgnomeui support module
+INTEGER_SAMPLES_DESC?= Integer audio sample format
LIBPROXY_DESC?= Proxy support via libproxy
LIGHTNING_DESC?= Calendar extension
LOGGING_DESC?= Additional log messages
diff --git a/www/firefox/files/patch-sample-type b/www/firefox/files/patch-sample-type
new file mode 100644
index 000000000000..980bde629d2a
--- /dev/null
+++ b/www/firefox/files/patch-sample-type
@@ -0,0 +1,13 @@
+# Let ports handle default sample type
+
+--- configure.in~
++++ configure.in
+@@ -5144,7 +5144,7 @@ dnl Use integers over floats for audio o
+ dnl (regarless of the CPU architecture, because audio
+ dnl backends for those platforms don't support floats. We also
+ dnl use integers on ARM with other OS, because it's more efficient.
+-if test "$OS_TARGET" = "Android" -o "$CPU_ARCH" = "arm"; then
++if test -n "$MOZ_INTEGER_SAMPLES"; then
+ MOZ_SAMPLE_TYPE_S16=1
+ AC_DEFINE(MOZ_SAMPLE_TYPE_S16)
+ AC_SUBST(MOZ_SAMPLE_TYPE_S16)