aboutsummaryrefslogtreecommitdiff
path: root/www/libxul/Makefile
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2014-06-11 03:42:55 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2014-06-11 03:42:55 +0000
commit0557b9315d4e0c460a7150b697ad040a7084852d (patch)
tree95c4039ece9c88b497d122c1719bf5d754d803a8 /www/libxul/Makefile
parent43fd6859fb194226b5da2b861b50a9d77315943b (diff)
downloadports-0557b9315d4e0c460a7150b697ad040a7084852d.tar.gz
ports-0557b9315d4e0c460a7150b697ad040a7084852d.zip
- Update Firefox to 30.0
- Update Firefox ESR to 24.6.0 - Update libxul to 24.6.0 - Update NSS to 3.16.1 - Update NSPR to 4.10.6 - Update Thunderbird to 24.6.0 - Convert USE_BZIP2 to USES - Backport ff31 fix against crashing DEBUG build on newegg.com [1] - Add a note in UPDATING to not build audio/soundtouch with INTEGER_SAMPLES [2] - Use arc4random_buf(3) to generate UUIDs (version 4) - Fix debugger detection used by Telemetry and the slow script dialog - Add STAGE support [3] PR: ports/189991 [1] PR: ports/189217 [2] PR: ports/189488 [2] Submitted by: bapt [3] Sumbitted by: Jan Beich Security: http://www.vuxml.org/freebsd/888a0262-f0d9-11e3-ba0c-b4b52fce4ce8.html
Notes
Notes: svn path=/head/; revision=357413
Diffstat (limited to 'www/libxul/Makefile')
-rw-r--r--www/libxul/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index 73c42c05dacf..d65d128968ff 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libxul
-DISTVERSION= 24.5.0
-PORTREVISION= 1
+DISTVERSION= 24.6.0
CATEGORIES?= www devel
MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source \
https://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/${DISTVERSION}esr-candidates/build1/source/
@@ -39,7 +38,7 @@ WANT_PERL= yes
ALL_TARGET= default
GNU_CONFIGURE= yes
USE_GL= gl
-USES= dos2unix tar:bzip2
+USES= dos2unix pathfix tar:bzip2
DOS2UNIX_FILES= media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp
MAKE_ENV= SKIP_GRE_REGISTRATION=1 mozappdir=${PREFIX}/lib/${MOZILLA}
LDFLAGS+= -Wl,-rpath,${PREFIX}/lib/${MOZ_RPATH}
@@ -51,12 +50,11 @@ USE_GECKO= gecko
OBJDIR_BUILD= # in-tree build broken after bug 789837
MOZILLA_EXEC_NAME=xulrunner
USE_MOZILLA= # empty
-MOZILLA_PLIST_DIRS= bin include lib share/idl
+MOZILLA_PLIST_DIRS= bin include lib share/idl libdata
PLIST_DIRSTRY= share/idl
MOZ_PKGCONFIG_FILES= libxul-embedding libxul mozilla-js \
mozilla-plugin
-NO_STAGE= yes
.include "${.CURDIR}/../../www/firefox/Makefile.options"
.include <bsd.port.pre.mk>