aboutsummaryrefslogtreecommitdiff
path: root/www/libxul/files
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2013-12-14 13:42:06 +0000
committerFlorian Smeets <flo@FreeBSD.org>2013-12-14 13:42:06 +0000
commit7efa77ad7c5cf3417d7fe8c89dbe949a8facca79 (patch)
tree3f75766ca5d76f6dd2367c583fb90b16519be03a /www/libxul/files
parent306f0fd83b4dd6ed92cb257b5f916bc09f1583bf (diff)
downloadports-7efa77ad7c5cf3417d7fe8c89dbe949a8facca79.tar.gz
ports-7efa77ad7c5cf3417d7fe8c89dbe949a8facca79.zip
Update to nspr 4.10.2
Update to nss 3.15.3.1 Update firefox-esr and thunderbird to 24.2.0 Update firefox to 26.0 Update seamonkey to 2.23 - catch up with directory renames since USES=webplugins was introduced; fixes plugins not being automatically enabled after install - linux-firefox and linux-seamonkey can play HTML5 audio [2][3] and measure about:memory usage, again - dom.ipc.plugins.enabled->true no longer crash linux-firefox which makes some flash sites work again; as there's no nspluginwrapper in-between the infamous "youtube issue" never occurs - install DEBUG with symbols [3] and describe the option better [4] - enable dumping about:memory upon kill -65, kill -66 and GC/CC log upon kill -67 to a file under /tmp directory; linux-firefox uses kill -34, kill -35 and kill -36 respectively PR: ports/183861 [1] PR: ports/184006 [2] PR: ports/169896 [3] PR: ports/184285 [3] PR: ports/184286 [4] Security: dd116b19-64b3-11e3-868f-0025905a4771 In collaboration with: Jan Beich <jbeich@tormail.org>
Notes
Notes: svn path=/head/; revision=336446
Diffstat (limited to 'www/libxul/files')
-rw-r--r--www/libxul/files/extra-bug78053124
-rw-r--r--www/libxul/files/patch-bug945046130
-rw-r--r--www/libxul/files/patch-bug94656044
-rw-r--r--www/libxul/files/patch-build_unix_run-mozilla.sh2
-rw-r--r--www/libxul/files/patch-xulrunner-stub-nsXULStub.cpp2
5 files changed, 176 insertions, 26 deletions
diff --git a/www/libxul/files/extra-bug780531 b/www/libxul/files/extra-bug780531
deleted file mode 100644
index 26859a9bde10..000000000000
--- a/www/libxul/files/extra-bug780531
+++ /dev/null
@@ -1,24 +0,0 @@
---- configure.in~
-+++ configure.in
-@@ -5364,15 +5364,18 @@ AC_SUBST(MOZ_SRTP)
-
- dnl Use integers over floats for audio on B2G and Android, because audio
- dnl backends for those platforms don't support floats.
--if test "$OS_TARGET" = "Android"; then
-+case "$target" in
-+*-android*|*-linuxandroid*|*-dragonfly*|*-freebsd*|*-netbsd*|*-openbsd*)
- MOZ_SAMPLE_TYPE_S16=1
- AC_DEFINE(MOZ_SAMPLE_TYPE_S16)
- AC_SUBST(MOZ_SAMPLE_TYPE_S16)
--else
-+;;
-+*)
- MOZ_SAMPLE_TYPE_FLOAT32=1
- AC_DEFINE(MOZ_SAMPLE_TYPE_FLOAT32)
- AC_SUBST(MOZ_SAMPLE_TYPE_FLOAT32)
--fi
-+;;
-+esac
-
- dnl ========================================================
- dnl = Disable Speech API code
diff --git a/www/libxul/files/patch-bug945046 b/www/libxul/files/patch-bug945046
new file mode 100644
index 000000000000..2da32f78cd4c
--- /dev/null
+++ b/www/libxul/files/patch-bug945046
@@ -0,0 +1,130 @@
+diff --git config/system-headers config/system-headers
+index 432cba6..18a9627 100644
+--- config/system-headers
++++ config/system-headers
+@@ -1157,3 +1157,4 @@ unicode/uenum.h
+ unicode/unum.h
+ unicode/ustring.h
+ #endif
++libutil.h
+diff --git js/src/config/system-headers js/src/config/system-headers
+index 432cba6..18a9627 100644
+--- js/src/config/system-headers
++++ js/src/config/system-headers
+@@ -1157,3 +1157,4 @@ unicode/uenum.h
+ unicode/unum.h
+ unicode/ustring.h
+ #endif
++libutil.h
+diff --git toolkit/library/Makefile.in toolkit/library/Makefile.in
+index 9975621..b4b037d 100644
+--- toolkit/library/Makefile.in
++++ toolkit/library/Makefile.in
+@@ -289,6 +289,10 @@ OS_LIBS += $(call EXPAND_LIBNAME,kvm)
+ EXTRA_DSO_LDOPTS += -Wl,--warn-unresolved-symbols
+ endif
+
++ifeq ($(OS_ARCH),FreeBSD)
++OS_LIBS += $(call EXPAND_LIBNAME,util)
++endif
++
+ ifeq ($(OS_ARCH),WINNT)
+ OS_LIBS += $(call EXPAND_LIBNAME,shell32 ole32 version winspool comdlg32 imm32 msimg32 shlwapi psapi ws2_32 dbghelp rasapi32 rasdlg iphlpapi uxtheme setupapi secur32 sensorsapi portabledeviceguids windowscodecs wininet wbemuuid)
+ ifdef ACCESSIBILITY
+diff --git xpcom/base/nsMemoryReporterManager.cpp xpcom/base/nsMemoryReporterManager.cpp
+index b8147c8..0ffb34e 100644
+--- xpcom/base/nsMemoryReporterManager.cpp
++++ xpcom/base/nsMemoryReporterManager.cpp
+@@ -153,6 +153,43 @@ static nsresult GetResidentFast(int64_t
+ return GetResident(n);
+ }
+
++#ifdef __FreeBSD__
++#include <libutil.h>
++
++static nsresult
++GetKinfoVmentrySelf(int64_t* prss)
++{
++ int cnt;
++ struct kinfo_vmentry *vmmap, *kve;
++ if ((vmmap = kinfo_getvmmap(getpid(), &cnt)) == NULL)
++ return NS_ERROR_FAILURE;
++
++ if (prss)
++ *prss = 0;
++
++ for (int i = 0; i < cnt; i++) {
++ kve = &vmmap[i];
++ if (prss)
++ *prss += kve->kve_private_resident;
++ }
++
++ free(vmmap);
++ return NS_OK;
++}
++
++#define HAVE_PRIVATE_REPORTER
++static nsresult
++GetPrivate(int64_t* aN)
++{
++ int64_t priv;
++ nsresult rv = GetKinfoVmentrySelf(&priv);
++ if (NS_SUCCEEDED(rv))
++ *aN = priv * getpagesize();
++
++ return NS_OK;
++}
++#endif // FreeBSD
++
+ #elif defined(SOLARIS)
+
+ #include <procfs.h>
+@@ -327,6 +364,24 @@ static nsresult GetResidentFast(int64_t
+ }
+
+ #define HAVE_PRIVATE_REPORTER
++static nsresult
++GetPrivate(int64_t* aN)
++{
++ PROCESS_MEMORY_COUNTERS_EX pmcex;
++ pmcex.cb = sizeof(PROCESS_MEMORY_COUNTERS_EX);
++
++ if (!GetProcessMemoryInfo(
++ GetCurrentProcess(),
++ (PPROCESS_MEMORY_COUNTERS) &pmcex, sizeof(pmcex))) {
++ return NS_ERROR_FAILURE;
++ }
++
++ *aN = pmcex.PrivateUsage;
++ return NS_OK;
++}
++#endif // XP_<PLATFORM>
++
++#ifdef HAVE_PRIVATE_REPORTER
+ class PrivateReporter MOZ_FINAL : public MemoryReporterBase
+ {
+ public:
+@@ -339,21 +394,10 @@ public:
+
+ NS_IMETHOD GetAmount(int64_t *aAmount)
+ {
+- PROCESS_MEMORY_COUNTERS_EX pmcex;
+- pmcex.cb = sizeof(PROCESS_MEMORY_COUNTERS_EX);
+-
+- if (!GetProcessMemoryInfo(
+- GetCurrentProcess(),
+- (PPROCESS_MEMORY_COUNTERS) &pmcex, sizeof(pmcex))) {
+- return NS_ERROR_FAILURE;
+- }
+-
+- *aAmount = pmcex.PrivateUsage;
+- return NS_OK;
++ return GetPrivate(aAmount);
+ }
+ };
+-
+-#endif // XP_<PLATFORM>
++#endif
+
+ #ifdef HAVE_VSIZE_AND_RESIDENT_REPORTERS
+ class VsizeReporter MOZ_FINAL : public MemoryReporterBase
diff --git a/www/libxul/files/patch-bug946560 b/www/libxul/files/patch-bug946560
new file mode 100644
index 000000000000..e2560bd0d0c3
--- /dev/null
+++ b/www/libxul/files/patch-bug946560
@@ -0,0 +1,44 @@
+diff --git xpcom/base/nsMemoryInfoDumper.cpp xpcom/base/nsMemoryInfoDumper.cpp
+index 0b2f78c..d857374 100644
+--- xpcom/base/nsMemoryInfoDumper.cpp
++++ xpcom/base/nsMemoryInfoDumper.cpp
+@@ -30,7 +30,7 @@
+ #include <unistd.h>
+ #endif
+
+-#ifdef XP_LINUX
++#if defined(XP_LINUX) || defined(__FreeBSD__)
+ #include <fcntl.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+@@ -109,7 +109,7 @@ private:
+
+ } // anonymous namespace
+
+-#ifdef XP_LINUX // {
++#if defined(XP_LINUX) || defined(__FreeBSD__) // {
+ namespace {
+
+ /*
+@@ -548,7 +548,7 @@ nsMemoryInfoDumper::~nsMemoryInfoDumper(
+ /* static */ void
+ nsMemoryInfoDumper::Initialize()
+ {
+-#ifdef XP_LINUX
++#if defined(XP_LINUX) || defined(__FreeBSD__)
+ SignalPipeWatcher::Create();
+ FifoWatcher::MaybeCreate();
+ #endif
+diff --git xpcom/base/nsMemoryReporterManager.cpp xpcom/base/nsMemoryReporterManager.cpp
+index 8c65665..8f6d0e9 100644
+--- xpcom/base/nsMemoryReporterManager.cpp
++++ xpcom/base/nsMemoryReporterManager.cpp
+@@ -824,7 +824,7 @@ nsMemoryReporterManager::Init()
+ RegisterReporter(new mozilla::dmd::DMDReporter);
+ #endif
+
+-#if defined(XP_LINUX)
++#if defined(XP_LINUX) || defined(__FreeBSD__)
+ nsMemoryInfoDumper::Initialize();
+ #endif
+
diff --git a/www/libxul/files/patch-build_unix_run-mozilla.sh b/www/libxul/files/patch-build_unix_run-mozilla.sh
index aae079e55456..604f14df29d4 100644
--- a/www/libxul/files/patch-build_unix_run-mozilla.sh
+++ b/www/libxul/files/patch-build_unix_run-mozilla.sh
@@ -4,7 +4,7 @@
export MOZILLA_FIVE_HOME LD_LIBRARY_PATH
export SHLIB_PATH LIBPATH LIBRARY_PATH ADDON_PATH DYLD_LIBRARY_PATH
-+MOZ_PLUGIN_PATH=%%LOCALBASE%%/lib/browser_plugins/symlinks/gecko19:%%LOCALBASE%%/lib/npapi/symlinks/firefox
++MOZ_PLUGIN_PATH=%%LOCALBASE%%/lib/browser_plugins/symlinks/gecko:%%LOCALBASE%%/lib/browser_plugins/symlinks/firefox
+export MOZ_PLUGIN_PATH
+
if [ $moz_debug -eq 1 ]
diff --git a/www/libxul/files/patch-xulrunner-stub-nsXULStub.cpp b/www/libxul/files/patch-xulrunner-stub-nsXULStub.cpp
index 83bda6c59b89..cb0e7f7b9abd 100644
--- a/www/libxul/files/patch-xulrunner-stub-nsXULStub.cpp
+++ b/www/libxul/files/patch-xulrunner-stub-nsXULStub.cpp
@@ -4,7 +4,7 @@
char greDir[MAXPATHLEN];
bool greFound = false;
-+ setenv("MOZ_PLUGIN_PATH", "%%LOCALBASE%%/lib/browser_plugins/symlinks/gecko19:%%LOCALBASE%%/lib/npapi/symlinks/xulrunner", 0);
++ setenv("MOZ_PLUGIN_PATH", "%%LOCALBASE%%/lib/browser_plugins/symlinks/gecko", 0);
+
#if defined(XP_MACOSX)
CFBundleRef appBundle = CFBundleGetMainBundle();