aboutsummaryrefslogtreecommitdiff
path: root/www/mod_gnutls/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-02-14 04:08:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-02-14 04:08:07 +0000
commit996c7672b9173cf2fe74353c68e1842610d20dd9 (patch)
tree9147bb545af65cacc77db0b678dc96bbe8169add /www/mod_gnutls/Makefile
parent430de3a3705c8b0eb333023d6a8cc29c18bb66fd (diff)
downloadports-996c7672b9173cf2fe74353c68e1842610d20dd9.tar.gz
ports-996c7672b9173cf2fe74353c68e1842610d20dd9.zip
mod_gnutls uses the GnuTLS library to provide SSL 3.0, TLS 1.0, TLS
1.1 and 1.2 encryption for Apache HTTPD. It is similar to mod_ssl in purpose, but does not use OpenSSL. WWW: http://www.outoforder.cc/projects/apache/mod_gnutls/ PR: ports/154463 Submitted by: Fumiyuki Shimizu <fumifumi at abacustech.jp>
Notes
Notes: svn path=/head/; revision=269128
Diffstat (limited to 'www/mod_gnutls/Makefile')
-rw-r--r--www/mod_gnutls/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/www/mod_gnutls/Makefile b/www/mod_gnutls/Makefile
new file mode 100644
index 000000000000..3c03117259e0
--- /dev/null
+++ b/www/mod_gnutls/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: mod_gnutls
+# Date created: 2011-01-19
+# Whom: Fumiyuki Shimizu <fumifumi@abacustech.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_gnutls
+PORTVERSION= 0.5.6
+CATEGORIES= www security
+MASTER_SITES= http://www.outoforder.cc/downloads/mod_gnutls/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
+
+MAINTAINER= fumifumi@abacustech.jp
+COMMENT= mod_gnutls uses the GnuTLS library to provide SSL, and TLS encryption for Apache HTTPD
+
+LIB_DEPENDS= gnutls.40:${PORTSDIR}/security/gnutls
+
+USE_BZIP2= yes
+USE_AUTOTOOLS= libtool
+USE_APACHE= 2.0+
+GNU_CONFIGURE= yes
+
+LICENSE= ASL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+DOCS= LICENSE NEWS README README.ENV
+
+.include <bsd.port.pre.mk>
+
+DBDIR= ${PREFIX}/var/db/${PORTNAME}
+
+SUB_FILES= pkg-message
+PLIST_SUB+= DBDIR=${DBDIR}
+
+CONFIGURE_ARGS= --with-apxs=${APXS}
+
+# mod_gnutls does not conflict with mod_ssl.
+#pre-install:
+# @if test -e '${LOCALBASE}/${APACHEMODDIR}/mod_ssl.so'; then for opt in -a -A -A; do '${APXS}' -e "$${opt}" -n ssl '${LOCALBASE}/${APACHEMODDIR}/mod_ssl.so' >/dev/null 2>&1; done; else true; fi
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} '${DOCSDIR}'
+ @cd '${WRKSRC}' && ${INSTALL_DATA} ${DOCS} '${DOCSDIR}'
+.endif
+ @if test -d '${DBDIR}'; then true; else ${MKDIR} '${DBDIR}'; fi
+ @${CHOWN} '${WWWOWN}:${WWWGRP}' '${DBDIR}'
+ @${CHMOD} 'u=rwx,g=rx,o=' '${DBDIR}'
+ @${CAT} '${PKGMESSAGE}'
+
+.include <bsd.port.post.mk>