aboutsummaryrefslogtreecommitdiff
path: root/www/mod_php4
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2002-05-13 05:58:06 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2002-05-13 05:58:06 +0000
commitabe5274ee790c6d225f9a71d24897edb0a157fea (patch)
treea854b99b80e822661b960f06cd18db7d35119426 /www/mod_php4
parenteb68930884c277516d768a4fa4d771f37bdc372e (diff)
downloadports-abe5274ee790c6d225f9a71d24897edb0a157fea.tar.gz
ports-abe5274ee790c6d225f9a71d24897edb0a157fea.zip
Fix mkdir() bug.
PR: ports/37825 Submitted by: Jason Taylor <jason@jase.org>
Notes
Notes: svn path=/head/; revision=58995
Diffstat (limited to 'www/mod_php4')
-rw-r--r--www/mod_php4/Makefile2
-rw-r--r--www/mod_php4/files/patch-ext_standard_file.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index bae9bf9669da..874a0cb40806 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mod_php4
PORTVERSION= 4.2.0
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= www
MASTER_SITES= http://us.php.net/${PHP_DISTDIR}/ \
http://php.he.net/${PHP_DISTDIR}/ \
diff --git a/www/mod_php4/files/patch-ext_standard_file.c b/www/mod_php4/files/patch-ext_standard_file.c
new file mode 100644
index 000000000000..7077adc68f47
--- /dev/null
+++ b/www/mod_php4/files/patch-ext_standard_file.c
@@ -0,0 +1,20 @@
+--- ext/standard/file.c.orig Thu Feb 28 09:26:44 2002
++++ ext/standard/file.c Tue May 7 13:57:19 2002
+@@ -1453,7 +1453,7 @@
+ PHP_FUNCTION(mkdir)
+ {
+ int dir_len, ret;
+- mode_t mode = 0777;
++ long mode = 0777;
+ char *dir;
+
+ if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "s|l", &dir, &dir_len, &mode) == FAILURE) {
+@@ -1468,7 +1468,7 @@
+ RETURN_FALSE;
+ }
+
+- ret = VCWD_MKDIR(dir, mode);
++ ret = VCWD_MKDIR(dir, (mode_t)mode);
+ if (ret < 0) {
+ php_error(E_WARNING, "mkdir() failed (%s)", strerror(errno));
+ RETURN_FALSE;