aboutsummaryrefslogtreecommitdiff
path: root/www/mohawk/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2013-11-11 15:03:39 +0000
committerWen Heping <wen@FreeBSD.org>2013-11-11 15:03:39 +0000
commitc78f4d0a334c94b5e07ea2035b99de8ef1c110e8 (patch)
treea8ba9dcc0a9321500c68a1f12bb9d6360ac5af5e /www/mohawk/Makefile
parent28ab8672819ea02ce7c5b84e2348be7295793cc4 (diff)
downloadports-c78f4d0a334c94b5e07ea2035b99de8ef1c110e8.tar.gz
ports-c78f4d0a334c94b5e07ea2035b99de8ef1c110e8.zip
- Update to 2.0.9
- Support stage PR: 183837 Submitted by: mohawk <mohawk@bsdsx.fr> (maintainer)
Notes
Notes: svn path=/head/; revision=333509
Diffstat (limited to 'www/mohawk/Makefile')
-rw-r--r--www/mohawk/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/www/mohawk/Makefile b/www/mohawk/Makefile
index 67470c9b40ef..93c76d8f7382 100644
--- a/www/mohawk/Makefile
+++ b/www/mohawk/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= mohawk
-PORTVERSION= 2.0.8
+PORTVERSION= 2.0.9
CATEGORIES= www ipv6
MASTER_SITES= http://fossil.etoilebsd.net/mohawk/tarball/ \
http://fossil.bsdsx.fr/mohawk/tarball/
@@ -12,7 +12,7 @@ COMMENT= Simple and lightweight HTTP daemon
LICENSE= BSD
-LIB_DEPENDS= event-2.0:${PORTSDIR}/devel/libevent2
+LIB_DEPENDS= event-2:${PORTSDIR}/devel/libevent2
PLIST_FILES+= bin/mhtpasswd \
sbin/mohawk \
@@ -21,8 +21,6 @@ PLIST_FILES+= bin/mhtpasswd \
PORTEXAMPLES= *
USE_RC_SUBR= mohawk
-MANCOMPRESSED= yes
-
MAN5= mohawk.conf.5
MAN8= mhtpasswd.8 \
mohawk.8
@@ -30,15 +28,14 @@ MAN8= mhtpasswd.8 \
CFLAGS+= -I${LOCALBASE}/include/event2/compat -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib/event2
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-install:
- ${INSTALL_DATA} ${WRKSRC}/examples/minimal.conf ${PREFIX}/etc/mohawk.conf.sample
- ${INSTALL_SCRIPT} ${WRKSRC}/mhtpasswd.sh ${PREFIX}/bin/mhtpasswd
+ ${INSTALL_DATA} ${WRKSRC}/examples/minimal.conf ${STAGEDIR}${PREFIX}/etc/mohawk.conf.sample
+ ${INSTALL_SCRIPT} ${WRKSRC}/mhtpasswd.sh ${STAGEDIR}${PREFIX}/bin/mhtpasswd
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/*.conf ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.conf ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>